[SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
vishgaur
Level 3
Level 3
Posts: 122
Joined: Thu Jul 26, 2018 4:59 pm
Location: India
Contact:

[SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by vishgaur »

This is not a question but a solution itself.
I am writing this solution because I searched it a lot. I almost died searching for a solution to my problem "How to disable bluetooth at the startup on Linux Mint 19, Cinnamon, TARA" and found NO SOLUTION AT ALL ON THE WHOLE WEB.
That was pretty strange.

Solutions those did not work:
  1. Code: Select all

    sudo service bluetooth stop
  2. Code: Select all

    sudo gedit /etc/rc.local
    I had no file named rc.local in my directory and thus opening it from terminal showed an empty text file. So, adding anything to it was meaningless.
  3. Code: Select all

    sudo systemctl disable bluetooth.service
    Didn't even disable already active bluetooth that I could have done with 2 clicks right away. Useless.
  4. Code: Select all

    sudo xed /etc/bluetooth/main.conf
    Edited last line to false (default is FALSE, IDK how my default was set to TRUE. Maybe because I had tried this solution earlier and when it didn't work I forgot to change the entry to default value).
  5. Code: Select all

    rfkill block bluetooth
    It disabled my bluetooth but only once, and bluetooth again restarted on next reboot/boot. So, all it did was something again I could do with 2 simple clicks, then why to type the terminal command?
Finally, the solution that worked for me was nowhere on web. How I came to this solution? After using LM for 3 months I became quite familiar with codes and settings on Linux and started to resolve my issues myself.
One day I was trying to setup an executable command to execute on startup each and every time I start my system. So, I headed to the startup apps from start menu and created a custom command. There I got the idea that

Code: Select all

rfkill block bluetooth
was able to stop bluetooth but just once, why not create a custom command for it on startup so that each time I start my system, this command gets executed and disables bluetooth on startup.

SOLUTION:
  1. GO TO: Start Menu>>Startup Applications
  2. Click on + (Soft Button denoted by "PLUS/ADDITION/+" sign/symbol at the bottom of the "Startup Applications" window).
  3. Click on "Custom command."
  4. Add any name/description you like ( I named DISABLE BLUETOOTH, name and description doesn't matter, what matters is the command)
  5. Add Command as:

    Code: Select all

    rfkill block bluetooth
You can test it by selecting the new entry you made in startup applications menu and executing it manually by clicking on gear icon and then on every reboot the command will execute by itself and bluetooth will get disabled after reboot.

Hope it helps someone who is already frustrated by the non-working solutions.
Writing doesn't earn me money, but it provides satisfaction that money can't provide.

Image

ArisBos
Level 1
Level 1
Posts: 1
Joined: Wed Nov 28, 2018 9:45 am

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by ArisBos »

Great!! I searched long on the internet, until I found your solution. Many thanks!

anywayitgoeson
Level 1
Level 1
Posts: 1
Joined: Sun Dec 16, 2018 10:41 am

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by anywayitgoeson »

Cheers for the solution. I was getting really frustrated by all those ...pseudo solutions until I came across your solution. Simple!

Luontokoodaus
Level 1
Level 1
Posts: 1
Joined: Sun Feb 03, 2019 11:13 am

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by Luontokoodaus »

Registered just to say thanks a lot for posting!

User avatar
Sir Charles
Level 7
Level 7
Posts: 1897
Joined: Thu Jan 04, 2018 1:00 pm

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by Sir Charles »

vishgaur wrote:
Wed Sep 05, 2018 10:08 am

Code: Select all

sudo systemctl disable bluetooth.service
Didn't even disable already active bluetooth that I could have done with 2 clicks right away. Useless.

Code: Select all

sudo systemctl disable --now bluetooth.service
would have done it.

For an "stronger disablement":

Code: Select all

sudo systemctl mask --now bluetooth.service
disable NAME...
Disables one or more units. This removes all symlinks to the unit
files backing the specified units from the unit configuration
directory, and hence undoes any changes made by enable or link.

--now
When used with enable, the units will also be started. When used
with disable or mask, the units will also be stopped. The start or
stop operation is only carried out when the respective enable or
disable operation has been successful.


mask NAME...
Mask one or more units, as specified on the command line. This will
link these unit files to /dev/null, making it impossible to start
them. This is a stronger version of disable, since it prohibits all
kinds of activation of the unit, including enablement and manual
activation
. Use this option with care. This honors the --runtime
option to only mask temporarily until the next reboot of the
system. The --now option may be used to ensure that the units are
also stopped. This command expects valid unit names only, it does
not accept unit file paths.

unmask NAME...
Unmask one or more unit files, as specified on the command line.
This will undo the effect of mask. This command expects valid unit
names only, it does not accept unit file paths.

from: man sytsemctl
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

User avatar
Zhu Jia You
Level 1
Level 1
Posts: 5
Joined: Wed Jun 26, 2019 6:22 am

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by Zhu Jia You »

Code: Select all

sudo apt remove --purge blueberry
sudo apt install blueman
System settings ==> Preferences ==> Startup Applications ==> Blueman Applet ==> TURN OFF IT

This works for me on Linux Mint 19.2 Cinnamon

User avatar
Monsieurzik
Level 1
Level 1
Posts: 13
Joined: Wed Sep 24, 2008 3:55 pm

Re: [SOLVED] Disable bluetooth at startup on Linux Mint 19 Cinnamon.

Post by Monsieurzik »

To get the tip.
LMDE 3 - Mate 1.20

Post Reply

Return to “Software & Applications”