Page 1 of 1


Posted: Wed Sep 19, 2018 11:09 am
by johnlannon
Is there a version of python-pgpme that works on Mint 19. I have python-pgpme .0.3.tar.gz . Is this compatible with python 2.7.15rc1. Trying to install dropbox. I don't want to break anything. I notice it is no longer in package manager like it was in earlier mint versions. Do I need a sandbox for python, so I can run multiple versions of python? Thank you for the help

Re: Python-pgpme

Posted: Wed Sep 19, 2018 12:13 pm
by phd21
Hi johnlannon,

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Linux Mint 19 is based on Ubuntu 18.04 Bionic

Install DropBox on Ubuntu 18.04 LTS Desktop | Website for Students ... s-desktop/

How to install and integrate Dropbox with Ubuntu 18.04 Bionic Beaver Desktop - ... er-desktop

How to Install Dropbox on Ubuntu 18.04 (Terminal/GUI) ... ox-ubuntu/

How to Install Dropbox on Ubuntu 18.04 & 16.04 - TecAdmin

Hope this helps ...

Re: Python-pgpme

Posted: Wed Sep 19, 2018 4:38 pm
by johnlannon
I already checked some of those links. They are only directions to install dropbox (in software manager too). This is to fix the error on launch of dropbox. It says roughly "python-pgpme is not installed". It is used for sync. It wont work without it. I'm pretty sure in 18 sudo apt-get install python-pgpme is all that is needed. 19 gives me this: "E: Package 'python-gpgme' has no installation candidate."

Also tried pip install python-pgpme get this "Collecting python-pgpme
Could not find a version that satisfies the requirement python-pgpme (from versions: )
No matching distribution found for python-pgpme"

If I run make on the pgpme.tar.gz extracted file, will it just fail if incompatible or, will it break the OS. It's a pain to reinstall Mint on UEFI. To bad fix-boot isn't included in the live OS. I'm told, don't change python version, it breaks the OS. So a python sandbox may be the only solution.

Not sure this will help as this is a python issue.

System: Host: Asus Kernel: 4.15.0-34-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: ASUSTeK product: K52F v: 1.0 serial: N/A
Mobo: ASUSTeK model: K52F v: 1.0 serial: N/A
UEFI: American Megatrends v: K52F.218 date: 07/12/2011
Battery BAT0: charge: 2.4 Wh 99.2% condition: 2.4/48.4 Wh (5%)
model: ASUSTek K52F-44 status: Full
CPU: Dual core Intel Core i3 M 370 (-MT-MCP-)
arch: Nehalem rev.5 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9575
clock speeds: max: 2399 MHz 1: 1200 MHz 2: 1199 MHz 3: 1167 MHz
4: 1097 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1680x1050@59.88hz
OpenGL: renderer: Mesa DRI Intel Ironlake Mobile
version: 2.1 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel 5 Series/3400 Series High Def. Audio
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network: Card-1: Intel Centrino Advanced-N + WiMAX 6250 [Kilmer Peak]
driver: iwlwifi bus-ID: 02:00.0
IF: wls1 state: down mac: <filter>
Card-2: JMicron JMC250 PCIE Gigabit Ethernet Controller
driver: jme v: 1.0.8 ports: a100 a000 bus-ID: 04:00.5
IF: ens5f5 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 500.1GB (11.9% used)
ID-1: /dev/sda model: ST9500325AS size: 500.1GB
Optical-1: /dev/sr0 model: HL-DT-ST DVDRAM GT32N
rev: AS01 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 24x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 457G used: 56G (13%) fs: ext4 dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 54.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 222 Uptime: 19 min Memory: 1960.9/3745.1MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56