Steam won't launch in Mint Cinnamon 18.3 (steamui.so)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
DJ_Explosive
Level 1
Level 1
Posts: 9
Joined: Fri Jan 26, 2018 9:12 am
Contact:

Steam won't launch in Mint Cinnamon 18.3 (steamui.so)

Post by DJ_Explosive » Thu Sep 20, 2018 5:57 pm

$inxi -Fxz

Code: Select all

System:    Host: CoolSkeleton95 Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 5567
           Mobo: Dell model: 0DG5G3 v: A00
           Bios: Dell v: 1.2.4 date: 04/02/2018
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 3099 MHz 2: 3099 MHz 3: 3099 MHz
           4: 3099 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: llvmpipe (LLVM 6.0, 256 bits)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (16.9% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB temp: 38C
Partition: ID-1: / size: 727G used: 150G (22%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 8.48GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 67.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 218 Uptime: 2:04 Memory: 3490.6/7880.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
I am unable to get Steam to launch in Mint, and consistently get the same error saying that steamui.so is missing. Things I've tried:

Installing Steam manually, in software manager, and from .deb

Purging Steam and restarting 18k times

ALL of the following commands:

Code: Select all

sudo apt install libgl1-mesa-dri

sudo apt-get install libgl1-mesa-glx

sudo apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

sudo dpkg --add-architecture i386

sudo nano /etc/ld.so.conf.d/steam.conf (with these lines added)
/usr/lib32
usr/lib/i386-linux-gnu/mesa
Followed by: sudo ldconfig

sudo apt-get install libxtst6:i386

sudo apt-get install libgtk2.0-0:i386

sudo apt-get install libgdk-pixbuf2.0-0:i386
If anyone has a way to get this godawful client to work I would appreciate it.

Post Reply

Return to “Software & Applications”