Japanese entry keyboard

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Japanese entry keyboard

Post by hinmingai666 » Sat Sep 29, 2018 11:16 pm

Hello I am Fabricio here .....

I solved the other problems I posted about just booting with pendrive now its all normal its saving im on my user logged in into mint
Now the problem is , I download every japanese packet , language packet I had set it on keyboard layout it was appearing in the taskbar I managed to put the japanese flag but it is not showing output in japanese when I type , I need support cause im japanese studente to make it work
The only thing I saw was to set the entire environment japanese I don't have this ammount of skill in the language to use my entire system in japanese it could be a point of no return for me , so anyway , I need help to type . thank you

User avatar
snowflake
Level 2
Level 2
Posts: 62
Joined: Tue Jul 03, 2018 12:52 pm

Re: Japanese entry keyboard

Post by snowflake » Sun Sep 30, 2018 3:48 am

Hi

I assume you have already installed Japanese language support if not: you can install new language support via Settings=>input method tab=>Language support=> Japanese install

All you have to do now is choose Fcitx or iBus (its right there at input method option) & logout re-log, select it in language tray, you can now type in japanese.

If not:
if you used Ibus, go to iBus Preferences=>Add=>look for Japanese=>select Mozc, relog
now click the language tray icon & select "Japanese-Mozc", now click the language tray icon again, select input mode, to type "hiragana" or "katakana";just tick it.
go ahead & test it.

If you went with Fcitx, go to Fcitx configuration=>click the "+" icon at the bottom left=>untick "only show current.." look for jap..=>select Mozc, now make it first in the list if you want it to be the default language, or just select it from the tray icon, that's it you're done.

Ps: even in Japan people don't type directly in japanese, they use the romaji keys, say you want to type "ま” you press m, an "m" gets typed in, then you press "a", & bamm you got yourself a "ま", so when you're testing try vowels..

  Good luck

Beerislife
Level 3
Level 3
Posts: 134
Joined: Fri Jun 12, 2009 3:45 am
Location: In a cardboard box

Re: Japanese entry keyboard

Post by Beerislife » Sun Sep 30, 2018 5:48 am

fcitx is the default Japanese language input method for Mint (fcitx-mozc) but I've never had much luck with it or ibus-mozc, I usually install ibus-anthy, it just works out of the box on my machines, even though it's old. I have my personal machine (KDE Neon) with English as the primary language and ibus-anthy installed for when I need to type Japanese and a Japanese keyboard PC (Mint 19 Cinnamon) with the same input method.

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Sun Sep 30, 2018 8:56 am

Thank you very much I did everything and on uput method config I selected japanese kana , there is kana 86 , dvorak , pc98 , suntype 6 , 7 for pc and sun , theres pc 98 .......
now with kana selected it is exiting as katakana , foreigner japanese words alphabet .
What I do to switch between kana Kanji , Hiragana and Katakana ?

User avatar
snowflake
Level 2
Level 2
Posts: 62
Joined: Tue Jul 03, 2018 12:52 pm

Re: Japanese entry keyboard

Post by snowflake » Sun Sep 30, 2018 11:23 am

hinmingai666 wrote:
Sun Sep 30, 2018 8:56 am
Thank you very much I did everything and on uput method config I selected japanese kana , there is kana 86 , dvorak , pc98 , suntype 6 , 7 for pc and sun , theres pc 98 .......
now with kana selected it is exiting as katakana , foreigner japanese words alphabet .
What I do to switch between kana Kanji , Hiragana and Katakana ?
It looks like you're describing keyboard-properties, & I think you aren't using Fcitx or iBus, you have to pick one, install it (or make sure its installed), then select it in "input method", log out and log in again
Image
to check Ibus open terminal &

Code: Select all

ibus-setup
to check fcitx open terminal & run

Code: Select all

fcitx-configtool
even if one is installed, & configured you must select it as the input method system.
I'm sure at-least one of them is included in the language support package you installed

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Sun Sep 30, 2018 1:13 pm

Hi
Terminal ->
Command 'fcitix-configtool' not found, did you mean:

command 'fcitx-configtool' from deb fcitx-bin

in some degree of configuring it all I selected fcitx but theres the other option u mentioned to chose to , the following returned this error on terminal I just pasted it here ...
Again , theres a small keyboard on the taskbar on the right , I select the japanese on this little keyboard with arrow up instead of portuguese my original language and it output as KATAKANA , the foreign words alphabet , I would like to know the shortcut or method to switch between hiragana/kanji/katakana whenever it is need
thank you for the attention you guys are great

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Mon Oct 01, 2018 8:04 pm

hi?

User avatar
snowflake
Level 2
Level 2
Posts: 62
Joined: Tue Jul 03, 2018 12:52 pm

Re: Japanese entry keyboard

Post by snowflake » Tue Oct 02, 2018 5:20 am

hey there, sorry that this isnt working, don't get frustrated
hinmingai666 wrote:
Sun Sep 30, 2018 1:13 pm
Again , theres a small keyboard on the taskbar on the right , I select the japanese on this little keyboard with arrow...
until you have selected an input system capable of producing hiragana & kanji, that's irrelevant, in fact you should remove Japanese from there.lets start over:

1- Open menu & find "Input Method":Image
2- Install Japanese language support:Image
3- when you're done, select a proper input method:Image
--Tell us what options you see when you click here : Image


log out, then log in again

Again, if for some reason you're facing problems doing the steps above, don't bother with the tray icon, that comes after.
Last edited by snowflake on Thu Oct 04, 2018 12:48 pm, edited 1 time in total.

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Thu Oct 04, 2018 12:11 pm

https://uploaddeimagens.com.br/imagens/ ... 6a6f661821

So when I select the japanese the brazilian flag just won't come out

Its configured to ibus input method see
https://uploaddeimagens.com.br/imagens/teclado2-png

these are the japanese keyboards available ...

https://uploaddeimagens.com.br/imagens/teclado3-png

I selected "japanese"

https://uploaddeimagens.com.br/imagens/teclados4-png

the inputs

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Thu Oct 04, 2018 12:21 pm

http://uploaddeimagens.com.br/imagens/teclado6-png

I think it worked !!! >D with mozc
i rebooted

hinmingai666
Level 1
Level 1
Posts: 11
Joined: Thu Sep 27, 2018 7:47 pm

Re: Japanese entry keyboard

Post by hinmingai666 » Thu Oct 04, 2018 12:23 pm

有難うございます
arigatou gozaimasu

User avatar
snowflake
Level 2
Level 2
Posts: 62
Joined: Tue Jul 03, 2018 12:52 pm

Re: Japanese entry keyboard

Post by snowflake » Fri Oct 05, 2018 7:32 am

awesome, Please edit your first post to mark the topic as [solved]

Post Reply

Return to “Software & Applications”