HOw to install Postgress9.5 in Mint 19 With Base Ubuntu 18.04

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
sasPier
Level 1
Level 1
Posts: 1
Joined: Sun Oct 07, 2018 5:02 pm

HOw to install Postgress9.5 in Mint 19 With Base Ubuntu 18.04

Post by sasPier » Sun Oct 07, 2018 5:21 pm

Hello
i am Ruby Developer
I wont to Develope Ruby BUt i have to install specific Versions of Softwares Such as postgress
i wont to install postgress 9.5
I havet problem in installing postgress
My problem is installing one part of postgress
sudo apt-get install postgresql-contrib
BUt my result is bellow message

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
postgresql-contrib : Depends: postgresql-contrib-10
E: Unable to correct problems, you have held broken packages.


But When i try to install the Following module postgresql-contrib-10 By bellow Command
sudo apt-get install postgresql-contrib-10
And This My result:
---------------------------------------------------------------------------------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'postgresql-10' instead of 'postgresql-contrib-10'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
postgresql-10 : Depends: libicu55 (>= 55.1-1~) but it is not installable
E: Unable to correct problems, you have held broken packages.
---------------------------------------------------------
means my package Depends on libicu55 and this is not installable
please help Me thanks

sreeju
Level 1
Level 1
Posts: 1
Joined: Sat Jan 05, 2019 3:16 pm

Re: HOw to install Postgress9.5 in Mint 19 With Base Ubuntu 18.04

Post by sreeju » Sat Jan 05, 2019 4:27 pm

I am getting the same error

Postgresql-11 : Depends: libicu55 (>= 55.1-1~) but it is not installable

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: HOw to install Postgress9.5 in Mint 19 With Base Ubuntu 18.04

Post by killer de bug » Sat Jan 05, 2019 4:31 pm

yes libicu55 is not in the repositories.
It may have been available in the repo of Ubuntu 16.04. Maybe you should check if that was the case and if you could install it manually.
If it ain't broke, fix it until it is.

Post Reply

Return to “Software & Applications”