Shutter icon disappear and the reappear in panel

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
overkill22
Level 4
Level 4
Posts: 390
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Shutter icon disappear and the reappear in panel

Post by overkill22 » Sat Oct 13, 2018 9:33 am

When I close Shutter I usually get the icon in the panel. You can activate this option in Preferences > Behavior > Minimize to tray when closing main window.
I don't know when it happened, but now, when I close shutter, the instance is still open, but the icon is missing from the panel.
The curious thing is that if I put the panel in edit mode, the icon reappear. When I exit the edit mode, the icon remain there as normal.
It's like the panel doesn't refresh when I close Shutter but only when I on/off the edit mode, or I have the auto hide option on.
I don't think is the `WARNING: Gtk2::AppIndicator is missing --> there will be no icon showing up in the status bar when running Unity!`

Any idea what could it be?

User avatar
trytip
Level 8
Level 8
Posts: 2396
Joined: Tue Jul 05, 2016 1:20 pm

Re: Shutter icon disappear and the reappear in panel

Post by trytip » Sat Oct 13, 2018 10:24 am

do you have these installed?

Code: Select all

libappindicator3
gir1.2-appindicator3
Image

User avatar
overkill22
Level 4
Level 4
Posts: 390
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Shutter icon disappear and the reappear in panel

Post by overkill22 » Sat Oct 13, 2018 10:31 am

trytip wrote:
Sat Oct 13, 2018 10:24 am
do you have these installed?

Code: Select all

libappindicator3
gir1.2-appindicator3
yes. As I said, the icon appear but only after "refreshing" the panel... :/

User avatar
trytip
Level 8
Level 8
Posts: 2396
Joined: Tue Jul 05, 2016 1:20 pm

Re: Shutter icon disappear and the reappear in panel

Post by trytip » Sat Oct 13, 2018 12:08 pm

i'm out of ideas. i see my shutter icon appear but a split second after the application opens. Cinnamon is too confusing for me why i switched to XFCE. my Audacious GTK and QT application doesn't show the tray icon in Cinnamon but will in XFCE

is your shutter giving you any more errors when running in Terminal? first fix it so all errors are gone. if the icon is still acting up it's not a Shutter issue but Cinnamon panel issue which i really have no clue
Image

JosephM
Level 6
Level 6
Posts: 1079
Joined: Sun May 26, 2013 6:25 pm

Re: Shutter icon disappear and the reappear in panel

Post by JosephM » Sat Oct 13, 2018 2:47 pm

Do you by chance have support for indicators enabled in System settings->General? If you do, try turning it off. I use shutter all the time and I've not seen the issue.
When I give opinions, they are my own. Not necessarily those of any other Linux Mint developer or the Linux Mint project as a whole.

User avatar
overkill22
Level 4
Level 4
Posts: 390
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Shutter icon disappear and the reappear in panel

Post by overkill22 » Mon Oct 15, 2018 12:08 am

trytip wrote:
Sat Oct 13, 2018 12:08 pm
i'm out of ideas. i see my shutter icon appear but a split second after the application opens. Cinnamon is too confusing for me why i switched to XFCE. my Audacious GTK and QT application doesn't show the tray icon in Cinnamon but will in XFCE

is your shutter giving you any more errors when running in Terminal? first fix it so all errors are gone. if the icon is still acting up it's not a Shutter issue but Cinnamon panel issue which i really have no clue
I don't see any other error.
JosephM wrote:
Sat Oct 13, 2018 2:47 pm
Do you by chance have support for indicators enabled in System settings->General? If you do, try turning it off. I use shutter all the time and I've not seen the issue.


It was disabled.

:roll:

User avatar
smurphos
Level 8
Level 8
Posts: 2018
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Shutter icon disappear and the reappear in panel

Post by smurphos » Mon Oct 15, 2018 12:31 am

overkill22 wrote:
Mon Oct 15, 2018 12:08 am
It was disabled.

:roll:
Have you fixed your menu issue yet from - viewtopic.php?p=1539090#p1538200

Just a hunch that some of these issues might be related....

User avatar
overkill22
Level 4
Level 4
Posts: 390
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Shutter icon disappear and the reappear in panel

Post by overkill22 » Mon Oct 15, 2018 1:13 am

smurphos wrote:
Mon Oct 15, 2018 12:31 am
overkill22 wrote:
Mon Oct 15, 2018 12:08 am
It was disabled.

:roll:
Have you fixed your menu issue yet from - viewtopic.php?p=1539090#p1538200

Just a hunch that some of these issues might be related....
used the code but didn't fix either issue. I answered in the other topic .

Post Reply

Return to “Software & Applications”