synaptic terminal ignores font settting; also set background? {SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Flemur
Level 16
Level 16
Posts: 6489
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

synaptic terminal ignores font settting; also set background? {SOLVED]

Post by Flemur » Sat Oct 13, 2018 11:19 am

Solution to bad font (not monospace) in synaptic terminal:

When "monospace" font (alias) is not set, "fc-match" returns a bogus value (Ubuntu font, IIRC) which makes it look like monospace is set. But then synaptic uses some weird non-monospace font and the characters overlap each other.

I defined "monospace" to "Cousine" following the good instructions here:
https://jichu4n.com/posts/how-to-set-de ... -on-linux/
and also set the custom terminal font in synaptic to "Cousine" - now it looks great!

I think it might also have something to do with using a font with a space in the name, e.g. "liberation mono" - didn't work.

+++++ END OF SOLUTION ++++++++++++++++++

Hi, Mint 18.3, synaptic 0.83

When I set synaptic's "terminal" font, the setting is ignored; I get the same result whether I run "logged in" as root (sudo -i) or with "gksudo".

The font I defined is listed in the preferences GUI when synaptic is restarted and the file
/root/.synaptic/synaptic.conf
contains the proper setting:

Code: Select all

TerminalFontName "Liberation Mono Bold 12";
but I see a serif-font.

Also: is there a way to make the synaptic terminal be black text on a white background?

TIA!
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Manjaro openbox/fluxbox/pulse-less
Lubuntu LXDE/fluxbox/pulse-less

User avatar
Flemur
Level 16
Level 16
Posts: 6489
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: synaptic terminal ignores font settting; also set background? [SOLVED]

Post by Flemur » Tue Nov 20, 2018 11:01 am

Solution to bad font (not monospace) in synaptic terminal:

When "monospace" font (alias) is not set, "fc-match" returns a bogus value (Ubuntu font, IIRC) which makes it look like monospace is set. But then synaptic uses some weird non-monospace font and the characters overlap each other.

I defined "monospace" to "Cousine" following the good instructions here:
https://jichu4n.com/posts/how-to-set-de ... -on-linux/
and also set the custom terminal font in synaptic to "Cousine" - now it looks great!

I think it might also have something to do with using a font with a space in the name, e.g. "liberation mono" - didn't work.

+++++ END OF SOLUTION ++++++++++++++++++
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Manjaro openbox/fluxbox/pulse-less
Lubuntu LXDE/fluxbox/pulse-less

Post Reply

Return to “Software & Applications”