Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sat Jun 20, 2009 10:25 am


Postby simonced » Sat Jun 20, 2009 10:30 am


I just installed Linuxmint (linux user for about 10 years).
But I encounter a problem I have never seen !
When loging, Mint asked me if I wanted a root account, I said no, I'm fine with the sudo way.
But then, my profile (a separate partition coming from another system) wich had other permissoins didn't allow mint to write some data, and I'm not in the sudoers list !

I can do nothing requirering admin rights ! I have live cds arround, but I can't do nothing from mint has admin.
Even the recovery mode > root shell doesn't work.

Thank you for your help.

Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm


Postby emorrp1 » Sat Jun 20, 2009 11:49 am

Hello, and Welcome to Linux Mint. That is certainly strange, but I have a feeling it's related to the "profile from another system". How did you do this? Can you detail the User configuration steps you took after install? The user you create on install is the only one to be given sudo rights. However if you try and simply copy the dirs from another system which uses a different UID, then you either have to recursively change the dir's id to your new user, or change your users uid. Now the thing is, you can't change your users id without a root account, as you'd have to login to use sudo, but the way around it is to create a new user with that uid, then delete the old one and if you delete the old one before adding the new one to sudoers, then you'd be in the situation you're in at the moment. If the recovery mode doesn't put you in root automatically, you may be able to recover by adding your user to the sudoers file using a liveCD. To be honest though, mint takes so little time to install, I'd just try again and be more careful when messing with the user config. Oh, also mint 7 Gloria is out, which has many improvements over felicia that you're using.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

Return to “Software & Applications”

Who is online

Users browsing this forum: Google [Bot] and 4 guests