URLs aren't passed on to Waterfox

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

URLs aren't passed on to Waterfox

Post by Moem »

Waterfox is set as default browser both in Preferred Applications and from inside Waterfox itself. Every time some application (pretty much any and all applications with the exception of Thunderbird and Pidgin, which do work) wants to open a website, it does manage to open Waterfox. But the URL is not correctly passed along, and so I just get an empty window which doesn't really help. I wish I knew how to remedy this.

Any ideas would be appreciated. Thank you in advance!

Code: Select all

System:    Host: moem-ThinkPad-X201 Kernel: 4.15.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 36805B8 v: ThinkPad X201
           Mobo: LENOVO model: 36805B8
           Bios: LENOVO v: 6QET61WW (1.31 ) date: 10/26/2010
CPU:       Dual core Intel Core i5 M 560 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10640
           clock speeds: max: 2667 MHz 1: 1337 MHz 2: 1397 MHz 3: 1443 MHz
           4: 1531 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile
           GLX Version: 2.1 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card-1: Intel 82577LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 1820 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6200
           driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 240.1GB (61.1% used)
           ID-1: /dev/sda model: INTEL_SSDSC2BW24 size: 240.1GB
Partition: ID-1: / size: 31G used: 15G (49%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 157G used: 119G (80%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 4.08GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: 3454
Info:      Processes: 240 Uptime: 3:25 Memory: 3893.2/7773.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Sounds like a bug with Waterfox. What happens if you try it manually?

Code: Select all

waterfox google.com
(I never used Waterfox, you may have to replace waterfox with the actual command to run it)
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

If I do

Code: Select all

waterfox/waterfox startpage.com
... it works just fine. But I'm not sure how to get the correct command into 'preferred applications'.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

So it's not listed in Preferred Applications? That's easy to fix for browsers. If you have another browser installed, go to Preferred Applications, set the browser to the other browser. Launch Waterfox. Either wait for it to ask to be made default browser or go to Preferences and click the button to make it the default yourself.

It should be listed as the default applications after that. To confirm:

Code: Select all

xdg-settings get default-web-browser
and this should open correctly:

Code: Select all

xdg-open https://startpage.com
Otherwise please post output of

Code: Select all

cat ~/.config/mimeapps.list
or just check it yourself, for a default browser definition there should be something like

Code: Select all

x-scheme-handler/http=waterfox.desktop
x-scheme-handler/https=waterfox.desktop
x-scheme-handler/ftp=waterfox.desktop
x-scheme-handler/chrome=waterfox.desktop
text/html=waterfox.desktop
application/x-extension-htm=waterfox.desktop
application/x-extension-html=waterfox.desktop
application/x-extension-shtml=waterfox.desktop
application/xhtml+xml=waterfox.desktop
application/x-extension-xhtml=waterfox.desktop
application/x-extension-xht=waterfox.desktop
The launcher's command line should end in %U.
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

gm10 wrote:
Wed Oct 24, 2018 9:16 am
So it's not listed in Preferred Applications?
It is, but apparently not in the correct way. It's probably not installed where it should be. It seems the system does not completely know it's there.
gm10 wrote:
Wed Oct 24, 2018 9:16 am
That's easy to fix for browsers. If you have another browser installed, go to Preferred Applications, set the browser to the other browser. Launch Waterfox. Either wait for it to ask to be made default browser or go to Preferences and click the button to make it the default yourself.
preferredapplications.png
gm10 wrote:
Wed Oct 24, 2018 9:16 am
It should be listed as the default applications after that. To confirm:

Code: Select all

xdg-settings get default-web-browser
and this should open correctly:

Code: Select all

xdg-open https://startpage.com

Code: Select all

moem@moem-ThinkPad-X201 ~ $ xdg-settings get default-web-browser
alacarte-made-8f499fd6-d8f3-11e7-a03c-183da205a2bc.desktop
moem@moem-ThinkPad-X201 ~ $ 
And there's the empty page again.
gm10 wrote:
Wed Oct 24, 2018 9:16 am
Otherwise please post output of

Code: Select all

cat ~/.config/mimeapps.list
I bet you can guess what that looks like, based on the previous result.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

gm10 wrote:
Wed Oct 24, 2018 9:16 am
The launcher's command line should end in %U.
Making this change in the menu entry for Waterfox fixed it partially!

Code: Select all

xdg-open https://startpage.com
works now; trying to open the Dropbox page from the panel icon still gives me an empty page.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 9:52 am
gm10 wrote:
Wed Oct 24, 2018 9:16 am
The launcher's command line should end in %U.
Making this change in the menu entry for Waterfox fixed it partially!

Code: Select all

xdg-open https://startpage.com
works now; trying to open the Dropbox page from the panel icon still gives me an empty page.
You may have to update or re-create the panel icon as well.
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

How? Oh wait, you mean for Waterfox? There isn't one. I meant the Dropbox panel icon.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 9:57 am
How?
Don't ask me about things Cinnamon, in MATE I just right click it. As far as I recall in Cinnamon you need to enter edit mode first, by right clicking the menu button, was it?
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

(Edited above.)
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 10:00 am
(Edited above.)
Same answer. Check the command line of that launcher. I don't use Dropbox so I don't know what it looks like.
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

It's not a launcher, it's a panel icon and I have no idea how to check its command line, if it even has one. Nevertheless, the problem is mostly solved so that's pretty good.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 10:09 am
It's not a launcher, it's a panel icon and I have no idea how to check its command line, if it even has one. Nevertheless, the problem is mostly solved so that's pretty good.
Panel icons are launchers, too. And I just checked in a VM because your statement surprised me: You can also just right-click them in Cinnamon. Select Edit and check the command line.
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

There is no 'edit'. Right- or leftclicking both gives me:

Code: Select all

Open Dropbox Folder
Launch Dropbox Website
Recently Changed Files >
----------------------------
(greyed out) 0.0% of 2.2 GB used
----------------------------
Get More Space
----------------------------
(greyed out) Up to date
Pause Synching
----------------------------
Preferences...
Help Center
----------------------------
Quit Dropbox
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Oh, you mean a notification area icon. Sorry, I thought you meant a panel launcher.

Have you tried simply re-logging for this one? Might be it picks up the configuration on launch and then sticks with it rather than use the xdg calls.
HaveaMint
Level 5
Level 5
Posts: 747
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: URLs aren't passed on to Waterfox

Post by HaveaMint »

Moem wrote:
Wed Oct 24, 2018 10:09 am
It's not a launcher, it's a panel icon and I have no idea how to check its command line, if it even has one. Nevertheless, the problem is mostly solved so that's pretty good.

Code: Select all

dropbox start -i
"Tune for maximum Smoke and then read the Instructions".
User avatar
kukamuumuka
Level 16
Level 16
Posts: 6699
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: URLs aren't passed on to Waterfox

Post by kukamuumuka »

Via Terminal

Code: Select all

gvfs-mime --set x-scheme-handler/http waterfox.desktop
gvfs-mime --set x-scheme-handler/https waterfox.desktop
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

administrollaattori wrote:
Wed Oct 24, 2018 11:05 am
Via Terminal

Code: Select all

gvfs-mime --set x-scheme-handler/http waterfox.desktop
gvfs-mime --set x-scheme-handler/https waterfox.desktop

Code: Select all

Failed to load info for handler 'waterfox.desktop'
Failed to load info for handler 'waterfox.desktop'
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

HaveaMint wrote:
Wed Oct 24, 2018 10:51 am
Moem wrote:
Wed Oct 24, 2018 10:09 am
It's not a launcher, it's a panel icon and I have no idea how to check its command line, if it even has one. Nevertheless, the problem is mostly solved so that's pretty good.

Code: Select all

dropbox start -i

Code: Select all

The program 'dropbox' is currently not installed. You can install it by typing:
sudo apt install nautilus-dropbox
(I believe I'm using the Flatpak version.)

I don't think this has anything to do with Waterfox, by the way.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
Moem
Level 20
Level 20
Posts: 11418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

gm10 wrote:
Wed Oct 24, 2018 10:37 am
Oh, you mean a notification area icon. Sorry, I thought you meant a panel launcher.
Well, I figured that was what you thought I meant, yeah. :)
gm10 wrote:
Wed Oct 24, 2018 10:37 am
Have you tried simply re-logging for this one? Might be it picks up the configuration on launch and then sticks with it rather than use the xdg calls.
You mean, logging out and back in? I'll do you one better: I'll restart.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
Post Reply

Return to “Software & Applications”