URLs aren't passed on to Waterfox

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Moem
Level 20
Level 20
Posts: 11413
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

Restarted, and Dropbox still doesn't know where to find Waterfox:
openwith.png
No option to browse. I can open a larger list below, and then choose 'Browser:Waterfox'. Waterfox then tries to open "file:///tmp/dbxlqa5tqc3a.html" and it fails: File not found
Waterfox can’t find the file at /tmp/dbxlqa5tqc3a.html.

Do I choose a different browser, then I just get redirected to the Dropbox site as should happen.

As problems go, this is a pretty minor one and we could leave it as it is now.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Did you try opening that file manually from the command line? Maybe the file:// protocol is blocked in Waterfox.

Another idea is that you've got multiple launchers configured and one of them is still misconfigured but being used by Dropbox:

Code: Select all

grep waterfox -lR ~/.local/share/applications

User avatar
Moem
Level 20
Level 20
Posts: 11413
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

Code: Select all

moem@moem-ThinkPad-X201 ~ $ grep waterfox -lR ~/.local/share/applications
/home/moem/.local/share/applications/userapp-Waterfox-WLV2AZ.desktop
/home/moem/.local/share/applications/alacarte-made-8f499fd6-d8f3-11e7-a03c-183da205a2bc.desktop
I retried the Dropbox icon again, got SeaMonkey and Firefox, clicked for more... clicked Waterfox again... and shiver me timbers, this time it worked. Progress!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6699
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: URLs aren't passed on to Waterfox

Post by kukamuumuka »

Moem wrote:
Wed Oct 24, 2018 11:33 am

Code: Select all

Failed to load info for handler 'waterfox.desktop'
Failed to load info for handler 'waterfox.desktop'
Strange. Is Waterfox installed from deb package or tar.gz file?

gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 12:51 pm

Code: Select all

moem@moem-ThinkPad-X201 ~ $ grep waterfox -lR ~/.local/share/applications
/home/moem/.local/share/applications/userapp-Waterfox-WLV2AZ.desktop
/home/moem/.local/share/applications/alacarte-made-8f499fd6-d8f3-11e7-a03c-183da205a2bc.desktop
I retried the Dropbox icon again, got SeaMonkey and Firefox, clicked for more... clicked Waterfox again... and shiver me timers, this time it worked. Progress!
Wasn't me. But in keeping with my theory, check the command lines in the second launcher. Actually I could just have given you the command like this:

Code: Select all

grep Exec $(grep waterfox -lR ~/.local/share/applications)
My guess is /home/moem/.local/share/applications/userapp-Waterfox-WLV2AZ.desktop is missing the %U at the end as well, so add it.
Last edited by gm10 on Wed Oct 24, 2018 12:58 pm, edited 1 time in total.

gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

administrollaattori wrote:
Wed Oct 24, 2018 12:55 pm
Strange. Is Waterfox installed from deb package or tar.gz file?
Clearly not from .deb. Also did you read the thread? It's correctly configured as default browser, the problem was with the launcher and we already solved it. The remaining issue is only with dropbox.

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6699
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: URLs aren't passed on to Waterfox

Post by kukamuumuka »

gm10 wrote:
Wed Oct 24, 2018 12:57 pm
administrollaattori wrote:
Wed Oct 24, 2018 12:55 pm
Strange. Is Waterfox installed from deb package or tar.gz file?
Clearly not from .deb. Also did you read the thread? It's correctly configured as default browser, the problem was with the launcher and we already solved it. The remaining issue is only with dropbox.
Yes. I installed from deb package, and the results are:
Command:

Code: Select all

gvfs-mime --set x-scheme-handler/http waterfox.desktop
Result:

Code: Select all

Set waterfox.desktop as the default for x-scheme-handler/http
Command:

Code: Select all

gvfs-mime --set x-scheme-handler/https waterfox.desktop
Result:

Code: Select all

Set waterfox.desktop as the default for x-scheme-handler/https
Command:

Code: Select all

grep waterfox -lR /usr/share/applications
Result:

Code: Select all

/usr/share/applications/mimeinfo.cache
/usr/share/applications/waterfox.desktop

gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

administrollaattori wrote:
Wed Oct 24, 2018 1:03 pm
Yes. I installed from deb package, and the results are:
The thread isn't about you though. Moem clearly didn't install from .deb.

srq2625
Level 4
Level 4
Posts: 420
Joined: Tue Jan 08, 2013 11:35 am
Location: State: Constant Confusion, Country: D'oh

Re: URLs aren't passed on to Waterfox

Post by srq2625 »

Moem wrote:
Wed Oct 24, 2018 9:49 am
gm10 wrote:
Wed Oct 24, 2018 9:16 am
So it's not listed in Preferred Applications?
It is, but apparently not in the correct way. It's probably not installed where it should be. It seems the system does not completely know it's there.
To Install waterfox:
  1. Down load the .tar.bz2 file
  2. cd to the location where the tar file was downloaded and:

    Code: Select all

    $ tar jxf <name of the tar file>
    $ sudo mv ./waterfox /opt
    $ sudo ln -s /opt/waterfox/waterfox /usr/bin/waterfox
    
  3. On the Cinnamon menu, right-click > configure... > second tab (I think this is menu something) > go through the steps of adding the new menu item, using /usr/bin/waterfox for the command. The icon (click on the icon square) is found at /opt/waterfox/browser/icon/xxxx.png (forgot the name)
You should now have waterfox installed and integrated into the Cinnamon menu.

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6699
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: URLs aren't passed on to Waterfox

Post by kukamuumuka »

gm10 wrote:
Wed Oct 24, 2018 1:05 pm
administrollaattori wrote:
Wed Oct 24, 2018 1:03 pm
Yes. I installed from deb package, and the results are:
The thread isn't about you though. Moem clearly didn't install from .deb.
I just did not see the installation method. I have dyslexia. :lol:

User avatar
Moem
Level 20
Level 20
Posts: 11413
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

administrollaattori wrote:
Wed Oct 24, 2018 12:55 pm
Strange. Is Waterfox installed from deb package or tar.gz file?
Tar.gz.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
Moem
Level 20
Level 20
Posts: 11413
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: URLs aren't passed on to Waterfox

Post by Moem »

gm10 wrote:
Wed Oct 24, 2018 12:55 pm
My guess is /home/moem/.local/share/applications/userapp-Waterfox-WLV2AZ.desktop is missing the %U at the end as well, so add it.
Interestingly, it's not missing.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: URLs aren't passed on to Waterfox

Post by gm10 »

Moem wrote:
Wed Oct 24, 2018 1:17 pm
gm10 wrote:
Wed Oct 24, 2018 12:55 pm
My guess is /home/moem/.local/share/applications/userapp-Waterfox-WLV2AZ.desktop is missing the %U at the end as well, so add it.
Interestingly, it's not missing.
In that case I'll just keep my fingers crossed that it keeps working. ;)

Post Reply

Return to “Software & Applications”