[SOLVED] Firefox scrolling

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

[SOLVED] Firefox scrolling

Post by kevin987 » Sun Oct 28, 2018 10:53 pm

I'm using Firefox 63 but this problem has been around at least 2 years for me and can't find any help topics on the subject anywhere.

When using the left click on my mouse in the scroll bar area located on the right, it always jumps the web page down lower than it should. Instead of simply going down one page, it jumps the page down to wherever my mouse happens to be located. If I'm at the bottom of the scroll bar area, it takes me all the way down to the bottom.

None of the other web browsers do this (Chromium, Opera, ect). They always click down one page.

I can't find anything in Preferences concerning this.

Code: Select all

 $ inxi -Fxzd
System:    Host: kev-KJ384AA-ABA-JR5410F Kernel: 4.4.0-130-generic x86_64 (64 bit gcc: 4.8.4)
           Desktop: Cinnamon 2.8.8 (Gtk 3.10.8~8+qiana)
           Distro: Linux Mint 17.3 Rosa
Machine:   System: Compaq-Presario product: KJ384AA-ABA JR5410F
           Mobo: MSI model: Boston v: 1.0
           Bios: Phoenix v: 5.04 date: 02/29/2008
CPU:       Dual core Intel Pentium Dual E2160 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 7199
           clock speeds: max: 1800 MHz 1: 1200 MHz 2: 1200 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.15.1 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1680x1050@74.9hz
           GLX Renderer: Mesa DRI Intel G33
           GLX Version: 1.4 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-130-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: de00 bus-ID: 01:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Ralink RT2561/RT61 802.11g PCI
           driver: rt61pci v: 2.3.0 bus-ID: 02:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (60.7% used)
           ID-1: /dev/sda model: Hitachi_HDP72503 size: 320.1GB
           Optical: /dev/sr0 model: TSST CDDVDW TS-H653N
           rev: 0208 dev-links: cdrom
           Features: speed: 40x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 199G used: 151G (80%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 8:52 Memory: 2170.5/3941.1MB
           Init: Upstart runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.111) inxi: 2.2.28 
Last edited by kevin987 on Mon Oct 29, 2018 6:51 am, edited 1 time in total.

aes2011
Level 5
Level 5
Posts: 506
Joined: Wed Jul 06, 2011 10:39 pm

Re: Firefox scrolling

Post by aes2011 » Mon Oct 29, 2018 6:06 am

kevin987 wrote:
Sun Oct 28, 2018 10:53 pm
I'm using Firefox 63 but this problem has been around at least 2 years for me and can't find any help topics on the subject anywhere.

When using the left click on my mouse in the scroll bar area located on the right, it always jumps the web page down lower than it should. Instead of simply going down one page, it jumps the page down to wherever my mouse happens to be located. If I'm at the bottom of the scroll bar area, it takes me all the way down to the bottom.
This is a gtk3 thing. To fix it, create ~/.config/gtk-3.0/settings.ini, if it doesn't already exist, and add the following content:

Code: Select all

[Settings]
gtk-primary-button-warps-slider=0
If the file already exists, add the second line anywhere below the Settings line. When you restart any gtk3 application, including Firefox, clicking in the vertical scroll area above or below the "thumb" will cause the page to scroll up or down by one page per click.

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Firefox scrolling

Post by kevin987 » Mon Oct 29, 2018 6:50 am

Thank you. I had to create settings.ini and managed to place it in the proper directory on the first try.
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

Post Reply

Return to “Software & Applications”