My WINE is broken and I can't fix it. [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
EdB
Level 3
Level 3
Posts: 121
Joined: Fri Jan 08, 2016 11:34 am

My WINE is broken and I can't fix it. [SOLVED]

Post by EdB »

Like all of a sudden this happened. I tried to use the Wine Installer to add a new app, and the wheel just spun and then went away. Nothing happened. I have a few apps already installed, and none of those worked any more. I swear I can't imagine what changed, since I really do not do a whole lot with Wine anyway, and it's not something that I would get invasive with. I would have to be a lot smarter than I am to commit that sort of screw-up.

Anyway, I removed everything Wine using the Software Center and tried to get it back installed using WineHQ, but I repeatedly get this error (the =version in parenthesis varies with what I try to install - stable, dev, or staging).

Code: Select all

$ sudo apt-get install --install-recommends winehq-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-staging : Depends: wine-staging (= 3.19.0~bionic)
E: Unable to correct problems, you have held broken packages.
When I look for the dev/stable/staging in the Software Manager, the option is greyed-out.

Ideas appreciated.

Ed
Last edited by EdB on Wed Nov 07, 2018 10:51 pm, edited 1 time in total.

User avatar
MrEen
Level 20
Level 20
Posts: 10527
Joined: Mon Jun 12, 2017 8:39 pm

Re: My WINE is broken and I can't fix it.

Post by MrEen »

Hi EdB.

Based on the last line of your output, I would suggest you open Synaptic Package Manager, then click Edit > Fix Broken Packages then in the terminal run apt update

After that, you should be able to start over again.

Good luck.

EdB
Level 3
Level 3
Posts: 121
Joined: Fri Jan 08, 2016 11:34 am

Re: My WINE is broken and I can't fix it.

Post by EdB »

MrEen wrote:
Wed Nov 07, 2018 8:20 pm
Hi EdB.

Based on the last line of your output, I would suggest you open Synaptic Package Manager, then click Edit > Fix Broken Packages then in the terminal run apt update

After that, you should be able to start over again.

Good luck.
I just tried this. It returned immediately, no indication of anything being modified. Still cannot install Wine, same error.
Thanks though. Any other ideas? Maybe Timeshift?

Ed

User avatar
MrEen
Level 20
Level 20
Posts: 10527
Joined: Mon Jun 12, 2017 8:39 pm

Re: My WINE is broken and I can't fix it.

Post by MrEen »

I'm afraid it's beyond my knowledge base. I do find it odd you're getting the same error though. Anyway, to help others help you, it would be good to post the output of inxi -Fxzr

EdB
Level 3
Level 3
Posts: 121
Joined: Fri Jan 08, 2016 11:34 am

Re: My WINE is broken and I can't fix it.

Post by EdB »

MrEen wrote:
Wed Nov 07, 2018 10:10 pm
I'm afraid it's beyond my knowledge base. I do find it odd you're getting the same error though. Anyway, to help others help you, it would be good to post the output of inxi -Fxzr
Here is the output requested. (yes, I do have quite a few disks - triple boot W7/Mint19 Cinnamon/Mint19 Xfce + various data disks).

Code: Select all

$ inxi -Fxzr 
System:    Host: Mint19-XFCE Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Gigabyte product: Z170X-UD5 serial: N/A
           Mobo: Gigabyte model: Z170X-UD5-CF v: x.x serial: N/A
           UEFI [Legacy]: American Megatrends v: F4 date: 10/21/2015
CPU:       Quad core Intel Core i5-6400 (-MCP-) arch: Skylake-S rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21696
           clock speeds: max: 3300 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 version: 4.6.0 NVIDIA 396.54 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1 Sound: ALSA v: k4.15.0-38-generic
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Card-3 Hauppauge driver: USB Audio usb-ID: 001-008
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel I211 Gigabit Network Connection driver: igb v: 5.4.0-k port: d000 bus-ID: 09:00.0
           IF: enp9s0 state: down mac: <filter>
Drives:    HDD Total Size: 9752.0GB (0.8% used)
           ID-1: /dev/sda model: WDC_WD20EZRX size: 2000.4GB temp: 28C
           ID-2: /dev/sdb model: Samsung_SSD_850 size: 250.1GB temp: 0C
           ID-3: /dev/sdc model: WDC_WD10EZEX size: 1000.2GB temp: 33C
           ID-4: /dev/sdd model: WDC_WD20EARX size: 2000.4GB temp: 28C
           ID-5: /dev/sde model: Samsung_SSD_860 size: 500.1GB temp: 0C
           ID-6: USB /dev/sdf model: BUP_Slim_SL size: 2000.4GB temp: 0C
           ID-7: USB /dev/sdg model: BUP_Slim_SL size: 2000.4GB temp: 0C
Partition: ID-1: / size: 458G used: 69G (16%) fs: ext4 dev: /dev/sde1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.5C mobo: 29.8C gpu: 0.0:42C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb http://security.ubuntu.com/ubuntu trusty-security main
           deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
           Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list
           deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
           deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/ubuntuhandbook1-dvdstyler-bionic.list
           deb http://ppa.launchpad.net/ubuntuhandbook1/dvdstyler/ubuntu bionic main
           deb-src http://ppa.launchpad.net/ubuntuhandbook1/dvdstyler/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/vscode.list
           deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
Info:      Processes: 246 Uptime: 3:06 Memory: 1396.2/15990.9MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

User avatar
MrEen
Level 20
Level 20
Posts: 10527
Joined: Mon Jun 12, 2017 8:39 pm

Re: My WINE is broken and I can't fix it.

Post by MrEen »

Well, I do spot one potential issue there. Open up Software Souces and click on Additional repositories and remove the checkmark next to deb http://security.ubuntu.com/ubuntu trusty-security main

Then see if an apt update gets you back in business.

User avatar
Pierre
Level 20
Level 20
Posts: 10416
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: My WINE is broken and I can't fix it.

Post by Pierre »

EdB wrote:
Wed Nov 07, 2018 10:03 pm

I just tried this. It returned immediately, no indication of anything being modified. Still cannot install Wine, same error.
Thanks though. Any other ideas? Maybe Timeshift?

Ed
it may do that, but you can still hit Refresh & then see if the Apply icons is still greyed out or not.
- if it isn't greyed out, then click on Apply, to see if it now updates correctly.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

EdB
Level 3
Level 3
Posts: 121
Joined: Fri Jan 08, 2016 11:34 am

Re: My WINE is broken and I can't fix it.

Post by EdB »

MrEen wrote:
Wed Nov 07, 2018 10:28 pm
Well, I do spot one potential issue there. Open up Software Souces and click on Additional repositories and remove the checkmark next to deb http://security.ubuntu.com/ubuntu trusty-security main

Then see if an apt update gets you back in business.
That was very encouraging. Got wine-stable installed, and ran winecfg so it looks like we may be back in business.
If you have a moment, can you give a quick summary of what you saw here?

Such helpful folks in this group.

Ed

User avatar
MrEen
Level 20
Level 20
Posts: 10527
Joined: Mon Jun 12, 2017 8:39 pm

Re: My WINE is broken and I can't fix it.

Post by MrEen »

trusty was the codename for Ubuntu 14.04 which Linux Mint 17.x was based on. Your version of Mint is based on the Bionic (18.04) version of Ubuntu.

EdB
Level 3
Level 3
Posts: 121
Joined: Fri Jan 08, 2016 11:34 am

Re: My WINE is broken and I can't fix it.

Post by EdB »

MrEen wrote:
Wed Nov 07, 2018 10:42 pm
trusty was the codename for Ubuntu 14.04 which Linux Mint 17.x was based on. Your version of Mint is based on the Bionic (18.04) version of Ubuntu.
I must have copy/pasted the wrong thing from the instructions on winehq. My compliments and thanks.

Ed

User avatar
MrEen
Level 20
Level 20
Posts: 10527
Joined: Mon Jun 12, 2017 8:39 pm

Re: My WINE is broken and I can't fix it.

Post by MrEen »

Happy to help. I'm glad everything worked out. :D

jtaxel1977
Level 1
Level 1
Posts: 3
Joined: Tue May 19, 2020 8:49 am

Re: My WINE is broken and I can't fix it. [SOLVED]

Post by jtaxel1977 »

I know this is old, but
i had this same issue with

wine client error:0: version mismatch 595/603.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?

typing in the terminal: wineserver -k did the trick.

Thanks!

Post Reply

Return to “Software & Applications”