Xfce suspend with lid close

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
all41
Level 14
Level 14
Posts: 5021
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Xfce suspend with lid close

Post by all41 » Mon Nov 12, 2018 9:26 pm

My netbook Compaq CQ-58 had been running 17.3 MATE successfully but I recently decided to reinstall a fresh copy of 19 MATE--but found Tara to be rather demanding of the minimal resources available, so I reverted to a freshly installed 18.3 Xfce. I am pleased with the decision--this is far less resource hungry.

I searched the forums but did not find pertinent posts.

The only issue involves Suspend when using lid close.
After suspending with lid close, lid reopening results in a blank screen and the only recovery option thus far
has been Ctrl+Alt+Backspace to log out, after which login results in a fresh (non suspended) desktop.

This does not happen when suspending from Menu/Logout/Suspend nor from command line systemctl suspend.
In both cases opening the lid results in normally expected suspend recovery.

Neither 17.3 Mate nor 19 Mate experienced this problem.
Is this something to do with Xfce?
What differs between the lid closure suspend instruction--vs systemctl suspend?

For the time being I am using keyboard shortcut Ctrl+Alt+S to implement the systemctl suspend instruction without issue when opening the lid, but I would really like this to happen after just closing the lid to suspend.
Proud to be a supporter and monthly contributor to Mint.

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: Xfce suspend with lid close

Post by MrEen » Mon Nov 12, 2018 11:15 pm

Hi all41.

I don't have a laptop. I don't use suspend. But I do drive by a Holiday Inn Express on my way to work!

I have seen tons of reports similar to yours on the web that don't seem to be getting properly solved. But I did get some hints of things to investigate.

Are you using the lock screen on suspend feature, and if so, where? There are two places this can be set via GUI and I'm wondering if it is causing some sort of conflict if both are set. Menu > Settings > Power Manager > Security tab and Menu > Settings > Light Locker Settings

Maybe disable one or the other then reverse them to see if you can find your way out of this.

Good luck.

User avatar
all41
Level 14
Level 14
Posts: 5021
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Xfce suspend with lid close

Post by all41 » Mon Nov 12, 2018 11:51 pm

MrEen wrote:
Mon Nov 12, 2018 11:15 pm
Hi all41.

I don't have a laptop. I don't use suspend. But I do drive by a Holiday Inn Express on my way to work!

I have seen tons of reports similar to yours on the web that don't seem to be getting properly solved. But I did get some hints of things to investigate.

Are you using the lock screen on suspend feature, and if so, where? There are two places this can be set via GUI and I'm wondering if it is causing some sort of conflict if both are set. Menu > Settings > Power Manager > Security tab and Menu > Settings > Light Locker Settings

Maybe disable one or the other then reverse them to see if you can find your way out of this.

Good luck.
@MrEen
Well I tried those iterations with negative results. Thanks for the suggestions.
I try to explore all paths.
I can get along using systemctl suspend--though I think I will install Sylvia MATE just to satisfy the questionmark:
is this related to Xfce?
As I have said suspend and recovery was not an issue with Rosa or Tara using MATE,
therefore I suspect the issue lies within Xfce. I will update this thread with my findings.
Proud to be a supporter and monthly contributor to Mint.

User avatar
all41
Level 14
Level 14
Posts: 5021
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Xfce suspend with lid close

Post by all41 » Tue Nov 13, 2018 12:53 am

OK I did it--I just installed 18.3 MATE in the same configuration and there are no issues with
lid closing/opening suspend.
Therefore I surmise this to be an anomaly associated with this particular machine's architecture
when using Xfce.
Proud to be a supporter and monthly contributor to Mint.

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: Xfce suspend with lid close

Post by MrEen » Tue Nov 13, 2018 5:27 pm

I've still got a bunch of tabs open on this topic. It seems there's been issues for several years on Xfce (everywhere, not just with Mint) when it comes to closing the laptop lid and the expected behavior.

I guess I'll have to ask Santa for a laptop so I can try to figure it all out. :mrgreen:

notned
Level 1
Level 1
Posts: 9
Joined: Thu Jan 07, 2016 6:29 pm

Re: Xfce suspend with lid close

Post by notned » Tue Nov 13, 2018 5:32 pm

I can confirm that something very like this happens with Manjaro Xfce.

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: Xfce suspend with lid close

Post by MrEen » Tue Nov 13, 2018 5:55 pm

Thanks notned. I can confirm the problem probaby lies with xfce4-power-manager, or upower, or systemd-logind, or pm-utils, or light-locker, or xfwm4, or the kernel, or someone blinked the wrong way, or a butterfly flapped it's wings in a hurricane. Shouldn't be too hard to fix once I get something to test on. :lol:

redlined
Level 4
Level 4
Posts: 408
Joined: Wed Jun 06, 2018 8:12 pm
Location: Mile High, Green State (Denver, CO:)

Re: Xfce suspend with lid close

Post by redlined » Tue Nov 13, 2018 6:09 pm

hi all41!

I came across this info chasing links to learn about compiz as I'm considering installing it for a nitpick issue I have. I realize this is something for compiz users to consider but thought it may be a hint related to nvidia drivers (if that's even applicable in your case)
https://wiki.archlinux.org/index.php/Co ... ry_drivers
Blank screen on resume from suspend-to-ram with NVIDIA binary drivers

If you receive a blank screen with a responsive cursor upon resume, try disabling sync to vblank. To do so, open CCSM, navigate to the OpenGL plugin and untick the Sync to VBlank option.
Moem kōan 42: Should tool manufacturers be required to fix their products so that you cannot use their saws to cut the tree branch that you're sitting on?

(The answer to the ultimate question of life, the universe and everything is... 42!!;)

User avatar
all41
Level 14
Level 14
Posts: 5021
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Xfce suspend with lid close

Post by all41 » Sat Nov 17, 2018 9:52 pm

redlined wrote:
Tue Nov 13, 2018 6:09 pm
hi all41!

I came across this info chasing links to learn about compiz as I'm considering installing it for a nitpick issue I have. I realize this is something for compiz users to consider but thought it may be a hint related to nvidia drivers (if that's even applicable in your case)
https://wiki.archlinux.org/index.php/Co ... ry_drivers
Blank screen on resume from suspend-to-ram with NVIDIA binary drivers

If you receive a blank screen with a responsive cursor upon resume, try disabling sync to vblank. To do so, open CCSM, navigate to the OpenGL plugin and untick the Sync to VBlank option.
Hi and thanks.
This has Radeon HD graphics
Proud to be a supporter and monthly contributor to Mint.

notned
Level 1
Level 1
Posts: 9
Joined: Thu Jan 07, 2016 6:29 pm

Re: Xfce suspend with lid close

Post by notned » Mon Nov 19, 2018 5:45 pm

https://forum.peppermintos.com/index.ph ... ;topicseen

Open the /etc/systemd/logind.conf file in a text editor as root, for example,

Code: [Select]
sudo xed /etc/systemd/logind.conf
Find the line that reads

Code: [Select]
#HandleLidSwitch=suspend

and make it read

Code: [Select]
HandleLidSwitch=ignore

save the file and then close it - reboot and then see what happens when you close the lid.

If this does not work - simply edit the file again and add a # to comment out the line again

Regards Zeb...

Found this ... Notned

Post Reply

Return to “Software & Applications”