VPN Unlimited repository error.

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
MattP490
Level 1
Level 1
Posts: 9
Joined: Sun Oct 28, 2018 1:33 am

VPN Unlimited repository error.

Post by MattP490 » Tue Nov 13, 2018 8:48 pm

Hey guys! I use a VPN service called VPN Unlimited. Since the day I installed it, everytime my Linux Mint system attempts to update, it fails and I have to continue it manually. Upon proceeding with the update, I receive an error message stating: Could not download all repository indexes; The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.; The repository 'http://apt.keepsolid.com/debian bionic Release' does not have a Release file. Although this is not debilitating, it is extremely annoying. I've tried blacklisting the repository, as well as adding it via apt. all that accomplished was the production of even more error messages concerning KeepSolid. By the way, KeepSolid is the company that provides VPN Unlimited. Another very irritating thing happening due to VPN Unlimited is all the error messages produced when I attempt to update via the command line. I'll post it all, as a reply to my own post. Any help would be greatly appreciated. Oh, I also attempted removing VPN Unlimited in an attempt to free myself of them error messages. I used apt remove, apt purge, apt autoclean, as well as apt autoremove. Although the VPN Unlimited was gone, and presumably any files associated to it, the error messages remained. Please help!

MattP490
Level 1
Level 1
Posts: 9
Joined: Sun Oct 28, 2018 1:33 am

Re: VPN Unlimited repository error.

Post by MattP490 » Tue Nov 13, 2018 8:50 pm

Code: Select all

mattp490@mattp490-HP-Pavilion-Notebook:~$ apt update && apt upgrade
[sudo] password for mattp490: 
Hit:1 http://mirror.lstn.net/ubuntu bionic InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:3 http://mirror.lstn.net/ubuntu bionic-updates InRelease [88.7 kB]         
Ign:4 http://packages.linuxmint.com tara InRelease                             
Hit:5 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease              
Ign:7 http://apt.keepsolid.com/debian bionic InRelease                         
Hit:8 https://brave-browser-apt-release.s3.brave.com bionic InRelease          
Hit:9 http://packages.linuxmint.com tara Release                               
Get:10 http://mirror.lstn.net/ubuntu bionic-backports InRelease [74.6 kB]      
Err:11 http://apt.keepsolid.com/debian bionic Release                          
  404  Not Found [IP: 149.56.19.14 80]
Hit:13 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease         
Hit:14 http://archive.canonical.com/ubuntu bionic InRelease                    
Hit:15 http://repository.spotify.com stable InRelease                          
Hit:16 https://repo.skype.com/deb stable InRelease                             
Reading package lists... Done                      
E: The repository 'http://apt.keepsolid.com/debian bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target CNF (main/cnf/Commands-amd64) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1
W: Target CNF (main/cnf/Commands-all) is configured multiple times in /etc/apt/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1

User avatar
greerd
Level 5
Level 5
Posts: 986
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: VPN Unlimited repository error.

Post by greerd » Tue Nov 13, 2018 9:37 pm

Hi MattP490,
Looks like you've added the keepsolid repo multiple times.
One way to sort this out is to run 'Software Sources' (from the menu), click 'Additional repositories' and un-check or remove all the repo's with 'keepsolid' in the name. Then run update manager, refresh and try again.

User avatar
phd21
Level 17
Level 17
Posts: 7518
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: VPN Unlimited repository error.

Post by phd21 » Tue Nov 13, 2018 10:03 pm

Hi MattP490

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.


I think your vpn provider is called "KeepSolid VPN Unlimited"
KeepSolid VPN Unlimited Review & Rating | PCMag.com
https://www.pcmag.com/review/344816/kee ... -unlimited

VPN Download – Download the VPN Unlimited for your Linux
https://www.vpnunlimitedapp.com/en/downloads/linux

It looks like there may be 2 issues, 1. your vpn provider does not have a Linux Mint 19.x based on Ubuntu 18.04 Bionic software source repository, although they have an Ubuntu 18 Linux deb file installer, and 2. you have added their software source repository multiple times maybe in multiple places, only supposed to have one entry. Maybe you installed the wrong deb file for your Linux Mint version.



To remove multiple software source repository entries,

From your post:
/sources.list.d/additional-repositories.list:1 and /etc/apt/sources.list.d/keepsolidinc.list:1

List what is in the "/sources.list.d/additional-repositories.list" file to see if there are any entries for "keepsolidinc" and if there are, remove them, check for other duplicates as well, (edit this text file remove lines with keepsolidinc, save the file, exit text editor).

Show contents of a file

Code: Select all

cat /sources.list.d/additional-repositories.list
To edit this text file using the "xed" text editor.

Code: Select all

sudo -H xed /sources.list.d/additional-repositories.list

Now, list all the currently installed software repositories, and remove all duplicates

Code: Select all

ls -hl /etc/apt/sources.list.d/
To remove a duplicate entry or any entry:
Example

Code: Select all

sudo rm /sources.list.d/keepsolidinc.list
To remove all repositories regarding "keepsolidinc"
Example

Code: Select all

sudo rm /sources.list.d/keepsolidinc.*

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

MattP490
Level 1
Level 1
Posts: 9
Joined: Sun Oct 28, 2018 1:33 am

Re: VPN Unlimited repository error.

Post by MattP490 » Fri Nov 16, 2018 10:25 pm

Thanks so much for your help guys. With the help you offered, I was able to solve my problem. :D

User avatar
phd21
Level 17
Level 17
Posts: 7518
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: VPN Unlimited repository error.

Post by phd21 » Fri Nov 16, 2018 11:29 pm

HI MattP490,

You are welcome from all of us that replied...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Software & Applications”