Page 1 of 1

failed to update repositories

Posted: Fri Dec 07, 2018 3:21 am
by APNpanditt
i am getting this error on the bottom right corner saying "your APT cache is corrupted." and whenever i try to open software source and try to update, it says " failed to update repositories". any solution for this?
also says ::::

Code: Select all

E:Failed to fetch http://packages.linuxmint.com/dists/tara/main/binary-i386/Packages.gz  File has unexpected size (12866 != 12861). Mirror sync in progress? [IP: 68.235.39.11 80]
Hashes of expected file:
 - Filesize:12861 [weak]
 - SHA256:fdc1369c6747bce0d61d2c4e39a3d657ce844e459736783615000c16b4d7811c
 - SHA1:0271f67b2f3152a1e36ac834044ee6204eea46f1 [weak]
 - MD5Sum:3587815a0928ca4b5b2866e46293170e [weak]
Release file created at: Thu, 29 Nov 2018 11:06:33 +0000
, E:Failed to fetch http://packages.linuxmint.com/dists/tara/main/binary-amd64/Packages.gz  , E:Some index files failed to download. They have been ignored, or old ones used instead.

Re: failed to update repositories

Posted: Fri Dec 07, 2018 3:34 am
by killer de bug
It may be that the package list is being sync on the server. You should wait a few hours and the error will resolve by itself normally.

Re: failed to update repositories

Posted: Fri Dec 07, 2018 10:12 pm
by Sathairn
I also received this error around 21:00 EST. I'm going to give it a few more hours before updating to see if it resolves.

Re: failed to update repositories

Posted: Sat Dec 08, 2018 7:24 am
by RSM12
hi
even i am getting this error while updating the software, attached image of same.
kindly help
cheers

Re: failed to update repositories

Posted: Sat Dec 08, 2018 7:42 am
by philotux
RSM12 wrote:
Sat Dec 08, 2018 7:24 am
hi
even i am getting this error while updating the software, attached image of same.
kindly help
cheers
Having a look at your screenshot, the issue you're experiencing seems to be of a different nature than OP's, please open a new thread to get adequate and relevant assistance to resolve it.
cheers

Re: failed to update repositories

Posted: Sat Dec 08, 2018 10:24 am
by APNpanditt
killer de bug wrote:
Fri Dec 07, 2018 3:34 am
It may be that the package list is being sync on the server. You should wait a few hours and the error will resolve by itself normally.
hi there,
its been almost 2 days having same problem. nothing is happening!

Re: failed to update repositories

Posted: Sat Dec 08, 2018 11:08 am
by gm10
APNpanditt wrote:
Sat Dec 08, 2018 10:24 am
killer de bug wrote:
Fri Dec 07, 2018 3:34 am
It may be that the package list is being sync on the server. You should wait a few hours and the error will resolve by itself normally.
hi there,
its been almost 2 days having same problem. nothing is happening!
Click on Software Sources > Maintenance > Fix MergeList problems

Re: failed to update repositories

Posted: Sat Dec 08, 2018 12:14 pm
by KoHoSo
gm10 wrote:
Sat Dec 08, 2018 11:08 am
Click on Software Sources > Maintenance > Fix MergeList problems
That fixed it for me! Thanks!

Re: failed to update repositories

Posted: Sun Dec 09, 2018 8:48 am
by APNpanditt
KoHoSo wrote:
Sat Dec 08, 2018 12:14 pm
gm10 wrote:
Sat Dec 08, 2018 11:08 am
Click on Software Sources > Maintenance > Fix MergeList problems
That fixed it for me! Thanks!
didn't work for me!! it says the same!

Re: failed to update repositories

Posted: Sun Dec 09, 2018 8:52 am
by gm10
How is that the same? You showed a completely different error in the OP.

You can try switching to a mirror.

Otherwise post an

Code: Select all

inxi -Fxz

Re: failed to update repositories

Posted: Sun Dec 09, 2018 10:09 am
by APNpanditt
gm10 wrote:
Sun Dec 09, 2018 8:52 am
How is that the same? You showed a completely different error in the OP.

You can try switching to a mirror.

Otherwise post an

Code: Select all

inxi -Fxz
Yeah it is fixed now.
1. I just restored the default setting in the software sources
2. unchecked every PPA's listed there.
3. and also in Additional repositories section, i did the same, unchecked all repositories sources and then updated my APT cache.
and then it's fixed.
Thank you so much for your follow ups!
greetings!