glib compiled...

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Tue May 29, 2007 5:11 pm

glib compiled...

Postby smev9 » Tue May 29, 2007 5:18 pm

i want to use the latest gimp (2.3.17) which has (in the INSTALL file) stated, that it needed late packages of gtk, glib, pango and so on

So i downloaded all packages, which i couldnt find via synaptic and began compiling them

After i compiled glib, it is no more possible for me to compile gtk any more.

When i run ./configure it says this:

*** 'pkg-config --modversion glib-2.0' returned 2.12.12, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.12.0 or better is required. The latest version of
*** GLIB is always available from

If you have any hints, i would be most grateful

Thanks in advance

User avatar
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Postby Boo » Tue May 29, 2007 8:56 pm

try using synaptic to remove the old version of Glib.
but you probably tried this already.

or have you tried what the message said?

export LD_LIBRARY_PATH=/path/to/glib2.12.12/ld_lib

if you are running these commands with sudo you would be best becoming root first. sudo su -

Now where was i going? Oh yes, crazy!

Level 1
Level 1
Posts: 2
Joined: Tue May 29, 2007 5:11 pm

Found one Solution

Postby smev9 » Wed May 30, 2007 5:32 am

I did a sudo make uninstall

I will stick with the old version, since it is enough for gimp 2.3.17

But thank you nevertheless

Return to “Software & Applications”