I Get The Below Error Trying To Update PulseAudio Components

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Wed Dec 19, 2018 1:22 pm

trying to update pulseaudio components and i get this. i clicked fix broken packages, but i was still left with that.

Code: Select all

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Wed Dec 19, 2018 3:12 pm

administrollaattori wrote:
Wed Dec 19, 2018 1:49 pm

Code: Select all

apt-mark showhold

??????

Code: Select all

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

User avatar
administrollaattori
Level 15
Level 15
Posts: 5898
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by administrollaattori » Thu Dec 20, 2018 3:29 am

apt-mark showhold tells if some package is hold.
https://www.computerhope.com/unix/apt-mark.htm

If you have installed some PPAs, etc. Them can break a system. For knowing you repos, run

Code: Select all

inxi -Sr
... and installed pulse packages

Code: Select all

dpkg --get-selections | grep pulse

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Thu Dec 20, 2018 8:25 am

apt-get showhold didn't bring up anything.

Code: Select all

System:    Host: LOTN Kernel: 4.15.0-42-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.9  Distro: Linux Mint 19 Tara
Repos:     Active apt sources in file: /etc/apt/sources.list.d/agornostal-ulauncher-bionic.list
           deb http://ppa.launchpad.net/agornostal/ulauncher/ubuntu bionic main
           deb-src http://ppa.launchpad.net/agornostal/ulauncher/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/clipgrab-team-ppa-bionic.list
           deb http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
           deb-src http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/elementary-os-stable-bionic.list
           deb http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic main
           deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/forkotov02-ppa-bionic.list
           deb http://ppa.launchpad.net/forkotov02/ppa/ubuntu bionic main
           deb-src http://ppa.launchpad.net/forkotov02/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/gezakovacs-ppa-bionic.list
           deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
           deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/jitsi-stable.list
           deb https://download.jitsi.org stable/
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-bionic.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
           deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-apps-bionic.list
           deb http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
           deb-src http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/noobslab-icons-bionic.list
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu bionic main
           deb-src http://ppa.launchpad.net/noobslab/icons/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/notepadqq-team-notepadqq-bionic.list
           deb http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu bionic main
           deb-src http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
           deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
           Active apt sources in file: /etc/apt/sources.list.d/rikmills-latte-dock-bionic.list
           deb http://ppa.launchpad.net/rikmills/latte-dock/ubuntu bionic main
           deb-src http://ppa.launchpad.net/rikmills/latte-dock/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/sergiomejia666-respin-bionic.list
           deb http://ppa.launchpad.net/sergiomejia666/respin/ubuntu bionic main
           deb-src http://ppa.launchpad.net/sergiomejia666/respin/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/teejee2008-ppa-bionic.list
           deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
           deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/xuzhen666-dockbarx-bionic.list
           deb http://ppa.launchpad.net/xuzhen666/dockbarx/ubuntu bionic main
           deb-src http://ppa.launchpad.net/xuzhen666/dockbarx/ubuntu bionic main

Code: Select all

gstreamer1.0-pulseaudio:amd64			install
libcanberra-pulse:amd64				install
libpulse-mainloop-glib0:amd64			install
libpulse0:amd64					install
libpulse0:i386					install
libpulsedsp:amd64				install
libpulsedsp:i386				install
pulseaudio					install
pulseaudio-equalizer				install
pulseaudio-module-bluetooth			install
pulseaudio-module-gconf				install
pulseaudio-module-zeroconf			install
pulseaudio-utils				install
xfce4-pulseaudio-plugin:amd64			install


User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by philotux » Thu Dec 20, 2018 11:12 am

MrGrimm wrote:
Thu Dec 20, 2018 8:25 am
apt-get showhold didn't bring up anything.
The right command would be:

Code: Select all

apt-mark showhold

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Thu Dec 20, 2018 11:21 am

philotux wrote:
Thu Dec 20, 2018 11:12 am
MrGrimm wrote:
Thu Dec 20, 2018 8:25 am
apt-get showhold didn't bring up anything.
The right command would be:

Code: Select all

apt-mark showhold
that was a typo on my part, i did mark and nothing,

User avatar
philotux
Level 5
Level 5
Posts: 833
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by philotux » Thu Dec 20, 2018 11:28 am

Alright. Worth a shot:

Code: Select all

sudo apt install -f
to rebuild the dependency tree.
administrollaattori wrote:
Thu Dec 20, 2018 3:29 am
If you have installed some PPAs, etc. Them can break a system.
Try deactivating/deselecting some of the PPAs in Software Sources and run update too see if it is one of them causing trouble.

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Thu Dec 20, 2018 11:55 am

pretty sure this has something to do with jisti. here.

https://community.jitsi.org/t/e-jitsi-m ... ured/16145

EDIT: jisti fixed.
Last edited by MrGrimm on Sun Dec 30, 2018 7:57 am, edited 1 time in total.

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Fri Dec 21, 2018 8:00 am

mint 19 just had a big update that fixed the above issue, however i'm not seeing the pulseaudio equalizer.

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: I Get The Below Error Trying To Update PulseAudio Components

Post by MrGrimm » Sat Dec 29, 2018 7:54 am

philotux wrote:
Thu Dec 20, 2018 11:28 am
Alright. Worth a shot:

Code: Select all

sudo apt install -f
to rebuild the dependency tree.
administrollaattori wrote:
Thu Dec 20, 2018 3:29 am
If you have installed some PPAs, etc. Them can break a system.
Try deactivating/deselecting some of the PPAs in Software Sources and run update too see if it is one of them causing trouble.
missed your post

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
reran the two commands from above.

Code: Select all

System:
  Host: LOTN Kernel: 4.15.0-43-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  No active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
  Active apt repos in: /etc/apt/sources.list.d/agornostal-ulauncher-bionic.list 
  1: deb http://ppa.launchpad.net/agornostal/ulauncher/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/agornostal/ulauncher/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/clipgrab-team-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/elementary-os-stable-bionic.list 
  1: deb http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/forkotov02-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/forkotov02/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/forkotov02/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/gezakovacs-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/jitsi-stable.list 
  1: deb https://download.jitsi.org stable/
  Active apt repos in: /etc/apt/sources.list.d/nilarimogard-webupd8-bionic.list 
  1: deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/noobslab-apps-bionic.list 
  1: deb http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/noobslab/apps/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/noobslab-icons-bionic.list 
  1: deb http://ppa.launchpad.net/noobslab/icons/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/noobslab/icons/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/nordvpn.list 
  1: deb https://repo.nordvpn.com/deb/nordvpn/debian stable main
  Active apt repos in: /etc/apt/sources.list.d/notepadqq-team-notepadqq-bionic.list 
  1: deb http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/openshot_developers-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list 
  1: deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
  Active apt repos in: /etc/apt/sources.list.d/rikmills-latte-dock-bionic.list 
  1: deb http://ppa.launchpad.net/rikmills/latte-dock/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/rikmills/latte-dock/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/rvm-smplayer-bionic.list 
  1: deb http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/sergiomejia666-respin-bionic.list 
  1: deb http://ppa.launchpad.net/sergiomejia666/respin/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/sergiomejia666/respin/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/stebbins-handbrake-releases-bionic.list 
  1: deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/teamviewer.list 
  1: deb http://linux.teamviewer.com/deb stable main
  Active apt repos in: /etc/apt/sources.list.d/teejee2008-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/ubuntuhandbook1-dvdstyler-bionic.list 
  1: deb http://ppa.launchpad.net/ubuntuhandbook1/dvdstyler/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/ubuntuhandbook1/dvdstyler/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/ubuntuhandbook1-lives-bionic.list 
  1: deb http://ppa.launchpad.net/ubuntuhandbook1/lives/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/ubuntuhandbook1/lives/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/vivaldi.list 
  1: deb http://repo.vivaldi.com/stable/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/xuzhen666-dockbarx-bionic.list 
  1: deb http://ppa.launchpad.net/xuzhen666/dockbarx/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/xuzhen666/dockbarx/ubuntu bionic main
mc2635599@LOTN:~$ dpkg --get-selections | grep pulse
gstreamer1.0-pulseaudio:amd64			install
libcanberra-pulse:amd64				install
libpulse-mainloop-glib0:amd64			install
libpulse0:amd64					install
libpulse0:i386					install
libpulsedsp:amd64				install
libpulsedsp:i386				install
pulseaudio					install
pulseaudio-equalizer				install
pulseaudio-module-bluetooth			install
pulseaudio-module-gconf				install
pulseaudio-module-zeroconf			install
pulseaudio-utils				install
xfce4-pulseaudio-plugin:amd64			install

Post Reply

Return to “Software & Applications”