MySQL Server Not Working

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 4
Level 4
Posts: 257
Joined: Fri Dec 12, 2014 6:46 am
Location: UK

MySQL Server Not Working

Post by MichaelJohn »


This is the second problem I have encountered on my Mint 17.3 Rosa laptop since catching up on over six months worth of updates. MySQL had been running fine for over a year, but following the upgrade would not see the databases! I have tried removing and reinstalling all the components but this lead to the Server not even starting. I then rn "sudo apt-get upgrade" and "update" with the following result:-

The following packages were automatically installed and are no longer required:
libqt5x11extras5 qt56-teamviewer qtdeclarative5-controls-plugin
qtdeclarative5-dialogs-plugin qtdeclarative5-privatewidgets-plugin
qtdeclarative5-qtquick2-plugin qtdeclarative5-quicklayouts-plugin
qtdeclarative5-window-plugin teamviewer
Use 'apt-get autoremove' to remove them.
The following packages have been kept back:
cups-filters cups-filters-core-drivers ia32-libs linux-kernel-generic
mintsystem qpdf ubuntu-minimal
0 to upgrade, 0 to newly install, 0 to remove and 7 not to upgrade.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up mysql-server-5.5 (5.5.62-0ubuntu0.14.04.1) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.5 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
mysql-server depends on mysql-server-5.5; however:
Package mysql-server-5.5 is not configured yet.

I am somewhat unsure what to do next! Any ideas?

Thanks, MichaelJohn

Level 4
Level 4
Posts: 257
Joined: Fri Dec 12, 2014 6:46 am
Location: UK

Re: MySQL Server Not Working - Solved

Post by MichaelJohn »

After spending hours trying to reinstall with no joy I decided to completely remove mysql and reinstall. The package manger did not seem totally effective in doing this so I did the following:-

apt-get purge mysql-server mysql-common mysql-client # Note in some cases you may need to add -version

Followed by:-

rm -rf /var/lib/mysql
rm -rf /etc/mysql*

I had backed up the database before updating Mint on Wednesday but found this backup to be corrupt but fortunately the one run on my last day in the office was fine! :)

I suspect that despite assurances someone tampered whilst I as away!

Level 17
Level 17
Posts: 7749
Joined: Sun Aug 09, 2015 10:00 am

Re: MySQL Server Not Working

Post by deepakdeshp » ... KlDUOvSmgw
The way to remove mysql is to purge it.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Software & Applications”