(Solved) HDMI sound option output always on

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
pcfan5
Level 4
Level 4
Posts: 361
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

(Solved) HDMI sound option output always on

Post by pcfan5 »

Hello, whenever I turn my computer on de HDMI sound otuput option is always on , this is in "volume control" right next to my clock. And I cannot change it back to "speakers" , the only way I can change it is by plugging in a headphone , then I get the option to change from headphone to speakers. Otherwise this options aren't available, neither shown.

error audio hdmi.png
I am in linux mint 18. xfce.


this is my laptop

Code: Select all

System:    Host: sil-MOV Kernel: 4.15.0-34-generic x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Linux Mint 18.3 Sylvia
Machine:   System: BANGHO (portable) product: MOV v: MODEL_EQUIP
           Mobo: BANGHO model: MOV v: D02A
           Bios: American Megatrends v: 1.01.15RPCD1 date: 07/11/2012
CPU:       Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3100 MHz 1: 990 MHz 2: 1040 MHz 3: 858 MHz
           4: 932 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.91hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 18.0.5
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network:   Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
           driver: rtl8192ce
           IF: wlp2s0 state: up mac: <filter>
           Card-2: JMicron JMC250 PCI Express Gigabit Ethernet Controller
           driver: jme
           IF: enp3s0f0 state: down mac: <filter>
Drives:    HDD Total Size: 570.1GB (40.3% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
           ID-2: USB /dev/sdb model: 2500BMV_External size: 250.1GB
Partition: ID-1: / size: 22G used: 12G (58%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 268G used: 199G (79%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 214 Uptime: 26 min Memory: 1303.1/3850.4MB
           Client: Shell (bash) inxi: 2.2.35 
Last edited by pcfan5 on Thu Jan 10, 2019 11:16 pm, edited 1 time in total.
User avatar
MrEen
Level 22
Level 22
Posts: 16625
Joined: Mon Jun 12, 2017 8:39 pm

Re: HDMI sound option output always on

Post by MrEen »

Hi pcfan5.

Depending on the setup, you can either disable HDMI sound if it is a separate card from the Built-in Audio, or set a default sink in default.pa if it's not. The easiest way for me to offer assistance is if you paste back the output of running pacmd list-cards in the terminal.
User avatar
pcfan5
Level 4
Level 4
Posts: 361
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: HDMI sound option output always on

Post by pcfan5 »

MrEen wrote:
Thu Jan 10, 2019 3:27 pm
Hi pcfan5.

Depending on the setup, you can either disable HDMI sound if it is a separate card from the Built-in Audio, or set a default sink in default.pa if it's not. The easiest way for me to offer assistance is if you paste back the output of running pacmd list-cards in the terminal.
Hello thank you for your reply this is a notebook I only have one card. here is the result for the command you sent me.

Code: Select all

LC_ALL=C pacmd list-cards
1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7e00000 irq 27"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1c20"
		device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Audio Interno"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Estéreo analógico Entrada (priority 60, available: unknown)
		output:analog-stereo: Estéreo analógico Salida (priority 6000, available: unknown)
		output:analog-stereo+input:analog-stereo: Estéreo Analógico Dúplex (priority 6060, available: unknown)
		output:hdmi-stereo: Digital Stereo (HDMI) Salida (priority 5400, available: unknown)
		output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Salida + Estéreo analógico Entrada (priority 5460, available: unknown)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Salida (priority 300, available: unknown)
		output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Salida + Estéreo analógico Entrada (priority 360, available: unknown)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Salida (priority 300, available: unknown)
		output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Salida + Estéreo analógico Entrada (priority 360, available: unknown)
		off: Apagado (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#2: Audio Interno Estéreo analógico
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#2: Monitor of Audio Interno Estéreo analógico
	ports:
		analog-input-internal-mic: Micrófono interno (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Micrófono (priority 8700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Altavoces (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Auriculares analógicos (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"

This is a recent problem , time ago I was able to chance my output without trouble. The last program I installed was "PulseEffects", and I remember messing arround in console with a pulse audio equalizer. This was 20 days back and I don't remember well what I run.

Maybe this can bring some light .. I have a foreing package called pulseaudio-equalizer-ladspa
Captura de pantalla_2019-01-10_21-35-15.png
User avatar
MrEen
Level 22
Level 22
Posts: 16625
Joined: Mon Jun 12, 2017 8:39 pm

Re: HDMI sound option output always on

Post by MrEen »

My apologies, pcfan5. There is a simpler fix that should work for you. Notice the check mark in the image in your first post? That means HDMI is set as the fallback (default) setting.

Once you've plugged in your headphones, then changed the output to your speakers, that will change what is showing on that tab. Click on the check mark while it is showing those new settings and that should make those settings default from then on. The check mark should have a green box around it when clicked with your preferred options.
User avatar
pcfan5
Level 4
Level 4
Posts: 361
Joined: Tue Sep 06, 2016 10:57 am
Location: Antartica

Re: HDMI sound option output always on

Post by pcfan5 »

MrEen wrote:
Thu Jan 10, 2019 8:48 pm
My apologies, pcfan5. There is a simpler fix that should work for you. Notice the check mark in the image in your first post? That means HDMI is set as the fallback (default) setting.

Once you've plugged in your headphones, then changed the output to your speakers, that will change what is showing on that tab. Click on the check mark while it is showing those new settings and that should make those settings default from then on. The check mark should have a green box around it when clicked with your preferred options.
Thank you very much, that did the trick!! and I also set in the tab "configuration"- "Analogue Stereo Duplex". Thank you for your kind reply. :D
User avatar
MrEen
Level 22
Level 22
Posts: 16625
Joined: Mon Jun 12, 2017 8:39 pm

Re: (Solved) HDMI sound option output always on

Post by MrEen »

You're very welcome. And you made the correct choice with Analogue Stereo Duplex, in case you ever want to use a microphone.
Post Reply

Return to “Software & Applications”