Lich King is hidden in my WoW folder

Questions about applications and software
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Thu Jul 02, 2009 1:56 pm

Lich King is hidden in my WoW folder

Postby gabrielmcneese21 » Thu Jul 02, 2009 2:21 pm

I've worked with Linux before I'm not completely dumb at it but this latest problem has me baffled. I play WoW (World of Warcraft) and I have it already installed, including the latest expansions. I install the original WoW then the first expansion Burning Crusade. I get to lich king, because the dvd disc is hidden on Linux I copy all the files to a folder on my desktop. I run the installer from terminal using wine. The lich king screen comes up I click install and the next page is the EULA agreement. I just scroll to the bottom and press accept, however, the accept button is greyed out and I can't click agree.
So I do a little research and find out that I need to install a newer version of wine. I install a new version. I get all this done and get lich king installed with all the updates. I go ahead and set it to play in opengl, then I click the WoW icon on the desktop and the launcher looks a little different from what I remember. I click play and its just the original WoW, and burning crusade expansion installed.
I go to the wine directory and browse to the WoW folder, I search through it and to my surprise the lichking.mpq is nowhere to be found. I have an idea, I try running the lich king installer from the folder on my desktop using wine. The installer screen comes back up and instead of install it says play. I click play and the lich king launcher comes up. I click play once more and lich king boots up. I login and run around a bit and everything is fine. I log back out and I'm going to install 2 addons. I browse back to the WoW folder within the wine directory. I click on interface and normally it would have a folder that says Addons there, yet, it had nothing there. I tried creating my own and I installed the addon, needless to say the addon didn't work.
What I'm asking is there a way I can launch lich king with out opening terminal, running the installer for lich king, and so on? I know that lich king is in the folder because when I launch it in terminal it says it opens all the .mpq archives. I want to make this a little bit user friendly instead of all these extra steps.

Level 8
Level 8
Posts: 2281
Joined: Thu Feb 26, 2009 8:58 pm

Re: Lich King is hidden in my WoW folder

Postby emorrp1 » Sat Jul 11, 2009 6:29 am

Hello, and Welcome to Linux Mint! There sounds like there's a specific problem with lich king on linux, maybe someone on the wow linux forums has a solution. Seeing as you have a series of steps to bypass the issue though, the automation is actually quite easy, you need to create a shell script. To do this, you create a new (text) file called in your home folder and make this the first line:

Code: Select all


Then you put the commands you normally type into the terminal into this file, one per line. Once finished run this command:

Code: Select all

sudo mv ~/ /usr/bin/

You can then launch it using alt+f2 and type, you could even create a menu item for it if you prefer.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

Return to “Software & Applications”

Who is online

Users browsing this forum: WharfRat and 7 guests