Evolution Mail not connecting to Gmail or Hotmail

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
lsemmens
Level 11
Level 11
Posts: 3547
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Evolution Mail not connecting to Gmail or Hotmail

Post by lsemmens »

Evolution mail looks to be the bee's knee's as an Email client and PIM, however, it does not want to play nicely with Gmail and Hotmail accounts. I keep getting a popup asking me to authorise it connecting to my mail servers. When I click on that I get a "The reported error was “Failed to authenticate: OAuth2 secret not found" message on both accounts.
It obviously is a BIG secret as I cannot find anything remotely helpful in Mint 19. Is there a method to convince it to work, or am I going to have join the Secret Drum Corps to fix it? :D

Code: Select all

System:    Host: leigh-HP-ProBook-470-G2 Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Hewlett-Packard product: HP ProBook 470 G2 v: A3009DD10303 serial: N/A
           Mobo: Hewlett-Packard model: 2249 v: KBC Version 67.24 serial: N/A
           BIOS: Hewlett-Packard v: M74 Ver. 01.09 date: 01/26/2015
Battery    BAT0: charge: 46.9 Wh 100.0% condition: 46.9/46.9 Wh (100%)
           model: Hewlett-Packard Primary status: Full
CPU:       Dual core Intel Core i5-4210U (-MT-MCP-) 
           arch: Haswell rev.1 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9577
           clock speeds: max: 2700 MHz 1: 1228 MHz 2: 1424 MHz 3: 1367 MHz
           4: 1660 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Topaz PRO [Radeon R5 M255]
           bus-ID: 0a:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,ati,amdgpu (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 08:00.0
           IF: enp8s0 state: down mac: <filter>
           Card-2: Broadcom Limited BCM43228 802.11a/b/g/n
           driver: wl bus-ID: 09:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: 128.0GB (14.7% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 128.0GB
Partition: ID-1: / size: 117G used: 18G (16%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: 0.0C gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 246 Uptime: 2:32 Memory: 1893.8/7376.9MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Fully mint Household
Out of my mind - please leave a message
Joan_2018
Level 1
Level 1
Posts: 15
Joined: Sat Jan 12, 2019 5:51 pm
Location: Barcelona

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by Joan_2018 »

Hi,

I use Evolution because IMHO it's the best client for my needs, and a very close 'clone' of Outlook. I use it for mails on Gmail, and Gmx. For security reasons, at Gmx, we nee to enter on the config of the account and allow the 3rd party clients to operate with it. I do not remember if on gmail it's the same.
User avatar
philotux
Level 5
Level 5
Posts: 832
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by philotux »

Not sure if that is needed for Evolution but here it is:

For Gmail

1) Log in to https://myaccount.google.com
2) On the left > Security. Scroll down a bit and activate "Less secure app access"
User avatar
AndyMH
Level 13
Level 13
Posts: 4975
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by AndyMH »

On the left > Security. Scroll down a bit and activate "Less secure app access"
Don't use evolution for gmail (my email is hosted elsewhere), but I do use it for my calendar and to sync with evolution I did the same. Not sure you have to do that any more, but don't know how - it's how I set it up under LM18.3 so did the same in LM19.0.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
lsemmens
Level 11
Level 11
Posts: 3547
Joined: Wed Sep 10, 2014 9:07 pm
Location: Rural South Australia

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by lsemmens »

Bugga, I held out some hope, but no joy. All I get is "Requesting account token, please wait"
Fully mint Household
Out of my mind - please leave a message
User avatar
AndyMH
Level 13
Level 13
Posts: 4975
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by AndyMH »

Hmmm....

Thought I would add my gmail account to evolution and see what happens (just accepted all the defaults, window - mini web page - opened up asking for my gmail pwd)...
Inbox (150 unread) — Evolution_029.png
As you can see, looks like I got the same error message as you, but it didn't stop it reading my inbox, which as you can see is full of crap as I don't use gmail. Haven't tried to send anything.

May not help, at least you know it's not you :(

Edit - Quick google search, did you try this:

https://www.reddit.com/r/gnome/comments ... n_nowhere/
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Neil Darlow
Level 2
Level 2
Posts: 66
Joined: Fri Aug 03, 2018 5:17 am

Re: Evolution Mail not connecting to Gmail or Hotmail

Post by Neil Darlow »

When you create a Google account (in the Online Accounts settings) GMail should be configured in Evolution automatically for you. If you cannot authenticate to Google then check your Google account setup. It may indicate that the authentication token has expired.

Evolution certainly does work with GMail (I use it daily) and I can also manage my Contacts, Calendar and Tasks through it.
Linux Mint 19.3, Intel Core i5 8400 2.8GHz, ASUS Prime Z370-P, Corsair Vengeance 3400 16GB, ASUS Cerberus GTX1050 Ti, Samsung 970 Evo 500GB M.2, Western Digital Blue 4TB, Wircard RealTek 8821ae PCIe Wireless+Bluetooth 4.0, Pioneer BDR-209EBK BDRW.
Post Reply

Return to “Software & Applications”