Strange text input field behavior in FreeCAD

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
a.bowers
Level 2
Level 2
Posts: 54
Joined: Mon Nov 24, 2014 3:50 pm

Strange text input field behavior in FreeCAD

Post by a.bowers »

Running FreeCAD in LM 18.3 Cinnamon. In several places in it's UI, there are text windows that appear over other text windows. For example, when you go to add a length constraint to a line, it pops up a dialog that lets you type in a value, or you can click an f(x) button to type a Python expression in to bind it to another dimension elsewhere or a variable or whatever it doesn't matter. It doesn't cover or blank the already existing text, so the text you type is jumbled with the already existing text.

On the FreeCAD forum, someone says this is a Gnome issue, and that the solution is to enter Gnome Tweak Tools > Windows > disable "merge modal dialogs." I've looked through Cinnamon settings and found no such thing. How do I fix this?

User avatar
Flemur
Level 18
Level 18
Posts: 8465
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Strange text input field behavior in FreeCAD

Post by Flemur »

a.bowers wrote:
Sat Feb 02, 2019 12:31 pm
Running FreeCAD in LM 18.3 Cinnamon. In several places in it's UI, there are text windows that appear over other text windows. For example, when you go to add a length constraint to a line, it pops up a dialog that lets you type in a value, or you can click an f(x) button to type a Python expression in to bind it to another dimension elsewhere or a variable or whatever it doesn't matter. It doesn't cover or blank the already existing text, so the text you type is jumbled with the already existing text.

On the FreeCAD forum, someone says this is a Gnome issue, and that the solution is to enter Gnome Tweak Tools > Windows > disable "merge modal dialogs." I've looked through Cinnamon settings and found no such thing. How do I fix this?
I-net search
gnome "merge modal dialogs"
--> 1 result = the post on freecad forum; https://forum.freecadweb.org/viewtopic.php?t=32985

IOW, the setting isn't called "merge modal dialogs"


There are several linux file-open GUIs - on the same desktop - used by various programs; as a work-around, try triple-click to hi-light the whole text string, then delete.

Edit: it's
gnome-tweaks -> windows -> attach modal dialogs.
Last edited by Flemur on Sat Feb 02, 2019 12:51 pm, edited 1 time in total.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

a.bowers
Level 2
Level 2
Posts: 54
Joined: Mon Nov 24, 2014 3:50 pm

Re: Strange text input field behavior in FreeCAD

Post by a.bowers »

as a work-around, try triple-click to hi-light the whole text string, then delete.
No, they'd thought of that. It doesn't work because if that field is empty, they automatically put "mm" or "in" or whatever your default unit is in as a placeholder, so there's still layered text.

Post Reply

Return to “Software & Applications”