xrandr rotate not working correctly in Mint 19.x

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
kenH2000
Level 1
Level 1
Posts: 3
Joined: Sat Feb 09, 2019 2:12 pm

xrandr rotate not working correctly in Mint 19.x

Post by kenH2000 » Sat Feb 09, 2019 2:43 pm

Background:
To rotate the screen the following command is used:
xrandr --output HDMI-0 --rotate left
To rotate it back to normal:
xrandr --output HDMI-0 --rotate normal

In Mint 17.x, 18.x, this rotation works perfectly, and without any special command arguments, or modes.

When I try this in Mint 19.x, the screen is misplaced by several inches, and the mouse registration is occurring where the screen 'should' be. I've been using Mint since 13, and can usually web-search solutions, but have not found a solution to this problem yet. I've tried many variations xrandr, using --pos arguments and so on, but haven't found anything that corrects the problem.

More info on the problem:
The screen 'displacement' problem occurs both using the Mint live USB or a fully updated and installed version of Mint 19.x, on any hardware I have tried.

Hardware info:
PC - #1
lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)

PC - #2
lspci |grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880 [Radeon HD 4250]

I was surprised to find that the problem DOES NOT occur using the Ubuntu 18.04 live disc/USB (since Mint 19 is derived from Ubuntu bionic), so this problem is specific to Mint 19.x.

I'd appreciate if anyone has any insights, or can grab a live disc/USB and try in on your pc to see if you have the same problem, or can think of other things I can try to troubleshoot the problem.

kenH2000
Level 1
Level 1
Posts: 3
Joined: Sat Feb 09, 2019 2:12 pm

Re: xrandr rotate not working correctly in Mint 19.x

Post by kenH2000 » Sun Feb 17, 2019 2:54 pm

For anyone that has been affected by this problem, I've found a workaround. After some more research, I found that after the rotate, just the background is offset. As a workaround, if you run gsettings to change the background picture-options to something other than it already is, the image will 'right' itself on the screen. The following command outputs the current picture-options setting:

gsettings get org.mate.background picture-options
>>for example may show this>> 'wallpaper'

So, running these commands together will cause the picture to correctly orient itself after the rotation:

xrandr --output HDMI=0 --rotate left;gsettings set org.mate.background picture-options 'zoom'

--then to go back to normal--

xrandr --output HDMI=0 --rotate normal;gsettings set org.mate.background picture-options 'wallpaper'

Its not the most elegant solution, but it's something that can be used in a script to 'automatically' fix the screen after a rotate.

kenH2000
Level 1
Level 1
Posts: 3
Joined: Sat Feb 09, 2019 2:12 pm

Re: xrandr rotate not working correctly in Mint 19.x

Post by kenH2000 » Tue Feb 19, 2019 6:02 pm

I was able to eliminate this problem altogether by not using Compton as the compositor.

Set back to default:
Control Center>Desktop Settings>Windows>Window Manager>Marco + Compositing,
then restart lightdm:
sudo service lightdm restart

I was using Marco because it eliminated video tearing. I eliminated video tearing by adding the file 20-radeon.conf in /usr/share/X11/xorg.conf.d/ with these contents:

Section "Device"
Identifier "Radeon"
Driver "radeon"
Option "TearFree" "on"
Option "DRI" "3"
Option "AccelMethod" "glamor"
EndSection

Thanks to everyone that read my posts.

Post Reply

Return to “Software & Applications”