Various problems with CAJA

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 1:17 pm

Is it possible that changing the processing priority of CAJA in system monitor
from normal to a higher priority setting could solve the various problems with
CAJA as described at the following link ?

https://github.com/mate-desktop/caja/issues/380

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Tue Feb 12, 2019 1:30 pm

The link says it's fixed? Upgrade your system is you're still on LM17.x

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 2:02 pm

gm10 wrote:
Tue Feb 12, 2019 1:30 pm
The link says it's fixed? Upgrade your system is you're still on LM17.x
Must not be fixed because these problems still occur and I am already on Mint 19.1 !!!

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Tue Feb 12, 2019 2:10 pm

Fair enough. I never experienced it but I'm not a huge caja user, either. From a quick scan of the issue thread it seems to be limited to networked file systems? If you've got additional info from your system maybe add it to the thread, the last relevant activity in there was saying it's fixed in LM18 and the confirmed reports were only from LM17.

Anyway, back to your original question, I can fairly confidently say that the caja process priority likely won't have any bearing on this, this issue will be in code.

PS: Or simply install another file browser like Nemo.

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 3:10 pm

gm10 wrote:
Tue Feb 12, 2019 2:10 pm
Fair enough. I never experienced it but I'm not a huge caja user, either. From a quick scan of the issue thread it seems to be limited to networked file systems? If you've got additional info from your system maybe add it to the thread, the last relevant activity in there was saying it's fixed in LM18 and the confirmed reports were only from LM17.

Anyway, back to your original question, I can fairly confidently say that the caja process priority likely won't have any bearing on this, this issue will be in code.

PS: Or simply install another file browser like Nemo.
Is Nemo compatible with Mate ? Is Nautilus compatible with Mate ?

This problem occurred this morning when I was copying folders and file contents from my /home to a USB thumb drive.
It occurred when I dragged my ISO folder which has the 19.1 mate image and the sumcheck files for the image in it.
That image is fairly large (2gb). It hung during the copying of the image to the USB thumb drive. The sumcheck files
never got to the point of being copied. (the thumb drive had plenty of space on it - because when I went back and
attempted the copying again (this time leaving the ISO folder and its contents out), the thumb drive still had 13gb of
space left over after copying everything else in /home.

Are these copying problems perhaps somehow related to the size of the files that are attempted to be copied ?

Thanks.

P.S. - I just tried copying the ISO folder again - to a different thumb drive. It did the same thing, copied the ISO image and
then never copied the 2 sumcheck files, stuck at that point. Is there some reason that it is not supposed to be able
to copy those sumcheck files ?

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Tue Feb 12, 2019 3:31 pm

Yes, you can use any file browser you want. And I can copy several gigabyte sized files without problems to thumb drives with caja on 19.1, so I really don't know what's happening.

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 3:50 pm

gm10 wrote:
Tue Feb 12, 2019 3:31 pm
Yes, you can use any file browser you want. And I can copy several gigabyte sized files without problems to thumb drives with caja on 19.1, so I really don't know what's happening.
Hmmmmmmmm, looks like there is something incompatibility with copying those sumcheck files, because I have tried it
several times, and that always seems to be where the problem occurs.

If there is some incompatibility in copying those files from one place to another, seems that a warning would be given about
this on the instructions that are given for the sumcheck procedures or did I miss that warning ?

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Tue Feb 12, 2019 5:41 pm

wpshooter wrote:
Tue Feb 12, 2019 3:50 pm
If there is some incompatibility in copying those files from one place to another, seems that a warning would be given about
this on the instructions that are given for the sumcheck procedures or did I miss that warning ?
There is no such thing, I can copy them along with the .isos without issues, I've done it many times and I just tried again just to be sure. I don't know what your very specific issue is but you should discuss it with the MATE team - but only AFTER trying another file browser first (because it's very well possible it's a hardware or kernel issue in your case and doesn't have anything to do with caja at all).

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 7:15 pm

Tried Nautilus and had same problem.

It seems that for some reason it is not being able to move from copying the actual ISO image and
moving on to copying the 2 sumcheck files.

However, I just tried doing the copying separately on the ISO and the 2 sumcheck files instead of
dragging the entire ISO folder and it copied all 3 just fine.

Also, I inserted a USB hard drive and it copied all 3 files just fine no problem by just dragging the ISO folder which included its 3 files over to it.

Do you think this may just be a problem with copying to this particular brand (Samsung) usb thumb drive ?
I don't have any others (that are not being used) right now that are big enough to try but will resume testing when I do.

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Tue Feb 12, 2019 8:41 pm

If copying to the USB HDD works but to the USB flash drive fails then yes, it might very well be the flash drive, although it's curious that you can copy the files individually, just not jointly. I have no answer for you, I haven't run into this problem yet. I'd start with re-formatting or even re-partitioning the flash drive and running a disk check on it (you can do both from within the Disks tool).

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 10:09 pm

Disk check utility reported problem with the USB drive, however the repair function of disk utility gave this:

Error repairing filesystem on /dev/sdb1: Process reported exit code 1:fsck fat 4.1 (2017-01-24) (udisks-error-quark,0)

I then went into gparted and it reported that it successfully repaired the FAT.

However, on again trying the copy operation, it copied only the ISO folder, the ISO image but NOT either of the other 2 files. Again, CAJA reported as not properly finished operation.

Really strange, I have no ideas as what to try next. What really baffles me is that this works just fine to the USB hard drive.
Am going to try copying this to some other USB thumb drives as soon as I can get some with sufficient size.

Thanks.

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Tue Feb 12, 2019 10:18 pm

I found this on another website regarding the quark, 0 error message:

A weird solution that worked for me where GParted did not, was to format it using Mac OS X's Disk Utility initially (not the file system I ultimately wanted). Then I was able to format it on Ubuntu to NTFS which is what I wanted, and didn't encounter any timeout.

wpshooter
Level 5
Level 5
Posts: 694
Joined: Sun May 22, 2011 8:06 am

Re: Various problems with CAJA

Post by wpshooter » Wed Feb 13, 2019 10:29 am

Finally found the solution - just WAIT.

Downloaded another copy of the ISO image from Linux Mint download site and
again started the copy process from its folder and this time when it got down
to the zero seconds left on the copy process window, I just went away and
worked on a household project for about 20 minutes and when I came back
to the computer, the copy window had properly closed and the copy was
successful. So, for some reason it just takes an inordinate amount of time
for the VERY FINAL part of the copy process to finish and the copy procedure
window to close !!!

Don't seem to have this problem though when copying anything other than
the ISO image(s).

Thanks.

gm10
Level 16
Level 16
Posts: 6261
Joined: Thu Jun 21, 2018 5:11 pm

Re: Various problems with CAJA

Post by gm10 » Wed Feb 13, 2019 11:44 am

Sounds like it may just be a slow USB stick. If you do individual files it probably closes the popup faster because of write caching masking the slow write speed, but when doing multiple files it's waiting for confirmation from the previous one probably. At least that's my very rough guess without having looked at any of the code (so it may be complete nonsense ;)).

Post Reply

Return to “Software & Applications”