VLC control bar erratic behaviour in full screen

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Halbarad
Level 1
Level 1
Posts: 28
Joined: Tue Feb 05, 2019 2:30 pm

VLC control bar erratic behaviour in full screen

Post by Halbarad »

Hi, I have Mint 19.1 Tessa and Lubuntu 18.04 in dual boot. When I start VLC in full screen mode the control bar should show up when I move the mouse. In Mint it does not: it sometimes appears if I keep moving the mouse for a while but its behaviour is quite erratic. If I move the cursor where the control bar should be, little bubbles with a time indication appear and the (invisible) bar is responsive: when I click on it, the video skips to the position indicated in the bubble, but the bar remains invisible (most of the times). If the control bar appears and I move the cursor on it, it stays put until I move the cursor away.

The same VLC version (3.0.4 Vetinari) is installed in Lubuntu on the same machine and the control bar works well in full screen, VLC settings are the same as in Mint -- basically, no changes from the default settings. I guess that the problem has to do with Mint's way of handling video streams but I am not an expert about video handling and I wonder whether anyone has an idea about what to tweak in order to solve this.

Graphics card: VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])

This is the output of inxi -Fxz:

Code: Select all

System:
  Host: axel-HP-250-G3-Notebook-PC Kernel: 4.15.0-45-generic x86_64 
  bits: 64 compiler: gcc v: 7.3.0 Desktop: MATE 1.20.1 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 250 G3 Notebook PC 
  v: 0991100000000000000600087 serial: <filter> 
  Mobo: Hewlett-Packard model: 2211 v: 86.49 serial: <filter> UEFI: Insyde 
  v: F.36 date: 12/18/2014 
Battery:
  ID-1: BAT1 charge: 27.8 Wh condition: 27.8/27.8 Wh (100%) 
  model: 11-85 OA03031 status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19154 
  Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 798 2: 799 
  3: 798 4: 798 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.2 
  direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-45-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 08:00.0 
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe 
  vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 3000 
  bus ID: 09:00.0 
  IF: wlp9s0f0 state: up mac: <filter> 
Drives:
  Local Storage: total: 931.52 GiB used: 239.60 GiB (25.7%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  ID-2: /dev/sdb type: USB model: ATA ST500LT012-1DG14 size: 465.76 GiB 
Partition:
  ID-1: / size: 91.17 GiB used: 36.98 GiB (40.6%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: 52.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 179 Uptime: 9m Memory: 7.72 GiB used: 1.10 GiB (14.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
What I have tried:
- I installed libvdpau-va-gl1 (i965-va-driver is already installed) and uncommented the last two lines in /etc/X11/Xsession.d/20vdpau-va-gl; reboot. This solved nothing and I restored the system to the previous state.
- I deleted the dir ~/.config/vlc.
- In ~/.config/vlc/vlc-qt-interface.conf I changed the values in pos=@Point(285 604) in the Fullscreen section.
None of the above helped. If you can figure out something, just tell me... Thanks!
Halbarad
Level 1
Level 1
Posts: 28
Joined: Tue Feb 05, 2019 2:30 pm

Re: VLC control bar erratic behaviour in full screen

Post by Halbarad »

Update: I have "discovered" a difference between the Lubuntu and the Mint VLC: the control bar is in solid colour in the Lubuntu version and it is partly transparent in the Mint version (that is, when it appears at all). I am going to investigate this a bit more. By the way, does anyone have a similar problem with Mint VLC?
User avatar
MrEen
Level 21
Level 21
Posts: 13267
Joined: Mon Jun 12, 2017 8:39 pm

Re: VLC control bar erratic behaviour in full screen

Post by MrEen »

Hi Halbarad.

I just noticed something similar using 18.3 Xfce. A workaround I just found was to click on Video > Fullscreen (Video > Always Fit Window was automatically selected)

Does that help?
Halbarad
Level 1
Level 1
Posts: 28
Joined: Tue Feb 05, 2019 2:30 pm

Re: VLC control bar erratic behaviour in full screen

Post by Halbarad »

MrEen wrote:
Sat Feb 23, 2019 2:30 pm
I just noticed something similar using 18.3 Xfce. A workaround I just found was to click on Video > Fullscreen (Video > Always Fit Window was automatically selected)
Does that help?
I regret it does not, VLC behaves just the same way.
By the way, I also found out how to turn off transparency in the control bar: Tools / Preferences / All / Interface / Main Interfaces / Qt / Fullscreen controller opacity; setting it to 1 made the control bar show up in solid colour but didn't fix the issue.
Post Reply

Return to “Software & Applications”