PowerDown does not complete to BIOS shutdown

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Mon Apr 08, 2019 10:29 am

some times it will, some times it won't.
it is a crap shoot, and I can't figure out why?

all is stable, I always close out running applications before selecting 'Shutdown' by menu.

here is what shows on the screen when the process does not result in a full BIOS power off.



Image


Code: Select all

 $ inxi -Fzxd
System:    Host: john-TP500LA Kernel: 4.15.0-46-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: TP500LA v: 1.0
           Mobo: ASUSTeK model: TP500LA v: 1.0 Bios: American Megatrends v: TP500LA.203 date: 06/11/2014
CPU:       Dual core Intel Core i3-4030U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7582
           clock speeds: max: 1800 MHz 1: 1795 MHz 2: 1795 MHz 3: 1796 MHz 4: 1795 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1360x768@59.80hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-46-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.1
           IF: enp2s0f1 state: down mac: <filter>
           Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter
           driver: mt7630e v: 2.3.8
2.3.8
2.3.8
2.3.8
2.3.8
2.3.8 bus-ID: 03:00.0
           IF: wlp3s0f0 state: down mac: <filter>
           Card-3: Ralink RT5372 Wireless Adapter driver: rt2800usb v: 2.3.0 usb-ID: 001-005
           IF: wlx9cefd5fd2968 state: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (54.0% used) ID-1: /dev/sda model: Samsung_SSD_860 size: 500.1GB
           ID-2: /dev/mmcblk0 model: N/A size: 15.8GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 28G used: 9.4G (37%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 164G used: 117G (75%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 0.01GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2600
Info:      Processes: 213 Uptime: 10 min Memory: 1254.4/11893.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
john@john-TP500LA ~ $ 

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: PowerDown does not complete to BIOS shutdown

Post by kevin987 » Mon Apr 08, 2019 11:59 pm

If this problem just started recently, perhaps it has something to do with the 4.15.0-46 kernel.

There's a 4.15.0-47 kernel available. I noticed the 46 kernel wasn't the latest available for very long, so perhaps it had some issues addressed with 47.

Go back to 45 if 47 doesn't correct it?
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

pbear
Level 6
Level 6
Posts: 1471
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: PowerDown does not complete to BIOS shutdown

Post by pbear » Tue Apr 09, 2019 1:53 pm

FWIW, I notice someone with a similar problem in this thread.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Tue Apr 09, 2019 10:34 pm

nope,
not the kernel, it has been plaguing me for a year or more.
just haven't said much about it.

surely there ought to be a way to figure out what is going on?

using the BIOS shutdown to power off is not my idea of fun, it sometimes scrambles things.
had to rebuild this laptop about 3 weeks ago after once such bad shutdown.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Tue Apr 09, 2019 10:47 pm

pbear wrote:
Tue Apr 09, 2019 1:53 pm
FWIW, I notice someone with a similar problem in this thread.
I would be more interested in that guy's results after he runs that new kernel for a few shutdowns in a row.
I noticed that someone referenced this thread in that thread for the same problem. I would be very happy if it were just a simple "wrong kernel" situation that could be fixed.

the active kernel has never had any effect on the shutdown, for more than a year now.
in fact, I just now looked for a new kernel, and installed the latest one. 4.15.0-47

.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Tue Apr 09, 2019 11:06 pm

Interesting results with that last kernel install.

I just went through 20+ consecutive Powerdown, and restart sequences.
all went normal like it should.

I am not counting this as completely healed, it will have to go thru a few days of being shutdown overnight, and then a few power up/dn sequences over the next few days....

2 years ago, when I first installed 18.3 Cinnamon, it worked as it should....
then somewhere around a year ago, this powerdown problem reared its' head, and has been a real bad deal for me, as it has caused file corruption a few times, with an image overwrite to fix it, or a fresh install which is what I had to do 2 weeks ago while on vacation away from home, and none of my image drives were with me.... argh!!!

but, fortunately, my backup Aptik files are stored on a separate partition on this same drive.
so a fresh install was not all that painful.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Wed Apr 10, 2019 12:11 pm

04/10/2019 11:03

I just went thru several full Shutdown commands, and powered back on.
let Grub timeout to boot up, and used <enter key> a couple of times to see if that had any effect?

in each instance, power on was normal, and Shutdown succeeded in fully powering off the laptop which is a ASUS TP500L

Looking back historically, I can only surmise that the base kernel developed a bug about a year ago, and that it has a negative effect on selected models of PCs.... as is evidenced by the other thread which was referenced in this thread.

I am going to leave this topic open for a week to build up more history on this problem.....
if a week goes by, and failure to Power OFF never occurs again, I will then report this thread 'Solved'

.

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Wed Apr 10, 2019 3:57 pm

04/10/2019 14:56

Well crap, that didn't last very long.

IT HAS ZERO TO DO WITH THE KERNEL

just tried to power down for the day, and it stopped at the same place, just like always



Image

User avatar
AZgl1500
Level 10
Level 10
Posts: 3437
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: PowerDown does not complete to BIOS shutdown

Post by AZgl1500 » Sat Apr 13, 2019 6:28 pm

Been a few days, anyone have any suggestions?


it is doing this more often, than it will actually shut down.....
closing the lid and leaving it on isn't working so well either, the WiFi looses the drivers for some reason.??

so, I end up having to shut it down, and restart.....

don't ever dare to use Restart as that will NOT give a visible view of the situation, you are left with a blank screen.... so if you have to force it off with BIOS power button, where is the OS at?

safe to power off?
I scrambled the file structure badly once with Restart.... never again.

Post Reply

Return to “Software & Applications”