Language setting Firefox (and Chrome) still not automatic

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
crlMIDI
Level 1
Level 1
Posts: 6
Joined: Mon May 09, 2016 12:34 pm

Language setting Firefox (and Chrome) still not automatic

Post by crlMIDI »

We run a free walk-in computer repair service for a local association in France, and install Cinnamon or xfce on older Windows machines - taking care first to rescue the family photos.

A big though very long-standing problem for non-English speakers is that Firefox always starts in English. There are work-arounds scattered around the web, but they seem to be different every time, and we just don't have the time. The worst feature is that the language plugin package doesn't track Firefox updates and so the browser soon goes back to English. Someone suggested we try Chrome, but that installed itself in English too.

This may seem a minor problem, but in our situation it turns out to be the main obstacle to getting Linux accepted, even by people who like experimenting. I know we should no longer think of Linux only as a means of saving old machines, but those we try to help can't afford to buy a new one.

Please could an expert on the subject review the situation, and if possible propose a permanent or at least reliable solution?

User avatar
Lord Boltar
Level 5
Level 5
Posts: 688
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Language setting Firefox (and Chrome) still not automatic

Post by Lord Boltar »

Download the language you want for Firefox from here

https://www.mozilla.org/en-US/firefox/all/

once download uninstall the version that is in your machine then install the one you download

should not have any more issues - then if you want you can use a program like Pinguy Builder to rebuild the OS with the new browser in it so it will install that by default and then you can install that on any machine
If you didn't uninstall the previous Firefox version in the wrong language then you need to change the pref general.useragent.locale to the name of the preferred language XPI file (e.g. "en-US" or "en-GB") on the about:config page.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

Post Reply

Return to “Software & Applications”