[Solved - sort of] kernel 4.15.0-48 won't shutdown (CInnamon 19.1)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
WiltshireJon
Level 2
Level 2
Posts: 54
Joined: Wed Nov 15, 2017 1:14 pm

[Solved - sort of] kernel 4.15.0-48 won't shutdown (CInnamon 19.1)

Post by WiltshireJon » Wed May 01, 2019 5:22 am

As it says in the title. Since updating to the -48 kernel my laptop won't shutdown. If I go to the menu and try shutdown from there it starts to shutdown (very briefly) then almost immediately takes me to the login screen - the one you get when you initially boot up from complete shutdown. Top right of this screen is a shutdown button - clicking on this brings up options to quit and something-else-I've-forgotten; clicking on the quit option does nothing, dead button. Can shutdown from terminal "REISU0".

This is a new fault to me and doesn't happen on earlier kernels...I'm currently using -47 which works as advertised. Up to now the laptop has been rock solid since installing 19.1. Marked as solved as reverting to an older kernel fixes the issue.

Code: Select all

jon@jon-zenbook:~$ inxi -Fxz
System:
  Host: jon-zenbook Kernel: 4.15.0-48-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: ASUSTeK product: UX360UA v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: UX360UA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX360UA.300 date: 06/17/2016 
Battery:
  ID-1: BAT0 charge: 44.8 Wh condition: 44.8/57.1 Wh (78%) 
  model: ASUSTeK ASUS Battery status: Not charging 
CPU:
  Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200 
  Speed: 500 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 3200x1800~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.15.0-48-generic 
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 
  bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 69.79 GiB (14.6%) 
  ID-1: /dev/sda vendor: SK Hynix model: HFS512G39MND-3510A size: 476.94 GiB 
Partition:
  ID-1: / size: 459.93 GiB used: 69.76 GiB (15.2%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 7.90 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3100 
Info:
  Processes: 200 Uptime: 8m Memory: 7.69 GiB used: 969.8 MiB (12.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 

deepakdeshp
Level 15
Level 15
Posts: 5818
Joined: Sun Aug 09, 2015 10:00 am

Re: [Solved - sort of] kernel 4.15.0-48 won't shutdown (CInnamon 19.1)

Post by deepakdeshp » Mon May 06, 2019 3:29 am

You can remove the .48 kernel so that .47 will be the only installed kernel and can boot as default without the need to choose from multiple kernels.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Software & Applications”