Running Java app: LM18.3 is ok, LM19 doesn't run it?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 23
Joined: Fri Apr 06, 2018 5:54 pm
Location: England

Running Java app: LM18.3 is ok, LM19 doesn't run it?

Post by taxedserf »

I'm struggling to run a Java app, ProReal Time ( in Linux.

On one machine - Windows 10 running Virtual Box in which Linux Mint 18.3 Xfce runs - the app worked perfectly first time. Just like it did (and always has done) in Windows. No requirement for the user to fiddle with subsidiary apps, or file permissions or anything like that. Superb. Mission accomplished.

One a different machine - Windows 10 running Virtual Box in which Linux Mint 19 Xfce runs - the app simply doesn't run. See "Mechanics" below for details.

In both instances of Linux Mint, the basic user config is the same, i.e. the non-admin user wants to run this Java app. The browser in both cases is Chromium.

Is there a checklist of dependencies for a normal user (not a techno geek!) to check whether the Linux instance is correctly configured?

This relates to the instance in which ProRealTime doesn't work.
  • ProRealTime downloads a jnlp file, which the (non-admin) user needs to chmod oug+x.
  • Although the website intends to run the program directly (in Windows and in the Linux instance that works), in this instance the user needs to use Thunar to right-click and open with Iced Team web start.
  • The program then appears to launch normally, but then ends up with a java dialogue box as below:
    The details are:

    Code: Select all

    net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file. The application has not been initialized, for more information execute javaws/browser from the command line and send a bug report.
    	at net.sourceforge.jnlp.Launcher.launchApplication(
    	at net.sourceforge.jnlp.Launcher$
    Caused by: java.lang.reflect.InvocationTargetException
    	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
    	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
    	at java.base/java.lang.reflect.Method.invoke(
    	at net.sourceforge.jnlp.Launcher.launchApplication(
    	... 1 more
    Caused by: java.lang.NoSuchMethodError: java.lang.SecurityManager.checkTopLevelWindow(Ljava/lang/Object;)Z
    	at obs.wG.mT(obs:1800)
    	at obs.wG.<init>(obs:688)
    	at com.itfinance.core.Starter.nM(obs:201)
    	at com.itfinance.core.Starter.startAppli(obs:530)
    	at com.itfinance.core.Starter.main(obs:165)
    	... 6 more
  • when attempting to launch the browser - terminal > javaws -browser - the following error appears:
    Screenshot_2019-05-16_13-51-25.png (7.23 KiB) Viewed 374 times
    ... subsequent to which a browser appears, but is functionally useless.
  • then I have no idea what to do next!
I have raised a query with ProRealTime, but they have yet to acknowledge the query. Even so, my instincts tell me there is (a) config issue(s) in this instance of LM19Xfce which I don't know how to audit.
Martin the Taxed Serf, an English Accountant
User avatar
Lord Boltar
Level 5
Level 5
Posts: 811
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Running Java app: LM18.3 is ok, LM19 doesn't run it?

Post by Lord Boltar »

You can try to disable the Java Security check by running

Code: Select all

javaws -nosecurity main.jnlp
hope this helps
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing
Post Reply

Return to “Software & Applications”