Page 1 of 1

Firejail javaldx

Posted: Fri May 17, 2019 4:45 pm
by baker
When running librewriter from the command prompt I receive the error message failed to launch javaldx. The javaldx file is located in the following directory on my pc usr/lib/libreoffice/program. I am running mint tara 32 bit with cinnamon desktop application. If I try and run same program from the firetool util nothing happens. I am able to run Firefox etc either from the cmd prompt or the firetool utility.

$ firejail lowriter
Reading profile /etc/firejail/lowriter.profile
Reading profile /etc/firejail/libreoffice.profile
Reading profile /etc/firejail/
Reading profile /etc/firejail/
Reading profile /etc/firejail/
Reading profile /etc/firejail/
Reading profile /etc/firejail/
Parent pid 4948, child pid 4949
Warning fseccomp: --protocol not supported on this platform
Blacklist violations are logged to syslog
Child process initialized in 163.62 ms
Warning: failed to launch javaldx - java may not function correctly
ERROR 4 forking process

$ firejail --version
firejail version

$ libreoffice --version
LibreOffice 00m0(Build:3)
Any help will be much approeciated
Blue Baker

Re: Firejail javaldx

Posted: Sat May 18, 2019 3:47 am
by slipstick
That sounds somewhat like a problem I have on LM18.3, Cinnamon with firejail - I couldn't launch xed, xreader, or xplayer from the gui (don't recall what happened if I tried to launch from the terminal, or if I ever tried). I finally resorted to a workaround by disabling the symlinks xed, xreader, and xplayer in /usr/local/bin. I just changed the name of each of those links; for example to xed_xxx. Not a solution, but an easy workaround. You could try the same with lowriter.