Thunderbird authentication

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Thunderbird authentication

Post by administrollaattori » Mon Jun 10, 2019 2:22 pm

greerd wrote:
Mon Jun 10, 2019 2:15 pm
I think you're going to have to log into your google account and relax the security for third party mail clients. I'll see if I can find out what I did when I get home later on today.
Or easier rename .thunderbird folder like .thunderbird.orig and make Thunderbird working with OAuth2
https://developers.google.com/gmail/api/auth/about-auth

User avatar
OveS
Level 2
Level 2
Posts: 80
Joined: Fri Jan 01, 2016 3:26 pm
Location: France

Re: Thunderbird authentication

Post by OveS » Mon Jun 10, 2019 3:43 pm

Go to myaccount.google.com and enable access for "less secure applications"

https://support.google.com/accounts/answer/6010255?hl
--
Ideapad 530S-14ARR - Linux Mint 19.2 Cinnamon, Thinkpad X240 - Linux Mint 19.2 Cinnamon,
MacBook Pro 15" (mid-2010), iMac 20" (early-2008), Raspberry Pi 2, 3 and 4

User avatar
greerd
Level 6
Level 6
Posts: 1056
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Thunderbird authentication

Post by greerd » Mon Jun 10, 2019 3:49 pm

OveS wrote:
Mon Jun 10, 2019 3:43 pm
Go to myaccount.google.com and enable access for "less secure applications"

https://support.google.com/accounts/ans ... 0255?hl=en

Terveisin
Cool, saves me looking it up! Although @Administrollaattori's suggestion is most likely more secure.

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Tue Jun 11, 2019 1:59 pm

Ok, when I set it to less secure I am getting

An error occurred with the POP3 mail server. Mail server imap.gmail.com responded.
I my google account I have disabled pop and enabled imap.
On my client I have set outgoing server to smtp and incoming to imap.

siawacsh

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 3:57 pm

OK, so since there have been no further bits of advice I guess I am going to have to go for the upgrade. Sorry Admin I tried to read the manual but it is all about editing scripts which is over my head. My thunderbird does not have 0Auth2 option. Doing it on the server side (gmail portal) was not all that clear.

I just read throught the Mint 19.1 release notes and see they mention problems with scanners. I have a Cannon Lide 200. Does any one know if there are any issues with that.? Also am I having to install the nvidia drivers via compatibility mode or will the installer do it by default.?

If there are too many bugs I might just reinstall 18.3.
And what alternatives to thunderbird would people recommend here that can allow me to copy over all the subdirectory sturcture I have in thunderbird.

siawacsh

LogMan
Level 2
Level 2
Posts: 55
Joined: Thu Apr 06, 2017 8:57 pm

Re: Thunderbird authentication

Post by LogMan » Wed Jun 12, 2019 4:55 pm

siawacsh wrote:
Wed Jun 12, 2019 3:57 pm
My thunderbird does not have 0Auth2 option. siawacsh
I have 0Auth2 in my Tbird under Preferences/Account Settings/Server Settings/Security Settings

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 5:02 pm

I think you may be using a different version. Mine does not have preferences. Just server settings. Unfortunately the forum wont let me upload the screenshots. Says they are too large. The drop down does not have that protocol

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 5:04 pm

Funny thing is that loosening up the security has not helped at all. I am wondering if try to use evolution would I be able to migrate my backup emails .thunderbird into it?

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 5:23 pm

I managed to compress the screenshots. As you can see the drop down selector does not show the protocol you mention.
Attachments
outgoing.jpg
incoming.jpg

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 5:40 pm

I just tried Evolution and see that it cannot authenticate either. The difference being that there is no specific error message. It just keeps asking me for my gmail password. When I put it in and click OK the same dialog box pops up with a blank password field.

LogMan
Level 2
Level 2
Posts: 55
Joined: Thu Apr 06, 2017 8:57 pm

Re: Thunderbird authentication

Post by LogMan » Wed Jun 12, 2019 6:08 pm

So what version of Tbird are you using ?

Like I said earlier, mine is 60.7.0 (64 bit)

You seem to be missing 2 items under that drop down menu, 0Auth2 and TLS Certificate, so looks like you have a different version.

I know Gmail requires 0Auth2, has for quite a while.

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Wed Jun 12, 2019 7:59 pm

It also says 60.7.0 (64 bit)

And it has worked just fine all these past seven years.

LogMan
Level 2
Level 2
Posts: 55
Joined: Thu Apr 06, 2017 8:57 pm

Re: Thunderbird authentication

Post by LogMan » Wed Jun 12, 2019 11:28 pm

Bizarre :roll:

Can't think of anything else except to try and reinstall T'Bird

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Thu Jun 13, 2019 6:31 am

I left .thunderbird folder as it was and reinstalled Tbird. Nothing changed.

siawacsh

User avatar
OveS
Level 2
Level 2
Posts: 80
Joined: Fri Jan 01, 2016 3:26 pm
Location: France

Re: Thunderbird authentication

Post by OveS » Sat Jun 15, 2019 4:59 pm

Maybe the problem is that in order to see OAuth2 in Thunderbird, the server connection (Server Type at the top of the screenshot) must be set to IMAP. If it's POP, the OAuth2 does not show up in the list of options.
And as far as I can remember, you cannot edit an existing POP3 setup into IMAP, you have to recreate the account as IMAP.
--
Ideapad 530S-14ARR - Linux Mint 19.2 Cinnamon, Thinkpad X240 - Linux Mint 19.2 Cinnamon,
MacBook Pro 15" (mid-2010), iMac 20" (early-2008), Raspberry Pi 2, 3 and 4

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Sat Jun 15, 2019 6:26 pm

Thanks I am still struggling with this. No idea why I started in the first place. I actually removed the account and recreated a new one with imap settings. It started download and syncing with all my historic mails. 4K in all. But it would not send anything. Crucially I have not been able to recreate and restore my data in the same three structure I have had originally. In the past when I would upgrade my OS, all I had to do was to backup the .thunderbird folder and paste it into default .thunderbird folder on the new system and my data was back up and running. Now I can get the data back up but not able to send. I removed that account and am left with the original one with the data. That one is set to pop.

Anyway, when you say you have to create as imap are you talking about at the server end or the client.? Right now I have enabled gmail account at the server to both imap and pop3.

Siawacsh

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Sat Jun 15, 2019 6:49 pm

I tried it again. I disabled pop at the server. Changed pop to imap with the usual port number above. And ended up getting same error "password not accepted"... And there is no option for 0Auth2.

But when I create a new account I see the 0Auth2 option. It downloads but wont send. Only incoming server has the 0Auth2. The outgoing smtp is limited to SSL/TLS.

Crucially, I do not know how to restore my data on it. If copied and pasted the backed up .thuderbird will it bring it up? I don't think a .thunderbird with pop settings (original set up which has served me for seven years) will work with an imap setup. Therefore if imap means I am going to have to recreate my data structure from scratch I rather stay with pop3.

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Sat Jun 15, 2019 6:56 pm

BTW when I say it wont send, it is without any errors. It just shows a dialog box saying sending. But it is there forever not doing anything.

Siawacsh

User avatar
OveS
Level 2
Level 2
Posts: 80
Joined: Fri Jan 01, 2016 3:26 pm
Location: France

Re: Thunderbird authentication

Post by OveS » Sun Jun 16, 2019 4:32 am

I found this short article that might help: https://www.supertechcrew.com/thunderbird-oauth2-gmail/

It's a very long time since I did that. But I remember I had the POP account set to retrieve mail form server and then delete the server copy. So all mail was locally stored. In Thunderbird, I stopped the POP account from retrieving mail and then I dragged the folders and dropped them under the newly setup IMAP account, one folder at a time.
--
Ideapad 530S-14ARR - Linux Mint 19.2 Cinnamon, Thinkpad X240 - Linux Mint 19.2 Cinnamon,
MacBook Pro 15" (mid-2010), iMac 20" (early-2008), Raspberry Pi 2, 3 and 4

siawacsh
Level 3
Level 3
Posts: 160
Joined: Fri Sep 06, 2013 9:32 am
Location: Ireland

Re: Thunderbird authentication

Post by siawacsh » Sun Jun 16, 2019 7:54 pm

Hello, I need to reiterated, only when I create a new account on the client with imap setting do I see an option for 0Auth2. And even then that option is limited to the incoming server. Outgoing still is limited to SSL/TLS, STARTLS and none.

The original account which also has been switched from pop to imap has no 0Auth2. But has SSL/TLS, STARTLS and none.

At the server I have imap enabled. I went ahead and deleted saved passwords as per that tutorial. That is where it stands at the moment.

siawacsh

Post Reply

Return to “Software & Applications”