Volume icon has disappeared

Questions about applications and software
Forum rules
Before you post please read how to get help
KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Volume icon has disappeared

Post by KIMW » Wed Jun 12, 2019 5:08 am

The volume icon has disappeared and instead I have this:
Screenshot_20190612_100438.png
Screenshot_20190612_100438.png (11.65 KiB) Viewed 425 times
Any ideas why?
Last edited by KIMW on Fri Jun 21, 2019 1:58 pm, edited 2 times in total.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: volume icon has disappeared

Post by sleeper12 » Wed Jun 12, 2019 4:13 pm

Unless I'm wrong, it seems you need to install org.kde.plasma.private.volume. I'm not certain how to do that, but you might try:

Code: Select all

 sudo apt-get update && sudo apt-get upgrade 

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: volume icon has disappeared

Post by KIMW » Wed Jun 12, 2019 4:31 pm

What you've suggested did not do anything.
Thanks anyway for your help sleeper12.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: volume icon has disappeared

Post by sleeper12 » Wed Jun 12, 2019 9:11 pm

Ok, someone else should know how to install that if indeed that's what is needed.

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: volume icon has disappeared

Post by MrEen » Wed Jun 12, 2019 9:24 pm

Hi KIMW.

Presumably you tried to install the Win7 Volume mixer?

I found someone that had the same issue on Manjaro here: https://forum.manjaro.org/t/attempting- ... io/52298/4

For installing plasma.pa you'd use apt install plasma.pa

Hope that helps.

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: volume icon has disappeared

Post by KIMW » Thu Jun 13, 2019 2:44 am

Thanks MrEen.
I did what you've suggested and apparently I have broken packages.
Reading state information... Done
Note, selecting 'plasma-pa' for regex 'plasma.pa'
Note, selecting 'plasma-pa-dbg' for regex 'plasma.pa'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
plasma-pa-dbg : Depends: plasma-pa (= 4:5.5.5-0ubuntu1) but 4:5.8.9-0ubuntu1~ubuntu16.04~ppa1 is to be installed
E: Unable to correct problems, you have held broken packages.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: volume icon has disappeared

Post by MrEen » Thu Jun 13, 2019 7:01 am

Try opening Synaptic Package Manager, then click on Edit > Fix broken packages

I'd first look at the bottom bar to see how many items are broken. Assuming a small number, I'd do the above.

Good luck.

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: volume icon has disappeared

Post by KIMW » Thu Jun 13, 2019 7:13 am

Thanks. I did fix broken packages but I still cannot install plasma.pa. I have the same message as written above.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: volume icon has disappeared

Post by MrEen » Thu Jun 13, 2019 1:29 pm

Ahh, I didn't spot this bit:
but 4:5.8.9-0ubuntu1~ubuntu16.04~ppa1 is to be installed
I'm using 18.3 and 5.5.5 is what is available to me. You have some ppa installed that has a newer version available.

See if this works (I've seen something similar used, but I don't know that it'll work for us):
apt install plasma-pa/xenial

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: volume icon has disappeared

Post by sleeper12 » Thu Jun 13, 2019 1:38 pm

Should he use sudo in that command or no matter?

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: volume icon has disappeared

Post by MrEen » Thu Jun 13, 2019 1:41 pm

No matter. It will prompt for the password regardless.

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: volume icon has disappeared

Post by sleeper12 » Thu Jun 13, 2019 1:45 pm

MrEen wrote:
Thu Jun 13, 2019 1:41 pm
No matter. It will prompt for the password regardless.
8)

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: volume icon has disappeared

Post by KIMW » Thu Jun 13, 2019 3:56 pm

MrEen wrote:
Thu Jun 13, 2019 1:29 pm
See if this works (I've seen something similar used, but I don't know that it'll work for us):
apt install plasma-pa/xenial
Yeah, it worked! Thank you very much MrEen. And thanks sleeper12 for your concern.

MrEen, it seems that you are an expert with sound issue. I always had issue with sound since I switched to Linux so I'll have a look at your tips and will probably ask you some more questions, if you don't mind...
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: volume icon has disappeared

Post by MrEen » Thu Jun 13, 2019 5:42 pm

I'm not an expert, but I know a fair deal. Ask anytime.

Glad we got the first issue fixed. :)

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: SOLVED - Volume icon has disappeared

Post by KIMW » Fri Jun 21, 2019 11:59 am

Hi MrEen,

Sorry to disturb you again but the issue happened again.
I typed apt install plasma.pa/xenial but nothing was changed.

The error message is slightly different:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'plasma-pa' for regex 'plasma.pa'
Note, selecting 'plasma-pa-dbg' for regex 'plasma.pa'
Selected version '4:5.8.9-0ubuntu1~ubuntu16.04~ppa1' (Kubuntu Backports:16.04/xenial [amd64]) for 'plasma-pa'
Selected version '4:5.5.5-0ubuntu1' (Ubuntu:16.04/xenial [amd64]) for 'plasma-pa-dbg'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
plasma-pa-dbg : Depends: plasma-pa (= 4:5.5.5-0ubuntu1) but 4:5.8.9-0ubuntu1~ubuntu16.04~ppa1 is to be installed
E: Unable to correct problems, you have held broken packages.


I checked if there was any broken packages via the Synaptic Package Manager, but there wasn't.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: SOLVED - Volume icon has disappeared

Post by sleeper12 » Fri Jun 21, 2019 1:36 pm

You can try:

Code: Select all

 sudo dpkg --configure -a 

Code: Select all

 sudo apt-get install -f 
If no luck, repeat the first command & reboot.

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: SOLVED - Volume icon has disappeared

Post by KIMW » Fri Jun 21, 2019 1:58 pm

Thanks, but it did not helped.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

sleeper12
Level 5
Level 5
Posts: 805
Joined: Thu May 25, 2017 3:22 pm

Re: Volume icon has disappeared

Post by sleeper12 » Fri Jun 21, 2019 2:51 pm

Ok, perhaps MrEen will have further advice. I don't want to lead you down the wrong road. :wink:

Edit: :idea: Synaptics>Custom Filters>Broken

User avatar
MrEen
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: Volume icon has disappeared

Post by MrEen » Fri Jun 21, 2019 4:13 pm

Well, I suspect the issue is a little different this time. Are you getting that same thing as mentioned in your first post?

You should still have the proper version of plasma.pa installed, but if you want to try that again, I think you should go to Software Sources in your Menu, and either under PPAs or Additional Repositories you should find the Kubuntu Backports entry and click on the check mark so it's unchecked. Close Software Sources then in the terminal run apt update followed by apt install plasma-pa/xenial. If it just says "Already the latest version" or similar, try apt install --reinstall plasma.pa/xenial

Hope that helps.

P.S. After all the above is done, you can re-enable the Kubuntu Backports PPA by checking the box again.

KIMW
Level 3
Level 3
Posts: 151
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Volume icon has disappeared

Post by KIMW » Sat Jun 22, 2019 9:48 am

I did all what you've suggested but the issue is still there.

The error message is slightly different:
Screenshot_20190622_144452.png
Screenshot_20190622_144452.png (11.28 KiB) Viewed 128 times
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

Post Reply

Return to “Software & Applications”