SSH Problem on LM19 (worked on LM18)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
WildPhydeaux
Level 1
Level 1
Posts: 8
Joined: Mon Mar 27, 2017 5:59 pm

SSH Problem on LM19 (worked on LM18)

Post by WildPhydeaux »

Hi folks,

I recently installed LM19. Moved my home folders elsewhere and did a clean install, then moved folders back. Was previously LM18.

Now when I SSH to my NAS I get connected but only see one item: "The". This happens when connecting from the terminal or from Nemo. Previously all was well under LM18.

However, I also have a Windows 7 VM I use in VirtualBox which I had backed up and from it I can connect and see everything on the NAS using WinSCP just like before.

Nothing has changed configuration wise on the NAS in many months.

Any ideas?

Thanks for your help...

RLW

8 ball
Level 1
Level 1
Posts: 45
Joined: Mon Mar 25, 2019 5:31 pm

Re: SSH Problem on LM19 (worked on LM18)

Post by 8 ball »

Stick a -v flag in your ssh command and it will report any problems to you, (Verbose mode)

WildPhydeaux
Level 1
Level 1
Posts: 8
Joined: Mon Mar 27, 2017 5:59 pm

Re: SSH Problem on LM19 (worked on LM18) [Solved]

Post by WildPhydeaux »

Thanks for the tip. I'm not sure this reveals a smoking gun though:

Code: Select all

$ ssh -v root@192.168.168.100
OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.168.100 [192.168.168.100] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/robert/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1-hpn14v5 Debian-5+deb8u7.netgear1
debug1: match: OpenSSH_6.7p1-hpn14v5 Debian-5+deb8u7.netgear1 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 192.168.168.100:22 as 'root'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:jYWXiW7325XD3FnhHgj2C7fEXCDzfowL4m6EzlwcwU0
debug1: Host '192.168.168.100' is known and matches the ECDSA host key.
debug1: Found key in /home/robert/.ssh/known_hosts:1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/robert/.ssh/id_rsa
debug1: Trying private key: /home/robert/.ssh/id_dsa
debug1: Trying private key: /home/robert/.ssh/id_ecdsa
debug1: Trying private key: /home/robert/.ssh/id_ed25519
debug1: Next authentication method: password
root@192.168.168.100's password: 
debug1: Authentication succeeded (password).
Authenticated to 192.168.168.100 ([192.168.168.100]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: Sending environment.
debug1: Sending env LANG = en_CA.UTF-8

Welcome to ReadyNASOS 6.10.0

Last login: Tue Jun 18 16:06:59 2019 from phydeaux
root@PASQUA:~# ls
The

But I sheepishly add that it appears I CAN see all the files:

Code: Select all

root@PASQUA:~# cd ..
root@PASQUA:/# ls
apps  boot  dev  frontview  homes  lib64  mnt	 opt   root  sbin  sys	usr
bin   data  etc  home	    lib    media  mysql  proc  run   srv   tmp	var
Sorry, it appears I've wasted people's time here. Very sorry for the dopey question...

Cheers,
RLW

Post Reply

Return to “Software & Applications”