SOLVED - Reinstall the volume system by default

Questions about applications and software
Forum rules
Before you post please read how to get help
KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Thu Jul 18, 2019 2:04 am

Here you are:
Screenshot_20190718_065451.png
I am hearing sound from the Built-in Speakers and sometimes from Headphones.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Thu Jul 18, 2019 2:40 am

You said in your original post that the sound was getting worse. There are a few ways of tackling this that I'll list in the order I would try them if it were my machine:

1.
If you're experiencing glitches, skips, pops or crackling in your audio playback, it's quite possibly caused by the timer-based scheduling pulseaudio now uses. Disable timer-based scheduling this way:
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Users of 19 and later versions of Mint type this in the terminal: xed admin:///etc/pulse/default.pa
Find the line that says load-module module-udev-detect and change it to load-module module-udev-detect tsched=0
Save the file, then run pulseaudio -k in the terminal and test your sound
If that doesn't change anything, undo it.

2. Run alsamixer in the terminal (or qasmixer) and unmute the headphone mic and headset mic. In alsamixer, muted columns show MM at the bottom. Navigate to the columns with the left and right arrow keys and press the m key to toggle mute.

3. If still no change, in the terminal enter gksudo xed /etc/modprobe.d/alsa-base.conf then enter your password and ignore the warnings. When the file opens, scroll to the bottom and add this new line:

Code: Select all

options snd-hda-intel model=dell-e7x
Save the file, reboot and test the sound.

Hopefully one of those will help. Good luck.

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Thu Jul 18, 2019 3:18 am

Now that pulseaudio has been reinstalled SMPlayer does not work again. I changed the audio settings, I tried pulse, alsa, etc, but nothing works.
Firefox also does not work.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Thu Jul 18, 2019 7:10 am

KIMW wrote:
Thu Jul 18, 2019 3:18 am
Now that pulseaudio has been reinstalled SMPlayer does not work again. I changed the audio settings, I tried pulse, alsa, etc, but nothing works.
Firefox also does not work.
Run sudo fuser -v /dev/snd/* again. Kill any process other than pulseaudio listed there. Last time kmix was there, so if it's there again, enter killall kmix in the terminal. Do the same with any others that show up, then restart pulseaudio with pulseaudio -k in the terminal. You may need to restart the browser and player after that.

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Fri Jul 19, 2019 11:18 am

MrEen wrote:
Thu Jul 18, 2019 2:40 am
Users of 18.3 and earlier versions of Mint type this in the terminal: gksudo xed /etc/pulse/default.pa
Did not do anything. So I opened my file manager in root, found the line and changed it.
MrEen wrote:
Thu Jul 18, 2019 2:40 am
If still no change, in the terminal enter gksudo xed /etc/modprobe.d/alsa-base.conf then enter your password and ignore the warnings.
Again, it did not do anything after I entered my password. This time I could not find the file so I did not add the line.

Anyway, what I've noticed is that, when I run pulseaudio -k in the terminal then I have sound in Firefox and SMPlayer. Great! It seems that pulseaudio -k does not load automatically after reboot. I have to launch it manually.
The problem I have now is that there is no sound on VirtualBox.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Fri Jul 19, 2019 2:49 pm

I'm sorry. For KDE users the command should have been kdesudo .... I've never used KDE and totally forgot about that.

Sounds like we're getting close to solving everything.

Regarding pulseaudio -k. That actually kills a running daemon, which with the default settings should automatically respawn itself seconds later. It is sounding to me like pulseaudio is possibly not automatically starting when you boot up? I have no idea where to check for that on KDE systems, but it should be something called Autostart Applications or something similar.

Regarding VirtualBox, is vboxusers in the output from running groups $USER in the terminal? If not, see if running sudo usermod -a -G vboxusers $USER in the terminal followed by a log out/in or reboot fixes that issue.

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Fri Jul 19, 2019 3:00 pm

MrEen wrote:
Fri Jul 19, 2019 2:49 pm
Regarding pulseaudio -k. That actually kills a running daemon, which with the default settings should automatically respawn itself seconds later. It is sounding to me like pulseaudio is possibly not automatically starting when you boot up? I have no idea where to check for that on KDE systems, but it should be something called Autostart Applications or something similar.
Actually, there might be some race condition messing up the sound system on boot up the pulseaudio -k is fixing. If that's the case, you'll want a new autostart script with something like this:

Code: Select all

sleep 7; pulseaudio -k
Again, not sure where to add that on KDE. The 7 can be adjusted with experimentation. It might work as low as 2 seconds after booting.

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Sat Jul 20, 2019 5:02 am

MrEen wrote:
Fri Jul 19, 2019 2:49 pm
I'm sorry. For KDE users the command should have been kdesudo .... I've never used KDE and totally forgot about that.
That's ok, no worry.
MrEen wrote:
Fri Jul 19, 2019 2:49 pm
Regarding VirtualBox, is vboxusers in the output from running groups $USER in the terminal?
Yes, it does appear in the output... But there is no sound on VirtualBox.

I think I found where to add the autostart script. I'll try that. thanks.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Sun Jul 21, 2019 3:37 am

I found something interesting...
It's not only when I reboot my computer that pulseaudio turns off by itself. It turns off like that from time to time (I haven't discovered why yet).
When pulseaudio is off I have sound on VirtualBox but NOT on Firefox and SMPlayer. When I run pulseaudio -k the sound comes back on Firefox and SMPlayer but NOT on VirtualBox.
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Sun Jul 21, 2019 1:52 pm

KIMW wrote:
Sun Jul 21, 2019 3:37 am
I found something interesting...
It's not only when I reboot my computer that pulseaudio turns off by itself. It turns off like that from time to time (I haven't discovered why yet).
When pulseaudio is off I have sound on VirtualBox but NOT on Firefox and SMPlayer. When I run pulseaudio -k the sound comes back on Firefox and SMPlayer but NOT on VirtualBox.
That is indeed interesting. What OS are you running on VB and what version of VB are you using?

I dumped VB recently and never used it much when I had it, so I will probably struggle trying to find answers to your situation, but I'll keep trying.

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Mon Jul 22, 2019 3:04 pm

Actually it changes everyday... Today I had sound on VirtualBox, Firefox and SMPlayer... I wonder for how long.
I'll let you know.
I am using W7 Pro on VB 5.2.30
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Sat Jul 27, 2019 5:54 am

Isn't it strange when I run pulseaudio -k that actually pulseaudio starts working on Firefox and SMPlayer? It should be the opposite...
Again I still don't have sound on VirtualBox...
I thought that running pulseaudio --start would make the sound comes back on VirtualBox, but it does not...
Any other command line I could run?
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Sat Jul 27, 2019 11:46 am

I think what you need to do is run pulseaudio -k, then launch VB.

The command is killing the running sound daemon. With the default setup, the daemon will automatically restart itself after being killed. After restarting it will have a new PID (process ID) and it's possible VB is still trying to talk to the old PID. Some software is able to figure out that the pulseaudio PID has changed and make the necessary adjustments, while other software can't, and therefore need to be restarted after running the command. In my case, when I was still using Firefox, I always had to restart it after running that command.

It would be helpful if we knew why your daemon was getting messed up and needed restarting, but figuring that out is way too advanced for me. We'd need to launch pulseaudio from the terminal with a very verbose option, and the output would be huge with so much useless info I wouldn't know how to find the info we need. If you want to try it to see what it looks like, run pulseaudio -k; pulseaudio -vvv I think you'll need to hit Ctrl+C to stop the output. You might want to follow up with another pulseaudio -k just in case.

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Sun Jul 28, 2019 5:25 am

MrEen wrote:
Sat Jul 27, 2019 11:46 am
I think what you need to do is run pulseaudio -k, then launch VB.
Yes, if I do that the sound works on VB but the sound is not working on SMPlayer. Then if I run pulseaudio -k again, the sound comes back on SMPlayer but does not work anymore on VB. When VB is running and I use pulseaudio -k then the sound stop working immediately on VB.
I am a bit lost...
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Sun Jul 28, 2019 12:01 pm

First, in SMPlayer, go to Options > Preferences > Audio tab ... is Output driver set to pulse? If not, change it so it is.

Now in VBox, I don't have it installed anymore, try to find the guest settings for audio and make sure that is also using pulseaudio.

I think if one or both of those needed to be changed, that might fix your issue.

User avatar
Flemur
Level 17
Level 17
Posts: 7305
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Reinstall the volume system by default

Post by Flemur » Sun Jul 28, 2019 12:16 pm

KIMW wrote:
Wed Jul 03, 2019 12:22 pm
To get the sound from Youtube on Firefox I need to have pulseaudio, but then if I want to watch a movie on SMPlayer the sound does not work anymore.
Check the settings in smplayer - it's probably set to something besides pulse (or default).
smplayer.jpg
smplayer.jpg (17.18 KiB) Viewed 231 times
FWIW, you can get audio from firefox w/o pulseaudio by

Code: Select all

apulse firefox
need to install apulse.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Mon Jul 29, 2019 9:08 am

Thanks Flemur but I had already tried apulse and it did not work...

When I launched VB, sounds is working fine in VB but not in SMPlayer, Firefox, etc, and when I run pulseaudio -k then the sound comes back in SMPlayer and Firefox but stops in VB.
SMPlayer and VB have always been properly configured in preferences on PulseAudio . The problem is somewhere else...

I think we've tried everything that we could do, so I'll leave it like that. I'll have to accept the fact that I can't have sound on all my apps...
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Mon Jul 29, 2019 3:37 pm

When everything but VBox is working, shut down the guest OS, go to Settings > Audio and change 'Audio: ICH AC97' to 'Audio: Intel HD Audio' then restart the guest OS.

That worked for some here but it's old: https://www.virtualbox.org/ticket/15859

KIMW
Level 3
Level 3
Posts: 152
Joined: Sat Nov 12, 2016 1:43 pm
Location: Italy

Re: Reinstall the volume system by default

Post by KIMW » Sun Aug 04, 2019 2:55 am

MrEen wrote:
Mon Jul 29, 2019 3:37 pm
When everything but VBox is working, shut down the guest OS, go to Settings > Audio and change 'Audio: ICH AC97' to 'Audio: Intel HD Audio' then restart the guest OS.
Thanks but I had tried to change that before and it did not work. I tried all different combinations of 'Host audio Driver' and 'Audio Controller' without success. But your link lead me to discover there's a VB forum (I never thought about that) and I am going to a post a message there to explain the issue I am facing.

Can you please have a look at the pictures below and tell me if Alsa Mixer is fine, because it seems that there is much more channels than there was originally.
Screenshot_20190804_075318.png
Distro: Linux Mint 18.3 KDE
Laptop: Dell Latitude-E7470. RAM 16GB. Dual core: Intel Core i7-6600U. Graphic Card: Intel Sky Lake..

User avatar
MrEen
Level 14
Level 14
Posts: 5391
Joined: Mon Jun 12, 2017 8:39 pm

Re: Reinstall the volume system by default

Post by MrEen » Sun Aug 04, 2019 12:13 pm

Good thinking trying the VB forum. Hopefully someone there has experienced the same as you and knows the fix.

Your alsamixer output is the same as when you ran the alsa-info script. It is a lot of options, but it's not that unusual. Your sound card has your Analog as well as HDMI options all on the same card.

Please let us know it the VB Forum is of any help.

Good luck.

Post Reply

Return to “Software & Applications”