PlayOnLinux problem

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
gazzol
Level 1
Level 1
Posts: 2
Joined: Sun Jul 28, 2019 6:38 am

PlayOnLinux problem

Post by gazzol » Sun Jul 28, 2019 7:15 am

Hi Guys,I'm very new to Linux and am not really interested in spending hours and hours learning the intricacies of an operating system as I use my PC Very little. I only became a Linux user because every time i wanted to use my PC i had to wait for ages for all the updates to be installed which I found extremely irritating.
And now to my problem. I have a specific Windows only application which I need to use. The program is on CD Rom and needs to be installed in order to use it, there is no EXE file for the program buried in the files only an EXE for the installation. I have tried to install the program using PlayOnLinux but it just crashes, an error log is generated which I haven't read all the way through but I did rear that i need to install wine 32 development however when I copied and pasted the command to do that in terminal I get an error message asking me if I am root?
Any help would be really great
Thanks
gazzol

User avatar
Pierre
Level 19
Level 19
Posts: 9154
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: PlayOnLinux problem

Post by Pierre » Sun Jul 28, 2019 7:34 am

you most likely will have to install the ./wine 32 bit dependencies,
if you are currently using an 64 bit machine.
sudo dpkg --add-architecture i386; sudo apt-get update
what is the Name of the Program - that you are trying to use ?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

gazzol
Level 1
Level 1
Posts: 2
Joined: Sun Jul 28, 2019 6:38 am

Re: PlayOnLinux problem

Post by gazzol » Sun Jul 28, 2019 7:50 am

Thanks for your reply, I ran the command you posted and it worked-thank you. However the program will still not work and I get the same error in the debug log. Having read further down in the log there is also the following message: Bad EXE format for D:\Setup.exe.
The program in question is configuration software for a stand alone engine management ecu from a company called Emerald.

User avatar
kc1di
Level 14
Level 14
Posts: 5411
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: PlayOnLinux problem

Post by kc1di » Sun Jul 28, 2019 8:40 am

you may want to try adding newer or older version of wine from the tool menu and see it it will install with one of those versions.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
Lanser
Level 4
Level 4
Posts: 298
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg Austria

Re: PlayOnLinux problem

Post by Lanser » Sun Jul 28, 2019 10:04 am

gazzol. This is old 32bit Win code. Even if you get it to run, I suspect you will have issues with the RS232 interface.
And even more fun if you are trying to use a USB to RS232 converter as well.
Not saying you can't get it run, but I don't think the playonlinux layer was really intended to talk to hardware directly
I keep a very old small laptop running WIN7 for bespoke Win applications driving external devices. Eg Alarm Panels, ECUs etc.
For other serial coms needs there are good linux alternaives.

Lanser
Thinkpads:- LM19.x Mate, LMDE3, Debian 10

Post Reply

Return to “Software & Applications”