Page 1 of 1

thunderbird 60.8.0 and first start

Posted: Thu Aug 01, 2019 11:19 am
by DobrAn
Hi all,
I have fresh installation of Linux Mint 19.1. I disconnect from Internet and can finish installation with UEFI. After all I connect and start the system. All programms work but not work Thunderbird.

Code: Select all

thunderbird -v
 Thunderbird 60.8.0
I cannot connect to my POP3 account. Safe-mode also not work. If I start from a terminal I see the next:

Code: Select all

thunderbird -safe-mode

(thunderbird:5256): Gtk-WARNING **: 18:16:01.107: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:5256): Gtk-WARNING **: 18:16:01.107: Theme parsing error: <data>:1:78: Expected ')' in color definition
1564672569461	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
In the directory

Code: Select all

ls -la /usr/lib/thunderbird/
total 160272
drwxr-xr-x   8 root root      4096 Jul 31 20:39 .
drwxr-xr-x 133 root root      4096 Jul 31 18:15 ..
-rw-r--r--   1 root root       526 Jul  5 20:14 application.ini
-rw-r--r--   1 root root    298934 Jul  5 11:04 blocklist.xml
drwxr-xr-x   3 root root      4096 Dec 17  2018 chrome
-rwxr-xr-x   1 root root    256136 Jul  5 20:14 crashreporter
-rw-r--r--   1 root root      4003 Jul  5 11:03 crashreporter.ini
drwxr-xr-x   4 root root      4096 Dec 17  2018 defaults
-rw-r--r--   1 root root       185 Jul  5 20:14 dependentlibs.list
lrwxrwxrwx   1 root root        20 Jul 31 16:31 dictionaries -> ../../share/hunspell
drwxr-xr-x   3 root root      4096 Dec 17  2018 distribution
lrwxrwxrwx   1 root root        32 Jul 31 16:31 extensions -> ../thunderbird-addons/extensions
drwxr-xr-x   2 root root      4096 Jul 31 20:39 fonts
drwxr-xr-x   2 root root      4096 Jul 31 20:39 gtk2
drwxr-xr-x   2 root root      4096 Jul 31 20:39 isp
-rw-rw-r--   1 root root       899 Jul  5 20:14 libfreeblpriv3.chk
-rw-r--r--   1 root root    518384 Jul  5 20:14 libfreeblpriv3.so
-rw-r--r--   1 root root    225728 Jul  5 20:14 libldap60.so
-rw-r--r--   1 root root     14328 Jul  5 20:14 libldif60.so
-rw-r--r--   1 root root     59704 Jul  5 20:14 liblgpllibs.so
-rw-r--r--   1 root root      5744 Jul  5 20:14 libmozgtk.so
-rw-r--r--   1 root root    138032 Jul  5 20:14 libmozsandbox.so
-rw-r--r--   1 root root    837064 Jul  5 20:14 libmozsqlite3.so
-rw-r--r--   1 root root    244536 Jul  5 20:14 libnspr4.so
-rw-r--r--   1 root root    627416 Jul  5 20:14 libnss3.so
-rw-r--r--   1 root root    536248 Jul  5 20:14 libnssckbi.so
-rw-rw-r--   1 root root       899 Jul  5 20:14 libnssdbm3.chk
-rw-r--r--   1 root root    134152 Jul  5 20:14 libnssdbm3.so
-rw-r--r--   1 root root    196040 Jul  5 20:14 libnssutil3.so
-rw-r--r--   1 root root     18672 Jul  5 20:14 libplc4.so
-rw-r--r--   1 root root     14480 Jul  5 20:14 libplds4.so
-rw-r--r--   1 root root     22928 Jul  5 20:14 libprldap60.so
-rw-r--r--   1 root root    160480 Jul  5 20:14 libsmime3.so
-rw-rw-r--   1 root root       899 Jul  5 20:14 libsoftokn3.chk
-rw-r--r--   1 root root    249912 Jul  5 20:14 libsoftokn3.so
-rw-r--r--   1 root root    332344 Jul  5 20:14 libssl3.so
-rw-r--r--   1 root root 111151136 Jul  5 20:14 libxul.so
-rw-r--r--   1 root root  47568193 Jul  5 20:14 omni.ja
-rw-r--r--   1 root root        48 Jul  5 20:14 platform.ini
-rwxr-xr-x   1 root root    190672 Jul  5 20:14 plugin-container
lrwxrwxrwx   1 root root        29 Jul 31 16:31 plugins -> ../thunderbird-addons/plugins
lrwxrwxrwx   1 root root        35 Jul 31 16:31 searchplugins -> ../thunderbird-addons/searchplugins
-rw-r--r--   1 root root       825 Jul  5 11:03 Throbber-small.gif
-rwxr-xr-x   1 root root    198856 Jul  5 20:14 thunderbird
-rwxr-xr-x   1 root root      2665 Jul  5 20:14 thunderbird.sh
I have not the directory features/. Why? What I have to install?

Re: thunderbird 60.8.0 and first start

Posted: Thu Aug 01, 2019 11:29 am
by Lord Boltar
Have you tried to reinstall it from the Synaptic Package Manager - in the search block type in thunderbird?

Re: thunderbird 60.8.0 and first start

Posted: Fri Aug 02, 2019 7:35 am
by DobrAn
Sorry, I do not know how to reinstall a package from Synaptic.

Re: thunderbird 60.8.0 and first start

Posted: Fri Aug 02, 2019 8:01 am
by DobrAn
I reinstalled Thunderbird with apt-get. Thunderbird not work and I see in text frame: Not Found The requested URL /und/release/ was not found on this server.
In the terminal:

Code: Select all

thunderbird 
1564746681690	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
1564746681699	addons.xpi-utils	WARN	addMetadata: Add-on wetransfer@extensions.thunderbird.net is invalid: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.isFile]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: loadManifestFromFile :: line 925"  data: no] Stack trace: loadManifestFromFile()@resource://gre/modules/addons/XPIInstall.jsm:925
syncLoadManifestFromFile()@resource://gre/modules/addons/XPIProvider.jsm:940
addMetadata()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1173
processFileChanges()@resource://gre/modules/addons/XPIProvider.jsm -> resource://gre/modules/addons/XPIProviderUtils.js:1529
checkForChanges()@resource://gre/modules/addons/XPIProvider.jsm:3291
startup()@resource://gre/modules/addons/XPIProvider.jsm:2196
callProvider()@resource://gre/modules/AddonManager.jsm:253
_startProvider()@resource://gre/modules/AddonManager.jsm:728
startup()@resource://gre/modules/AddonManager.jsm:892
startup()@resource://gre/modules/AddonManager.jsm:2981
observe()@jar:file:///usr/lib/thunderbird/omni.ja!/components/addonManager.js:63
1564746681699	addons.xpi-utils	WARN	Could not uninstall invalid item from locked install location
[calBackendLoader] Using Thunderbird's builtin libical backend

(thunderbird:6015): Gtk-WARNING **: 14:51:22.171: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:6015): Gtk-WARNING **: 14:51:22.171: Theme parsing error: <data>:1:78: Expected ')' in color definition
console.warn: Lightning: Warning:  Using guessed timezone
  Europe/Kiev (UTC+0200/+0300).
This ZoneInfo timezone seems to match the operating system timezone this year.
This ZoneInfo timezone was chosen based on the operating system timezone
identifier "/etc/localtime -> /usr/share/zoneinfo/Europe/Kiev".
1564746815786	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
1564746833190	addons.update-checker	WARN	Update manifest for messagingmenu@mozilla.com did not contain an updates property
1564746833206	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

With tcpdump I see that Thunderbird not connect to the servers. And I didn't set a password as setup my curren email. Thunderbird not ask me about.

Re: thunderbird 60.8.0 and first start

Posted: Fri Aug 02, 2019 8:10 am
by DobrAn
In safe-mode:

Code: Select all

thunderbird -safe-mode
1564747524191	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net

(thunderbird:6414): Gtk-WARNING **: 15:05:24.266: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:6414): Gtk-WARNING **: 15:05:24.266: Theme parsing error: <data>:1:78: Expected ')' in color definition
1564747527979	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net

And also did not asks about the password and not works.

Re: thunderbird 60.8.0 and first start

Posted: Tue Aug 06, 2019 9:58 am
by DobrAn
One more detail, TB even not try to connect to the server... What ThunderBird makes, I do not know...

Re: thunderbird 60.8.0 and first start

Posted: Tue Aug 06, 2019 10:01 am
by DobrAn
Again... :)

Code: Select all

Could not read chrome manifest 'file:///usr/lib/thunderbird/chrome.manifest'.
1565107444175	addons.xpi	WARN	Can't get modified time of /usr/lib/thunderbird/features/wetransfer@extensions.thunderbird.net
1565107444185	addons.xpi-utils	WARN	addMetadata: Add-on wetransfer@extensions.thunderbird.net is invalid: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.isFile]"  nsresult: "0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST)"  location: "JS frame :: resource://gre/modules/addons/XPIInstall.jsm :: loadManifestFromFile :: line 925"  data: no] Stack trace: loadManifestFromFile()@resource://gre/modules/addons/XPIInstall.jsm:925
Why manifest not included in packeg? Why add-on wetransfer@extensions.thunderbird.net is invalid?