Shotwell .31 flatpak won't install

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mttr
Level 1
Level 1
Posts: 16
Joined: Fri Mar 09, 2012 11:46 am

Shotwell .31 flatpak won't install

Post by mttr » Sat Aug 10, 2019 9:40 pm

The news version of Shotwell .31 is available at since April at
https://wiki.gnome.org/Apps/Shotwell
But when I try to install it on Mint 19 I get an error

Sorry, something went wrong: "failed to get origin-hostname:Remote "flathub" not found"

Now version .30.4 flatpak has install properly and works
if look for shotwell I get this

$ flatpak remote-ls | grep -i shotwell
org.gnome.Shotwell flathub

$ flatpak update org.gnome.Shotwell
doesn't update the package

No idea where to go from here.

ajgringo619
Level 6
Level 6
Posts: 1483
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California, USA

Re: Shotwell .31 flatpak won't install

Post by ajgringo619 » Sat Aug 10, 2019 10:40 pm

This is what I get querying Shotwell:

Code: Select all

$ flatpak remote-info flathub org.gnome.Shotwell

Shotwell - Popular photo manager

        ID: org.gnome.Shotwell
       Ref: app/org.gnome.Shotwell/x86_64/stable
      Arch: x86_64
    Branch: stable
   Version: 0.30.4
   License: LGPL-2.1+
Collection: org.flathub.Stable
  Download: 7.0 MB
 Installed: 20.0 MB
   Runtime: org.gnome.Platform/x86_64/3.32

       Sdk: org.gnome.Sdk/x86_64/3.32
    Commit: 36307f69fdb98d4422f585a03621cd39ac01f5c7cd13c11bf039b5d74a6b0362
    Parent: 19c826db9155a14581a625a9cf7f4aef07d101b221cb23993fc794a3867fee0b
   Subject: Update gnome runtime to 3.32 (5dec4c63)
      Date: 2019-05-25 17:30:34 +0000
The 0.31 branch is the latest, but is also from their unstable branch.. If you want to install it, try this:

Code: Select all

flatpak install https://gitlab.gnome.org/GNOME/shotwell/raw/master/flatpak/org.gnome.Shotwell.unstable.flatpakref
Mint 19.2 XFCE
kernel 4.15.0-72-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (440.44)
Image

mttr
Level 1
Level 1
Posts: 16
Joined: Fri Mar 09, 2012 11:46 am

Re: Shotwell .31 flatpak won't install

Post by mttr » Tue Aug 13, 2019 2:13 pm

Tried it but get the
error: Failed to install org.gnome.Shotwell/x86_64/unstable: Commit 47f4214aac70a6ab8c860a31a54a16e09e06f6aa7db282657c8f7200878b7b81: GPG signatures found, but none are in trusted keyring

Post Reply

Return to “Software & Applications”