Xterm oddity

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
swordfish
Level 1
Level 1
Posts: 31
Joined: Tue Aug 02, 2011 6:10 am

Xterm oddity

Post by swordfish »

I have recently updated to the latest Mint (19.2 MATE edition IIRC) and my xterms have started to behave oddly.

If I launch an xterm from the menu it starts up in the root directory. The default terminal starts up in the home directory, as normal. If I launch an xterm from the default terminal, it starts up in the home directory.

This is a very recent issue and I have not changed anything that would obviously affect this, other than updating Mint.

The configured command for launching the xterm is

Code: Select all

xterm -bg white -fg slateblue -sb -sl 512
curtvaughan
Level 3
Level 3
Posts: 163
Joined: Sun Dec 21, 2014 5:54 pm
Location: Austin, Tx

Re: Xterm oddity

Post by curtvaughan »

Hmm. I recently upgraded from 19.1 to 19.2 (Mate). The only way I can get a terminal to open in the root directory is to launch the terminal as root. If by "menu" you are referring to the startup application menu, right click on the xterm icon and select "Edit properties" and then note its invocation next to the "Command:" property. On my xterm it simply says "xterm", and as such, it executes from my non-root account into my home directory. If your "Command:" property is listed as you indicate, not prepended with "gksu" or some such, and if you aren't logged in as "root", I can't seem to replicate your problem. Here's my properties screenshot:
Screenshot at 2019-08-12 10-10-03.png
Screenshot at 2019-08-12 10-10-03.png (34.87 KiB) Viewed 200 times
I have another "root terminal" icon which is launched with "gksu" prepended to the "xterm" command. When I click that I'm prompted for a root login and then get the terminal as root rooted in the root home directory. Sorry I can't help other than this. You might look at properties on your other application menu icons and see if they also launch as root. If so, then somehow that got configured during the installation/upgrade process.
Move from rim to hub: know the wheel.

Image
swordfish
Level 1
Level 1
Posts: 31
Joined: Tue Aug 02, 2011 6:10 am

Re: Xterm oddity

Post by swordfish »

The options aren't standard, they were edited to suit my preferences, but they haven't been changed for years.

This is what I have in the properties.
Screenshot at 2019-08-12 21-28-26.png
Screenshot at 2019-08-12 21-28-26.png (23.76 KiB) Viewed 176 times
curtvaughan
Level 3
Level 3
Posts: 163
Joined: Sun Dec 21, 2014 5:54 pm
Location: Austin, Tx

Re: Xterm oddity

Post by curtvaughan »

Here's a thread on this issue on an Ubuntu forum, though rather dated (2010). At that point they seem to have found the problem to be associated with some keyboard shortcut. Anyway, the odds of it having anything to do with your issue aren't stellar, but f.y.i.

https://ubuntuforums.org/showthread.php?t=1469240

Doing a search for "what causes an xterm launch to use root as a home directory" produced this and many others. If things have worked for several years, perhaps through several upgrade iterations, it may be something unique to the latest 19.2 upgrade process. I'm assuming you upgraded rather than doing a clean install - that is what I did. I haven't used the original "xterm" for quite a while, using newer terminal emulators, but I'm assuming that the launch process would be the same across the board for a given command. For your query, I just installed xterm this morning. None of my terminal emulator applications have had the root directory issue across several upgrades (going back to 17.*). Hopefully, someone else on the forum may have experienced your situation and can help.
Move from rim to hub: know the wheel.

Image
swordfish
Level 1
Level 1
Posts: 31
Joined: Tue Aug 02, 2011 6:10 am

Re: Xterm oddity

Post by swordfish »

I've just noticed that Emacs also opens with a working directory of /.
Post Reply

Return to “Software & Applications”