Page 1 of 1

MintUpdate "Error in checkAPT.py" RESOLVED

Posted: Fri Jul 24, 2009 1:16 am
by red-e-made
I can't refresh the list of packages anymore, as I'm getting this "Error in checkAPT.py" message when I check the Information setting of MintUpdate. There's this thread on the subject but the solution confuses me. Can someone shed some light on this?

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Jul 24, 2009 2:42 am
by DrHu
red-e-made wrote:I can't refresh the list of packages anymore, as I'm getting this "Error in checkAPT.py" message when I check the Information setting of MintUpdate.
My first thought, reinstall the offending application: mintupdate, synaptic makes that fairly easy (package manager)

Yeah, I don't know what that link is either, it is just the log of of mintupdate ?
--anyway a search in Mint with that error gets this hit list..
http://forums.linuxmint.com/search.php? ... heckapt+py
http://forums.linuxmint.com/viewtopic.p ... py#p107473

Anyway, try
In a terminal
  • sudo apt clean
    sudo apt autoremove

    or
    sudo aptitude clean
    sudo aptitude autoclean

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Jul 24, 2009 3:27 am
by red-e-made
DrHu wrote:
red-e-made wrote:I can't refresh the list of packages anymore, as I'm getting this "Error in checkAPT.py" message when I check the Information setting of MintUpdate.
My first thought, reinstall the offending application: mintupdate, synaptic makes that fairly easy (package manager)
Ah, funnily (actually not so funny) enough, when I hit Synaptic, I get this error message:

Code: Select all

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/deb.playonlinux.com_dists_hardy_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
E: _cache->open() failed, please report.
So I'm guessing this is a sources problem or what? I'm out of ideas.

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Jul 24, 2009 3:39 am
by DrHu

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Jul 24, 2009 11:49 am
by red-e-made
Nope, nothing there made a difference.

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Jul 24, 2009 11:58 am
by red-e-made
I did find a solution to this problem, though: I went into /var/lib/apt/lists and removed the offending file from the directory. To be on the safe side, I opened this directory in root and moved the file to Trash instead of flat-out deleting it. This made both MintUpdate and Synaptic work.

Re: MintUpdate "Error in checkAPT.py"

Posted: Fri Aug 07, 2015 5:58 am
by Paddy78
DrHu wrote:
red-e-made wrote:I can't refresh the list of packages anymore, as I'm getting this "Error in checkAPT.py" message when I check the Information setting of MintUpdate.
My first thought, reinstall the offending application: mintupdate, synaptic makes that fairly easy (package manager)

Yeah, I don't know what that link is either, it is just the log of of mintupdate ?
--anyway a search in Mint with that error gets this hit list..
http://forums.linuxmint.com/search.php? ... heckapt+py
http://forums.linuxmint.com/viewtopic.p ... py#p107473

Anyway, try
In a terminal
  • sudo apt clean
    sudo apt autoremove

    or
    sudo aptitude clean
    sudo aptitude autoclean
I was having the same error message and tried this, all sorted now Thanks for the help