Page 1 of 1

Could not install the security updates

Posted: Fri Sep 06, 2019 10:23 am
by ronsmeyer
Second time this week; earlier with the firefox and snmp update. Today the with new version of Update Manager that it want to install. I click "Apply the Update" and enter the password. It sits for a bit and then stops. There is a message at the bottom of the screen says "Could not install the security updates". There are no other messages or errors. Just this. I have no idea what is wrong or what to do. It seems to me if can give you this message it must have detected some problem and it could also tell you why, doesn't it?

Anyone else? Any ideas?

Re: Could not install the security updates

Posted: Fri Sep 06, 2019 11:02 am
by Fraoch
Yes, I'm seeing this issue - Update Manager shows new updates - "A new version of the Update Manager is available" - click update, enter password - "Could not install the security updates" and the Update Manager now shows the broken icon.

Tried sudo apt-get update, sudo apt-get upgrade but nothing to upgrade.

Re: Could not install the security updates

Posted: Mon Sep 09, 2019 3:41 pm
by Fraoch
I guess we were the only two this affected, but the problem seems to have expanded.

There was a kernel update today and I can't install it. "Could not install the security updates." apt-get doesn't find any new updates so I can't do it that way either.

There's just a generic error message in the log:

Code: Select all

(synaptic:17834): Gtk-CRITICAL **: 15:24:00.534: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed
09.09@15:25 ++ Return code:0
09.09@15:25 ++ Install finished
09.09@15:25 -- Exception occurred in the install thread: <class 'TypeError'>
09.09@15:25 -- Could not install security updates
09.09@15:25 ++ Install requested by user
09.09@15:25 ++ Will install python2.7-minimal
09.09@15:25 ++ Will install libpython2.7
09.09@15:25 ++ Will install python2.7
09.09@15:25 ++ Will install libpython2.7-minimal
09.09@15:25 ++ Will install libpython2.7-stdlib
09.09@15:25 ++ Will install libpython3.6-minimal
09.09@15:25 ++ Will install libpython3.6-stdlib
09.09@15:25 ++ Will install libpython3.6
09.09@15:25 ++ Will install python3.6
09.09@15:25 ++ Will install python3.6-minimal
09.09@15:25 ++ Will install linux-headers-generic
09.09@15:25 ++ Will install linux-libc-dev
09.09@15:25 ++ Will install linux-image-generic
09.09@15:25 ++ Will install linux-generic
09.09@15:25 ++ Ready to launch synaptic

(synaptic:4298): Gtk-CRITICAL **: 15:26:02.494: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed
09.09@15:26 ++ Return code:0
09.09@15:26 ++ Install failed

Re: Could not install the security updates

Posted: Tue Sep 10, 2019 3:40 pm
by Fraoch
So this was still happening today, but I noticed something: all the previous updates that seemingly failed were gone, only new ones were appearing (and failing).

It was the same thing for the systemd update today.

I updated through apt-get which correctly informed me of the systemd update. After that it indicated no more updates.

And the Update Manager GUI didn't show any updates either.

So, it's an annoying cosmetic thing. The Update Manager GUI is still showing installation failed and has the ominous red X but the updates actually did install. That red X will go away eventually.

I see more than a few threads with Update Manager problems here, so something's up that will hopefully get fixed. In the meantime, updates are still being applied, but Update Manager only shows failures.

Re: Could not install the security updates

Posted: Tue Sep 10, 2019 4:22 pm
by experimenter
open update manager and click refresh. that should fix the red x icon

Re: Could not install the security updates

Posted: Tue Sep 10, 2019 4:30 pm
by Fraoch
Thanks for the reply.
experimenter wrote:
Tue Sep 10, 2019 4:22 pm
open update manager and click refresh. that should fix the red x icon
It didn't for me, once the install "fails" and the red X appears, refreshing it did not clear the X. It went away on its own eventually.

Edit: scratch that, it happened again today and yes, a simple refresh clears it.

Re: Could not install the security updates

Posted: Thu Sep 12, 2019 9:17 am
by War Horse
I'm having the same problem, but only on 2 of my Mint 19.2 computers. The rest don't seem to have this problem.
Has anyone come up with an answer. is it hardware, or installed software like Skype? I did recently sign up to Stream Yard, but that's on only one computer and it seems to be only in Firefox, not an software install.