HPLIP 3.19.8

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
samiel60
Level 3
Level 3
Posts: 146
Joined: Thu Apr 13, 2017 1:03 pm

HPLIP 3.19.8

Post by samiel60 » Sun Sep 08, 2019 2:04 pm

I'va a printer HP Color LaserJet Pro M454dn, supported only from HPLIP 3.19.8
(https://developers.hp.com/hp-linux-imag ... news/hplip),
but it's impossible to install it because dependencies:
dpkg: problemi con le dipendenze impediscono la configurazione di hplip:
hplip dipende da libhpmud0 (= 3.19.6+dfsg0-1); tuttavia:
La versione di libhpmud0:amd64 nel sistema è 3.17.10+repack0-5.
hplip dipende da libsane-hpaio (= 3.19.6+dfsg0-1); tuttavia:
La versione di libsane-hpaio:amd64 nel sistema è 3.17.10+repack0-5.
hplip dipende da printer-driver-hpcups (= 3.19.6+dfsg0-1); tuttavia:
La versione di printer-driver-hpcups nel sistema è 3.17.10+repack0-5.
and
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
Now. is there a method to make thic HPLIP version working,
or does it break all dependencies?
thanx
s

samiel60
Level 3
Level 3
Posts: 146
Joined: Thu Apr 13, 2017 1:03 pm

Re: HPLIP 3.19.8

Post by samiel60 » Mon Sep 09, 2019 4:20 pm

Do all of you have printers old more than 2 years?

User avatar
experimenter
Level 1
Level 1
Posts: 19
Joined: Fri Apr 30, 2010 3:54 pm

Re: HPLIP 3.19.8

Post by experimenter » Mon Sep 09, 2019 5:16 pm

How are you trying to install it? try installing from sourceforge https://sourceforge.net/projects/hplip/ ... ip/3.19.8/ directly. use the run file.

samiel60
Level 3
Level 3
Posts: 146
Joined: Thu Apr 13, 2017 1:03 pm

Re: HPLIP 3.19.8

Post by samiel60 » Mon Sep 09, 2019 6:30 pm

I've already tempted, but unable to solve some dependencies:

INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install openssl'
Please wait, this may take several minutes...
Running 'sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install libsnmp-dev'
Please wait, this may take several minutes...
error: Install command failed with error code 100

User avatar
kato181
Level 4
Level 4
Posts: 335
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: HPLIP 3.19.8

Post by kato181 » Tue Sep 10, 2019 6:14 am

Try this...
$ sudo apt-get update
$ sudo apt-get install hplip hplip-gui
$ hp-setup
$ hp-plugin
https://developers.hp.com/hp-linux-imaging-and-printing
Download the HPLIP file.

samiel60
Level 3
Level 3
Posts: 146
Joined: Thu Apr 13, 2017 1:03 pm

Re: HPLIP 3.19.8

Post by samiel60 » Tue Sep 10, 2019 12:37 pm

----------------------
| INSTALLING PLUG-IN |
----------------------

Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.17.10 Plugin Self Extracting Archive................................................

HP Linux Imaging and Printing System (ver. 3.17.10)
Plugin Installer ver. 3.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.17.10
Installed HPLIP version: 3.17.10
Number of files to install: 42
It installs the old version :(

User avatar
experimenter
Level 1
Level 1
Posts: 19
Joined: Fri Apr 30, 2010 3:54 pm

Re: HPLIP 3.19.8

Post by experimenter » Tue Sep 10, 2019 4:55 pm

error code 100 may occur if another package manager has an apt lock on it. close software manager and synaptic before you run the hplip 3.19 file and make sure you have mintsources installed.

Code: Select all

apt install mintsources

samiel60
Level 3
Level 3
Posts: 146
Joined: Thu Apr 13, 2017 1:03 pm

Re: HPLIP 3.19.8

Post by samiel60 » Wed Sep 11, 2019 12:06 pm

I've mnysources and no software manager open.
Simply, they are missing some dependencies,
impossible to download

Post Reply

Return to “Software & Applications”