Can't remove Firefox

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Can't remove Firefox

Post by iamthewalrus » Mon Sep 09, 2019 12:53 pm

https://imgur.com/a/i35s2el
Image

My computer keeps slowing down when I am online. I think it might have been hacked. I try to remove Firefox and try and install the latest edition but it gives an error message. See the attached screenshot ...
Last edited by Moem on Mon Sep 09, 2019 2:34 pm, edited 1 time in total.
Reason: Using the [rimg] tags (for remote images) with the link to the actual image makes your image appear directly inside the post.

User avatar
Moem
Level 19
Level 19
Posts: 9201
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Can't remove Firefox

Post by Moem » Mon Sep 09, 2019 1:35 pm

Have you tried doing what the message says?

Furthermore: have you tried resetting Firefox / starting with a fresh and clean profile?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Mon Sep 09, 2019 2:00 pm

I have no idea what repositories I am using. The default one nearest me, I think.

It says "furthermore" I should do something but doesn't give a reason or say why so I am rather nervous to type random commands. I vaguely thought it might be part of the hacking. It isn't very grammatical English ...

User avatar
Moem
Level 19
Level 19
Posts: 9201
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Can't remove Firefox

Post by Moem » Mon Sep 09, 2019 2:36 pm

Check the 'additional repositories' tab on the window of Software Sources.

And hacking... I honestly doubt it. The browser profile could be infected with malware. That's why I'm asking: have you tried a clean browser profile?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
experimenter
Level 1
Level 1
Posts: 19
Joined: Fri Apr 30, 2010 3:54 pm

Re: Can't remove Firefox

Post by experimenter » Mon Sep 09, 2019 5:40 pm

when pasting a screenshot expand the details tab so that the troubleshooter might have an idea of the issue plaguing you.
it'll be helpful if you tried

Code: Select all

apt update
apt remove --autoremove firefox
and post the error you get, if any, and as Moem said clean the browser profile.

gregory_opera
Level 1
Level 1
Posts: 26
Joined: Tue Aug 13, 2019 4:56 pm
Contact:

Re: Can't remove Firefox

Post by gregory_opera » Mon Sep 09, 2019 6:12 pm

Try to fix your packages... Press Ctrl + Alt + T and then type-in:

Code: Select all

sudo apt-get update
Enter your password and press "Enter".

Then type-in:

Code: Select all

sudo apt-get install -f
Finally, type type-in:

Code: Select all

sudo apt-get upgrade
If you get an error messages, feel free to post some or all of what you see in the Terminal window: "drag" to select the relevant text --> riht-click on your mouse / touchpad --> Copy.

Once you have done this, you can try to refresh your Firefox profile (the three lines / menu in the right corner --> Help --> Troubleshooting Information --> Refresh Firefox), or remove / re-install Firefox using the Terminal commands shown above (you should also be able to remove Firefox using the Software Manager, after following my instructions above)...
--

"All our dreams can come true - if we have the courage to pursue them."

Walt Disney. °o°

User avatar
Pjotr
Level 21
Level 21
Posts: 13220
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Can't remove Firefox

Post by Pjotr » Mon Sep 09, 2019 6:31 pm

And that tantalizing triangle before Details remains unclicked.... :shock:
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
Flemur
Level 17
Level 17
Posts: 7076
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Can't remove Firefox

Post by Flemur » Mon Sep 09, 2019 6:33 pm

Pjotr wrote:
Mon Sep 09, 2019 6:31 pm
And that tantalizing triangle before Details remains unclicked.... :shock:
I'd click it! But sometimes I do nutty things...
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

gregory_opera
Level 1
Level 1
Posts: 26
Joined: Tue Aug 13, 2019 4:56 pm
Contact:

Re: Can't remove Firefox

Post by gregory_opera » Mon Sep 09, 2019 11:26 pm

in case you missed the not-so-subtle-hint,
Image
they want you to click the arrow ...
--

"All our dreams can come true - if we have the courage to pursue them."

Walt Disney. °o°

User avatar
trytip
Level 11
Level 11
Posts: 3576
Joined: Tue Jul 05, 2016 1:20 pm

Re: Can't remove Firefox

Post by trytip » Mon Sep 09, 2019 11:46 pm

start fresh with a USER profile. do not worry. your linux browser application is not hacked, but your USER profile may be. this will DELETE your current firefox settings and you will start fresh
:backup your bookmarks first:

Code: Select all

rm -rf .mozilla
Image

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Thu Sep 12, 2019 6:25 am

I did click details in a previous session but what it said made no more sense than the error message with the non-grammatical "furthermore".

Thanks for the advice, Gregory. I ran the first command sudo apt-get update and got this response:

Code: Select all

Reading package lists... Done                                               
E: Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 Installer PPA' to 'Oracle Java (JDK) 8 Installer PPA (DISCONTINUED)'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Code: Select all

URL transformed to HTTPS due to an HSTS policy
--2019-09-12 12:03:01--  https://www.minecraft.net/android-icon-192x192.png
Resolving www.minecraft.net (www.minecraft.net)... 152.199.20.92, 2606:2800:233:18f9:1142:8f:20aa:11e2
Connecting to www.minecraft.net (www.minecraft.net)|152.199.20.92|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:03:01 ERROR 404: Not Found.
I ran the second command sudo apt-get install -f and got this:

Code: Select all

dpkg: error processing package minecraft-installer (--configure):
 installed minecraft-installer package post-installation script subprocess returned error exit status 8
Setting up libswscale4:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up libpostproc54:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libavformat57:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up libavresample3:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up libavfilter6:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up libavdevice57:amd64 (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up ffmpeg (7:3.4.6-0ubuntu0.18.04.1) ...
Setting up winff-gtk2 (1.5.5-4) ...
update-alternatives: using /usr/bin/winff-gtk2 to provide /usr/bin/winff (winff) in auto mode
Setting up winff (1.5.5-4) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 oracle-java8-installer
 minecraft-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
I ran the third command sudo apt-get upgrade and it did a million things, which ended in this error:

Code: Select all

Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
:(

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Thu Sep 12, 2019 6:31 am

I tried to remove Minecraft again and got more simple error message which said the removal had failed. When I clicked details it gave this:

Code: Select all

installArchives() failed: Setting up wget (1.19.4-1ubuntu2.2) ...
(Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 264730 files and directories currently installed.)
Removing firefox (65.0.1+linuxmint1+tessa) ...
Setting up libquadmath0:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libgs9-common (9.26~dfsg+0-0ubuntu0.18.04.11) ...
Setting up libgomp1:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libatomic1:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libxcb-present0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libglvnd0:amd64 (1.0.0-2ubuntu2.3) ...
Setting up libnss-systemd:amd64 (237-3ubuntu10.29) ...
Setting up libxcb-dri2-0:amd64 (1.13-2~ubuntu18.04) ...
Setting up keyboard-configuration (1.178ubuntu2.9) ...
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Setting up libxcb-dri3-0:amd64 (1.13-2~ubuntu18.04) ...
Setting up kmod (24-1ubuntu3.2) ...
Installing new version of config file /etc/modprobe.d/blacklist.conf ...
Setting up libxcb-glx0:amd64 (1.13-2~ubuntu18.04) ...
Setting up libcc1-0:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libxcb-xfixes0:amd64 (1.13-2~ubuntu18.04) ...
Setting up xserver-common (2:1.19.6-1ubuntu4.3) ...
Setting up cups-server-common (2.2.7-1ubuntu2.7) ...
Setting up libgstreamer1.0-0:amd64 (1.14.5-0ubuntu1~18.04.1) ...
Setcap worked! gst-ptp-helper is not suid!
Setting up libnss-myhostname:amd64 (237-3ubuntu10.29) ...
Setting up apt-utils (1.6.11) ...
Setting up debconf-i18n (1.5.66ubuntu1) ...
Setting up cups-common (2.2.7-1ubuntu2.7) ...
Setting up cups-ipp-utils (2.2.7-1ubuntu2.7) ...
Setting up libelf1:amd64 (0.170-0.4ubuntu0.1) ...
Setting up gir1.2-polkit-1.0 (0.105-20ubuntu0.18.04.5) ...
Setting up libtsan0:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up gpgconf (2.2.4-1ubuntu1.2) ...
Setting up libasound2-data (1.1.3-5ubuntu0.2) ...
Setting up libcurl4:amd64 (7.58.0-2ubuntu3.8) ...
Setting up java-common (0.68ubuntu1~18.04.1) ...
Setting up dbus-x11 (1.12.2-1ubuntu1.1) ...
Setting up gpg-agent (2.2.4-1ubuntu1.2) ...
Setting up libnss3:amd64 (2:3.35-2ubuntu2.3) ...
Setting up libcupsmime1:amd64 (2.2.7-1ubuntu2.7) ...
Setting up libgif7:amd64 (5.1.4-2ubuntu0.1) ...
Setting up cups-daemon (2.2.7-1ubuntu2.7) ...
Installing new version of config file /etc/apparmor.d/usr.sbin.cupsd ...
Setting up libglapi-mesa:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up python3-gi-cairo (3.26.1-2ubuntu1) ...
Setting up iproute2 (4.18.0-1ubuntu2~ubuntu18.04.1) ...
Installing new version of config file /etc/iproute2/ematch_map ...
Installing new version of config file /etc/iproute2/rt_protos ...
Setting up dbus-user-session (1.12.2-1ubuntu1.1) ...
Setting up gnupg-l10n (2.2.4-1ubuntu1.2) ...
Setting up libasound2:amd64 (1.1.3-5ubuntu0.2) ...
Setting up libneon27-gnutls:amd64 (0.30.2-3~ubuntu18.04.1) ...
Setting up libcupsppdc1:amd64 (2.2.7-1ubuntu2.7) ...
Setting up bzip2 (1.0.6-8.1ubuntu0.2) ...
Setting up libdrm-common (2.4.97-1ubuntu1~18.04.1) ...
Setting up liblsan0:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libxcb-sync1:amd64 (1.13-2~ubuntu18.04) ...
Setting up libcupsfilters1:amd64 (1.20.2-0ubuntu3.1) ...
Setting up libxslt1.1:amd64 (1.1.29-5ubuntu0.1) ...
Setting up libpoppler73:amd64 (0.62.0-2ubuntu2.10) ...
Setting up libsndfile1:amd64 (1.0.28-4ubuntu0.18.04.1) ...
Setting up libcupsimage2:amd64 (2.2.7-1ubuntu2.7) ...
Setting up libmpx2:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libfontembed1:amd64 (1.20.2-0ubuntu3.1) ...
Setting up libx11-xcb1:amd64 (2:1.6.4-3ubuntu0.2) ...
Setting up libglib2.0-data (2.56.4-0ubuntu0.18.04.4) ...
Setting up udev (237-3ubuntu10.29) ...
update-initramfs: deferring update (trigger activated)
Setting up gpgsm (2.2.4-1ubuntu1.2) ...
Setting up gnupg-utils (2.2.4-1ubuntu1.2) ...
Setting up libhsqldb1.8.0-java (1.8.0.10+dfsg-10~18.04) ...
Setting up libgail-3-0:amd64 (3.22.30-1ubuntu4) ...
Setting up libgles2:amd64 (1.0.0-2ubuntu2.3) ...
Setting up libavahi-glib1:amd64 (0.7-3.1ubuntu1.2) ...
Setting up console-setup-linux (1.178ubuntu2.9) ...
Setting up fonts-opensymbol (2:102.10+LibO6.0.7-0ubuntu0.18.04.9) ...
Setting up uno-libs3 (6.0.7-0ubuntu0.18.04.9) ...
Setting up libatk-wrapper-java (0.33.3-20ubuntu0.1) ...
Setting up dirmngr (2.2.4-1ubuntu1.2) ...
Setting up bluez (5.48-0ubuntu3.1) ...
Setting up libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.11) ...
Setting up libglib2.0-bin (2.56.4-0ubuntu0.18.04.4) ...
Setting up libgles2-mesa:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up cups-client (2.2.7-1ubuntu2.7) ...
Setting up libcupscgi1:amd64 (2.2.7-1ubuntu2.7) ...
Setting up ure (6.0.7-0ubuntu0.18.04.9) ...
Setting up libitm1:amd64 (8.3.0-6ubuntu1~18.04.1) ...
Setting up xserver-xorg-legacy (2:1.19.6-1ubuntu4.3) ...
setting xserver-xorg-legacy/xwrapper/allowed_users from configuration file
Setting up gpg (2.2.4-1ubuntu1.2) ...
Setting up libpython3.6:amd64 (3.6.8-1~18.04.2) ...
Setting up libwayland-server0:amd64 (1.16.0-1ubuntu1.1~18.04.1) ...
Setting up libxcb-xkb1:amd64 (1.13-2~ubuntu18.04) ...
Setting up libgstreamer-plugins-base1.0-0:amd64 (1.14.5-0ubuntu1~18.04.1) ...
Setting up console-setup (1.178ubuntu2.9) ...
update-initramfs: deferring update (trigger activated)
Setting up libpoppler-glib8:amd64 (0.62.0-2ubuntu2.10) ...
Setting up poppler-utils (0.62.0-2ubuntu2.10) ...
Setting up ifupdown (0.8.17ubuntu1.1) ...
Setting up cups-browsed (1.20.2-0ubuntu3.1) ...
Setting up libdw1:amd64 (0.170-0.4ubuntu0.1) ...
Setting up curl (7.58.0-2ubuntu3.8) ...
Setting up oracle-java8-installer (8u201-1~webupd8~1) ...
Using wget settings from /var/cache/oracle-jdk8-installer/wgetrc
Downloading Oracle Java 8...
--2019-09-12 12:27:19--  http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz
Resolving download.oracle.com (download.oracle.com)... 23.61.4.14
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz [following]
--2019-09-12 12:27:19--  https://edelivery.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.218.152.87, 2a02:a000:1:395::366, 2a02:a000:1:38f::366
Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.218.152.87|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284159_4dc5bff7ca9ca0eaa85b6092e7a5b356 [following]
--2019-09-12 12:27:20--  http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284159_4dc5bff7ca9ca0eaa85b6092e7a5b356
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284159_4dc5bff7ca9ca0eaa85b6092e7a5b356 [following]
--2019-09-12 12:27:20--  https://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284159_4dc5bff7ca9ca0eaa85b6092e7a5b356
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:27:22 ERROR 404: Not Found.

download failed
Oracle JDK 8 is NOT installed.
dpkg: error processing package oracle-java8-installer (--configure):
 installed oracle-java8-installer package post-installation script subprocess returned error exit status 1
Setting up cups-ppdc (2.2.7-1ubuntu2.7) ...
Setting up ghostscript (9.26~dfsg+0-0ubuntu0.18.04.11) ...
Setting up gpg-wks-server (2.2.4-1ubuntu1.2) ...
Setting up gpg-wks-client (2.2.4-1ubuntu1.2) ...
Setting up libxkbcommon-x11-0:amd64 (0.8.0-1ubuntu0.1) ...
Setting up libpulse0:amd64 (1:11.1-1ubuntu7.2) ...
Setting up libdrm2:amd64 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libgpgme11:amd64 (1.10.0-1ubuntu2) ...
Setting up cups-bsd (2.2.7-1ubuntu2.7) ...
Setting up libatk-wrapper-java-jni:amd64 (0.33.3-20ubuntu0.1) ...
Setting up cups-filters-core-drivers (1.20.2-0ubuntu3.1) ...
Setting up ghostscript-x (9.26~dfsg+0-0ubuntu0.18.04.11) ...
Setting up libgpgmepp6:amd64 (1.10.0-1ubuntu2) ...
Setting up libglx-mesa0:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up libpulse-mainloop-glib0:amd64 (1:11.1-1ubuntu7.2) ...
Setting up cups-filters (1.20.2-0ubuntu3.1) ...
Setting up libpulsedsp:amd64 (1:11.1-1ubuntu7.2) ...
Setting up pulseaudio-utils (1:11.1-1ubuntu7.2) ...
Setting up libgbm1:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up gnupg (2.2.4-1ubuntu1.2) ...
Setting up cups-core-drivers (2.2.7-1ubuntu2.7) ...
Setting up libegl-mesa0:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up python-apt (1.6.4) ...
Setting up libglx0:amd64 (1.0.0-2ubuntu2.3) ...
Setting up pulseaudio (1:11.1-1ubuntu7.2) ...
Setting up cups (2.2.7-1ubuntu2.7) ...
Updating PPD files for cups ...
Updating PPD files for cups-filters ...
Updating PPD files for foomatic-db-compressed-ppds ...
Updating PPD files for openprinting-ppds ...
Updating PPD files for brlaser ...
Updating PPD files for c2esp ...
Updating PPD files for foo2zjs-common ...
Updating PPD files for gutenprint ...
Updating PPD files for hpcups ...
Updating PPD files for m2300w ...
Updating PPD files for postscript-hp ...
Updating PPD files for ptouch ...
Updating PPD files for pxljr ...
Updating PPD files for sag-gdi ...
Updating PPD files for splix ...
Setting up libegl1:amd64 (1.0.0-2ubuntu2.3) ...
Setting up pulseaudio-module-bluetooth (1:11.1-1ubuntu7.2) ...
Setting up libgl1:amd64 (1.0.0-2ubuntu2.3) ...
Setting up libegl1-mesa:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up xserver-xorg-core (2:1.19.6-1ubuntu4.3) ...
Setting up libgl1-mesa-glx:amd64 (19.0.8-0ubuntu0~18.04.1) ...
Setting up openjdk-8-jre-headless:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Installing new version of config file /etc/java-8-openjdk/calendars.properties ...
Installing new version of config file /etc/java-8-openjdk/security/java.security ...
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/hsdb to provide /usr/bin/hsdb (hsdb) in auto mode
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/clhsdb to provide /usr/bin/clhsdb (clhsdb) in auto mode
update-alternatives: warning: alternative /usr/lib/jvm/java-11-openjdk-amd64/bin/orbd (part of link group orbd) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/orbd is dangling; it will be updated with best choice
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/orbd to provide /usr/bin/orbd (orbd) in auto mode
update-alternatives: warning: alternative /usr/lib/jvm/java-11-openjdk-amd64/bin/servertool (part of link group servertool) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/servertool is dangling; it will be updated with best choice
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/servertool to provide /usr/bin/servertool (servertool) in auto mode
update-alternatives: warning: alternative /usr/lib/jvm/java-11-openjdk-amd64/bin/tnameserv (part of link group tnameserv) doesn't exist; removing from list of alternatives
update-alternatives: warning: /etc/alternatives/tnameserv is dangling; it will be updated with best choice
update-alternatives: using /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/tnameserv to provide /usr/bin/tnameserv (tnameserv) in auto mode
Setting up libreoffice-style-galaxy (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up ca-certificates-java (20180516ubuntu1~18.04.1) ...
Installing new version of config file /etc/ca-certificates/update.d/jks-keystore ...
Importing keystore /etc/ssl/certs/java/cacerts to /etc/ssl/certs/java/cacerts.dpkg-new...
Entry for alias debian:geotrust_primary_certification_authority_-_g2.pem successfully imported.
Entry for alias debian:entrust_root_certification_authority_-_g2.pem successfully imported.
Entry for alias debian:opentrust_root_ca_g2.pem successfully imported.
Entry for alias debian:oiste_wisekey_global_root_gb_ca.pem successfully imported.
Entry for alias debian:certum_trusted_network_ca.pem successfully imported.
Entry for alias debian:ee_certification_centre_root_ca.pem successfully imported.
Entry for alias debian:amazon_root_ca_1.pem successfully imported.
Entry for alias debian:usertrust_ecc_certification_authority.pem successfully imported.
Entry for alias debian:buypass_class_3_root_ca.pem successfully imported.
Entry for alias debian:security_communication_rootca2.pem successfully imported.
Entry for alias debian:ssl-cert-snakeoil.pem successfully imported.
Entry for alias debian:certum_trusted_network_ca_2.pem successfully imported.
Entry for alias debian:certplus_class_2_primary_ca.pem successfully imported.
Entry for alias debian:quovadis_root_ca.pem successfully imported.
Entry for alias debian:buypass_class_2_root_ca.pem successfully imported.
Entry for alias debian:trustcor_rootcert_ca-2.pem successfully imported.
Entry for alias debian:sonera_class_2_root_ca.pem successfully imported.
Entry for alias debian:verisign_class_3_public_primary_certification_authority_-_g3.pem successfully imported.
Entry for alias debian:affirmtrust_commercial.pem successfully imported.
Entry for alias debian:trustcor_rootcert_ca-1.pem successfully imported.
Entry for alias debian:t-telesec_globalroot_class_3.pem successfully imported.
Entry for alias debian:starfield_class_2_ca.pem successfully imported.
Entry for alias debian:trktrust_elektronik_sertifika_hizmet_salaycs_h5.pem successfully imported.
Entry for alias debian:ssl.com_root_certification_authority_rsa.pem successfully imported.
Entry for alias debian:staat_der_nederlanden_ev_root_ca.pem successfully imported.
Entry for alias debian:entrust_root_certification_authority_-_ec1.pem successfully imported.
Entry for alias debian:gdca_trustauth_r5_root.pem successfully imported.
Entry for alias debian:identrust_commercial_root_ca_1.pem successfully imported.
Entry for alias debian:certigna.pem successfully imported.
Entry for alias debian:netlock_arany_=class_gold=_ftanstvny.pem successfully imported.
Entry for alias debian:digicert_global_root_g3.pem successfully imported.
Entry for alias debian:twca_root_certification_authority.pem successfully imported.
Entry for alias debian:baltimore_cybertrust_root.pem successfully imported.
Entry for alias debian:amazon_root_ca_4.pem successfully imported.
Entry for alias debian:ssl.com_ev_root_certification_authority_rsa_r2.pem successfully imported.
Entry for alias debian:ssl.com_ev_root_certification_authority_ecc.pem successfully imported.
Entry for alias debian:verisign_class_3_public_primary_certification_authority_-_g5.pem successfully imported.
Entry for alias debian:certinomis_-_root_ca.pem successfully imported.
Entry for alias debian:comodo_ecc_certification_authority.pem successfully imported.
Entry for alias debian:cybertrust_global_root.pem successfully imported.
Entry for alias debian:starfield_root_certificate_authority_-_g2.pem successfully imported.
Entry for alias debian:geotrust_primary_certification_authority_-_g3.pem successfully imported.
Entry for alias debian:comodo_rsa_certification_authority.pem successfully imported.
Entry for alias debian:actalis_authentication_root_ca.pem successfully imported.
Entry for alias debian:addtrust_external_root.pem successfully imported.
Entry for alias debian:entrust_root_certification_authority.pem successfully imported.
Entry for alias debian:entrust.net_premium_2048_secure_server_ca.pem successfully imported.
Entry for alias debian:hongkong_post_root_ca_1.pem successfully imported.
Entry for alias debian:atos_trustedroot_2011.pem successfully imported.
Entry for alias debian:isrg_root_x1.pem successfully imported.
Entry for alias debian:globalsign_root_ca_-_r3.pem successfully imported.
Entry for alias debian:digicert_assured_id_root_g3.pem successfully imported.
Entry for alias debian:verisign_class_3_public_primary_certification_authority_-_g4.pem successfully imported.
Entry for alias debian:accvraiz1.pem successfully imported.
Entry for alias debian:securetrust_ca.pem successfully imported.
Entry for alias debian:digicert_assured_id_root_ca.pem successfully imported.
Entry for alias debian:globalsign_root_ca_-_r2.pem successfully imported.
Entry for alias debian:starfield_services_root_certificate_authority_-_g2.pem successfully imported.
Entry for alias debian:d-trust_root_class_3_ca_2_2009.pem successfully imported.
Entry for alias debian:staat_der_nederlanden_root_ca_-_g2.pem successfully imported.
Entry for alias debian:thawte_primary_root_ca_-_g2.pem successfully imported.
Entry for alias debian:deutsche_telekom_root_ca_2.pem successfully imported.
Entry for alias debian:geotrust_primary_certification_authority.pem successfully imported.
Entry for alias debian:izenpe.com.pem successfully imported.
Entry for alias debian:secure_global_ca.pem successfully imported.
Entry for alias debian:thawte_primary_root_ca_-_g3.pem successfully imported.
Entry for alias debian:go_daddy_class_2_ca.pem successfully imported.
Entry for alias debian:securesign_rootca11.pem successfully imported.
Entry for alias debian:szafir_root_ca2.pem successfully imported.
Entry for alias debian:quovadis_root_ca_3_g3.pem successfully imported.
Entry for alias debian:t-telesec_globalroot_class_2.pem successfully imported.
Entry for alias debian:hellenic_academic_and_research_institutions_rootca_2015.pem successfully imported.
Entry for alias debian:amazon_root_ca_2.pem successfully imported.
Entry for alias debian:d-trust_root_class_3_ca_2_ev_2009.pem successfully imported.
Entry for alias debian:hellenic_academic_and_research_institutions_ecc_rootca_2015.pem successfully imported.
Entry for alias debian:swisssign_gold_ca_-_g2.pem successfully imported.
Entry for alias debian:go_daddy_root_certificate_authority_-_g2.pem successfully imported.
Entry for alias debian:network_solutions_certificate_authority.pem successfully imported.
Entry for alias debian:globalsign_root_ca.pem successfully imported.
Entry for alias debian:opentrust_root_ca_g3.pem successfully imported.
Entry for alias debian:visa_ecommerce_root.pem successfully imported.
Entry for alias debian:staat_der_nederlanden_root_ca_-_g3.pem successfully imported.
Entry for alias debian:hellenic_academic_and_research_institutions_rootca_2011.pem successfully imported.
Entry for alias debian:quovadis_root_ca_3.pem successfully imported.
Entry for alias debian:security_communication_root_ca.pem successfully imported.
Entry for alias debian:global_chambersign_root_-_2008.pem successfully imported.
Entry for alias debian:autoridad_de_certificacion_firmaprofesional_cif_a62634068.pem successfully imported.
Entry for alias debian:dst_root_ca_x3.pem successfully imported.
Entry for alias debian:amazon_root_ca_3.pem successfully imported.
Entry for alias debian:digicert_high_assurance_ev_root_ca.pem successfully imported.
Entry for alias debian:certplus_root_ca_g2.pem successfully imported.
Entry for alias debian:digicert_global_root_g2.pem successfully imported.
Entry for alias debian:epki_root_certification_authority.pem successfully imported.
Entry for alias debian:quovadis_root_ca_2_g3.pem successfully imported.
Entry for alias debian:geotrust_universal_ca_2.pem successfully imported.
Entry for alias debian:teliasonera_root_ca_v1.pem successfully imported.
Entry for alias debian:oiste_wisekey_global_root_ga_ca.pem successfully imported.
Entry for alias debian:digicert_trusted_root_g4.pem successfully imported.
Entry for alias debian:certsign_root_ca.pem successfully imported.
Entry for alias debian:quovadis_root_ca_1_g3.pem successfully imported.
Entry for alias debian:ca_disig_root_r2.pem successfully imported.
Entry for alias debian:usertrust_rsa_certification_authority.pem successfully imported.
Entry for alias debian:trustcor_eca-1.pem successfully imported.
Entry for alias debian:globalsign_ecc_root_ca_-_r4.pem successfully imported.
Entry for alias debian:cfca_ev_root.pem successfully imported.
Entry for alias debian:affirmtrust_networking.pem successfully imported.
Entry for alias debian:digicert_assured_id_root_g2.pem successfully imported.
Entry for alias debian:globalsign_ecc_root_ca_-_r5.pem successfully imported.
Entry for alias debian:ssl.com_root_certification_authority_ecc.pem successfully imported.
Entry for alias debian:affirmtrust_premium.pem successfully imported.
Entry for alias debian:identrust_public_sector_root_ca_1.pem successfully imported.
Entry for alias debian:quovadis_root_ca_2.pem successfully imported.
Entry for alias debian:swisssign_silver_ca_-_g2.pem successfully imported.
Entry for alias debian:verisign_universal_root_certification_authority.pem successfully imported.
Entry for alias debian:e-tugra_certification_authority.pem successfully imported.
Entry for alias debian:geotrust_global_ca.pem successfully imported.
Entry for alias debian:opentrust_root_ca_g1.pem successfully imported.
Entry for alias debian:ac_raiz_fnmt-rcm.pem successfully imported.
Entry for alias debian:ec-acc.pem successfully imported.
Entry for alias debian:thawte_primary_root_ca.pem successfully imported.
Entry for alias debian:twca_global_root_ca.pem successfully imported.
Entry for alias debian:chambers_of_commerce_root_-_2008.pem successfully imported.
Entry for alias debian:luxtrust_global_root_2.pem successfully imported.
Entry for alias debian:taiwan_grca.pem successfully imported.
Entry for alias debian:tubitak_kamu_sm_ssl_kok_sertifikasi_-_surum_1.pem successfully imported.
Entry for alias debian:affirmtrust_premium_ecc.pem successfully imported.
Entry for alias debian:comodo_certification_authority.pem successfully imported.
Entry for alias debian:trustis_fps_root_ca.pem successfully imported.
Entry for alias debian:comodo_aaa_services_root.pem successfully imported.
Entry for alias debian:geotrust_universal_ca.pem successfully imported.
Entry for alias debian:microsec_e-szigno_root_ca_2009.pem successfully imported.
Entry for alias debian:certplus_root_ca_g1.pem successfully imported.
Entry for alias debian:xramp_global_ca_root.pem successfully imported.
Entry for alias debian:digicert_global_root_ca.pem successfully imported.
Import command completed:  134 entries successfully imported, 0 entries failed or cancelled
Setting up openjdk-8-jdk-headless:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Setting up openjdk-11-jre-headless:amd64 (11.0.4+11-1ubuntu2~18.04.3) ...
Installing new version of config file /etc/java-11-openjdk/accessibility.properties ...
Installing new version of config file /etc/java-11-openjdk/jvm-amd64.cfg ...
Installing new version of config file /etc/java-11-openjdk/management/management.properties ...
Installing new version of config file /etc/java-11-openjdk/net.properties ...
Installing new version of config file /etc/java-11-openjdk/security/default.policy ...
Installing new version of config file /etc/java-11-openjdk/security/java.security ...
Installing new version of config file /etc/java-11-openjdk/security/policy/README.txt ...
Setting up openjdk-8-jre:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Setting up libreoffice-style-tango (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up default-jre-headless (2:1.11-68ubuntu1~18.04.1) ...
Setting up openjdk-11-jre:amd64 (11.0.4+11-1ubuntu2~18.04.3) ...
Setting up libreoffice-common (1:6.0.7-0ubuntu0.18.04.9) ...
Installing new version of config file /etc/apparmor.d/usr.lib.libreoffice.program.senddoc ...
Installing new version of config file /etc/apparmor.d/usr.lib.libreoffice.program.soffice.bin ...
Setting up openjdk-8-jdk:amd64 (8u222-b10-1ubuntu1~18.04.1) ...
Setting up default-jre (2:1.11-68ubuntu1~18.04.1) ...
Setting up libreoffice-core (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up openjdk-8-demo (8u222-b10-1ubuntu1~18.04.1) ...
Setting up python3-uno (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up minecraft-installer (1.8~xenial1.0) ...
--2019-09-12 12:27:36--  http://s3.amazonaws.com/Minecraft.Download/launcher/Minecraft.jar
Resolving s3.amazonaws.com (s3.amazonaws.com)... 52.216.138.21
Connecting to s3.amazonaws.com (s3.amazonaws.com)|52.216.138.21|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 280212 (274K) [application/java-archive]
Saving to: /tmp/minecKRnjjO.jar


/tmp/minecKRnjjO.ja   0%%[                    ]       0  --.-KB/s               
/tmp/minecKRnjjO.ja  16%%[==>                 ]  46.18K   228KB/s               
/tmp/minecKRnjjO.ja  80%%[===============>    ] 219.59K   544KB/s               
/tmp/minecKRnjjO.ja 100%%[===================>] 273.64K   602KB/s    in 0.5s    

2019-09-12 12:27:37 (602 KB/s) - /tmp/minecKRnjjO.jar saved [280212/280212]

URL transformed to HTTPS due to an HSTS policy
--2019-09-12 12:27:37--  https://www.minecraft.net/android-icon-192x192.png
Resolving www.minecraft.net (www.minecraft.net)... 152.199.20.92, 2606:2800:233:18f9:1142:8f:20aa:11e2
Connecting to www.minecraft.net (www.minecraft.net)|152.199.20.92|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:27:37 ERROR 404: Not Found.

dpkg: error processing package minecraft-installer (--configure):
 installed minecraft-installer package post-installation script subprocess returned error exit status 8
Setting up libreoffice-base-drivers (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-gtk3 (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-gnome (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-pdfimport (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-draw (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-avmedia-backend-gstreamer (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-java-common (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-impress (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-math (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-base-core (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-sdbc-hsqldb (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-calc (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-ogltrans (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-writer (1:6.0.7-0ubuntu0.18.04.9) ...
Setting up libreoffice-base (1:6.0.7-0ubuntu0.18.04.9) ...
Processing triggers for libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.4) ...
Processing triggers for initramfs-tools (0.130ubuntu3) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-20-generic
Processing triggers for gnome-icon-theme (3.12.0-3) ...
Processing triggers for mintsystem (8.3.8) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for doc-base (0.10.8) ...
Processing 2 changed doc-base files...
Registering documents with scrollkeeper...
Processing triggers for systemd (237-3ubuntu10.29) ...
Processing triggers for man-db (2.8.3-2) ...
Processing triggers for shared-mime-info (1.9-2) ...
Processing triggers for dbus (1.12.2-1ubuntu1.1) ...
Processing triggers for ca-certificates (20180409) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

done.
done.
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for fontconfig (2.12.6-0ubuntu2) ...
Processing triggers for ufw (0.35-5) ...
Processing triggers for gconf2 (3.2.6-4ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Processing triggers for desktop-file-utils (0.23+linuxmint3) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up libgnomekbd8:amd64 (3.26.0-3ubuntu0.18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 oracle-java8-installer
 minecraft-installer
Setting up oracle-java8-installer (8u201-1~webupd8~1) ...
Using wget settings from /var/cache/oracle-jdk8-installer/wgetrc
Downloading Oracle Java 8...
--2019-09-12 12:28:38--  http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz
Resolving download.oracle.com (download.oracle.com)... 23.61.4.14
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz [following]
--2019-09-12 12:28:38--  https://edelivery.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz
Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.218.152.87, 2a02:a000:1:38f::366, 2a02:a000:1:395::366
Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.218.152.87|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284239_82b142245258702ae2907a17dee07054 [following]
--2019-09-12 12:28:39--  http://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284239_82b142245258702ae2907a17dee07054
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284239_82b142245258702ae2907a17dee07054 [following]
--2019-09-12 12:28:39--  https://download.oracle.com/otn-pub/java/jdk/8u201-b09/42970487e3af4f5aa5bca3f542482c60/jdk-8u201-linux-x64.tar.gz?AuthParam=1568284239_82b142245258702ae2907a17dee07054
Connecting to download.oracle.com (download.oracle.com)|23.61.4.14|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:28:40 ERROR 404: Not Found.

download failed
Oracle JDK 8 is NOT installed.
dpkg: error processing package oracle-java8-installer (--configure):
 installed oracle-java8-installer package post-installation script subprocess returned error exit status 1
Setting up minecraft-installer (1.8~xenial1.0) ...
--2019-09-12 12:28:41--  http://s3.amazonaws.com/Minecraft.Download/launcher/Minecraft.jar
Resolving s3.amazonaws.com (s3.amazonaws.com)... 52.217.38.238
Connecting to s3.amazonaws.com (s3.amazonaws.com)|52.217.38.238|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 280212 (274K) [application/java-archive]
Saving to: /tmp/minecvLiIsa.jar

/tmp/minecvLiIsa.ja   0%%[                    ]       0  --.-KB/s               
/tmp/minecvLiIsa.ja  18%%[==>                 ]  50.34K   252KB/s               
/tmp/minecvLiIsa.ja  86%%[================>   ] 236.34K   587KB/s               
/tmp/minecvLiIsa.ja 100%%[===================>] 273.64K   655KB/s    in 0.4s    

2019-09-12 12:28:41 (655 KB/s) - /tmp/minecvLiIsa.jar saved [280212/280212]

URL transformed to HTTPS due to an HSTS policy
--2019-09-12 12:28:41--  https://www.minecraft.net/android-icon-192x192.png
Resolving www.minecraft.net (www.minecraft.net)... 152.199.20.92, 2606:2800:233:18f9:1142:8f:20aa:11e2
Connecting to www.minecraft.net (www.minecraft.net)|152.199.20.92|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:28:41 ERROR 404: Not Found.

dpkg: error processing package minecraft-installer (--configure):
 installed minecraft-installer package post-installation script subprocess returned error exit status 8
Processing triggers for hicolor-icon-theme (0.17-2) ...

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: Can't remove Firefox

Post by gm10 » Thu Sep 12, 2019 6:40 am

iamthewalrus wrote:
Thu Sep 12, 2019 6:25 am
I did click details in a previous session but what it said made no more sense than the error message with the non-grammatical "furthermore".

Code: Select all

Reading package lists... Done                                               
E: Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 Installer PPA' to 'Oracle Java (JDK) 8 Installer PPA (DISCONTINUED)'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
This is telling you that the webupd8team/java PPA is discontinued, so you should remove it (via the Software Sources tool). You should probably also remove the software you installed from it. What's wrong with OpenJDK, anyway?
iamthewalrus wrote:
Thu Sep 12, 2019 6:25 am

Code: Select all

URL transformed to HTTPS due to an HSTS policy
--2019-09-12 12:03:01--  https://www.minecraft.net/android-icon-192x192.png
Resolving www.minecraft.net (www.minecraft.net)... 152.199.20.92, 2606:2800:233:18f9:1142:8f:20aa:11e2
Connecting to www.minecraft.net (www.minecraft.net)|152.199.20.92|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-09-12 12:03:01 ERROR 404: Not Found.
I don't know why Mint is distributing the minecraft-installer package (it's a no longer maintained package from an abandoned PPA for older versions of Mint/Ubuntu) but it clearly has very broken packaging, trying to download a remote icon (probably a weak attempt at getting around copyrights) and then failing when it cannot be found anymore after all this time. Not sure what Clem was thinking. Isn't there a Minecraft flatpak?

Anyway, try

Code: Select all

sudo dpkg --remove --force-remove-reinstreq --force-depends oracle-java8-installer minecraft-installer
and then see if this goes through:

Code: Select all

apt purge --autoremove
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Thu Sep 12, 2019 7:01 am

I tried to install Minecraft because my son wanted to play it but it never worked. I used you first command and it seemed to execute successfully. Maybe with Minecraft gone things will work okay ...

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: Can't remove Firefox

Post by gm10 » Thu Sep 12, 2019 7:28 am

iamthewalrus wrote:
Thu Sep 12, 2019 7:01 am
I tried to install Minecraft because my son wanted to play it but it never worked. I used you first command and it seemed to execute successfully. Maybe with Minecraft gone things will work okay ...
You will know if the second one runs without errors. ;)

I'm not a Minecraft player so I cannot advise on the best way to install it. I just know that there is a flatpak version so that might be easier to install (should also be in Software Manager).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Thu Sep 12, 2019 7:45 am

Yes, the second command worked okay too. What should I do now? Go back and try Gregory's suggestions that didn't work before?

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: Can't remove Firefox

Post by gm10 » Thu Sep 12, 2019 7:50 am

iamthewalrus wrote:
Thu Sep 12, 2019 7:45 am
Yes, the second command worked okay too. What should I do now? Go back and try Gregory's suggestions that didn't work before?
No, you should be all good now, nothing else you have to do.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Thu Sep 12, 2019 8:16 am

OMG! Thanks very much ...

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: Can't remove Firefox

Post by gm10 » Thu Sep 12, 2019 8:19 am

You are welcome. Actually just to make sure, you did remove that PPA via Software Sources like I said, right? Otherwise that first error will come up again when you try to refresh the repository lists.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

iamthewalrus
Level 1
Level 1
Posts: 28
Joined: Wed Sep 11, 2013 9:53 am

Re: Can't remove Firefox

Post by iamthewalrus » Fri Sep 13, 2019 5:27 am

I did everything in the terminal ...

Actually the weirdness continues. I don't think the central problem was Firefox or Minecraft. I opened a new thread starting with explaining the symptoms rather than my diagnosis:
viewtopic.php?f=47&t=301669&p=1685293#p1685293

Post Reply

Return to “Software & Applications”