[SOLVED] Opera doesn't open maximized in 19.2 (Cinnamon)

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
FenderGuy
Level 2
Level 2
Posts: 51
Joined: Thu Aug 18, 2016 5:24 pm

[SOLVED] Opera doesn't open maximized in 19.2 (Cinnamon)

Post by FenderGuy » Tue Sep 10, 2019 3:31 pm

Where/How do I change how Opera opens, so that the screen is always maximized?
Last edited by FenderGuy on Fri Sep 13, 2019 3:04 pm, edited 7 times in total.

User avatar
murray
Level 4
Level 4
Posts: 300
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: Installed Linux Mint 19.2, BUT Opera won't open maximized

Post by murray » Tue Sep 10, 2019 4:05 pm

FenderGuy wrote:
Tue Sep 10, 2019 3:31 pm
Unfortunately, Mint 19.2 isn't recognizing the code.
What "code" are you using?
Running Mint 19.2 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

FenderGuy
Level 2
Level 2
Posts: 51
Joined: Thu Aug 18, 2016 5:24 pm

Re: Installed Linux Mint 19.2, BUT Opera won't open maximized

Post by FenderGuy » Tue Sep 10, 2019 4:15 pm

murray wrote:
Tue Sep 10, 2019 4:05 pm
FenderGuy wrote:
Tue Sep 10, 2019 3:31 pm
Unfortunately, Mint 19.2 isn't recognizing the code.
What "code" are you using?
I'm not. Don't know where/how to do it.
Last edited by FenderGuy on Fri Sep 13, 2019 9:23 am, edited 2 times in total.

User avatar
murray
Level 4
Level 4
Posts: 300
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: Installed Linux Mint 19.2, BUT Opera won't open maximized

Post by murray » Tue Sep 10, 2019 4:45 pm

I use Opera and I too like it to open maximised. Like you I edit the opera.desktop file and add the --start-maximized option to the end of the Exec=opera %U line. However I do this directly on the /usr/share/applications/opera.desktop file, I don't copy that file and then edit the copy.

But I'm guessing that it depends on where you're running Opera from, eg from the Start menu, a desktop shortcut, etc. You'd have to make sure that you were editing the correct file that matches where you're launching Opera from.

Personally I find having to manually edit the desktop file every time Opera updates a real pain (the update process overwrites my changes each time). It would be good if this could be automated somehow...
Running Mint 19.2 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

FenderGuy
Level 2
Level 2
Posts: 51
Joined: Thu Aug 18, 2016 5:24 pm

Re: Installed Linux Mint 19.2, BUT Opera won't open maximized

Post by FenderGuy » Wed Sep 11, 2019 9:46 am

murray wrote:
Tue Sep 10, 2019 4:45 pm
I use Opera and I too like it to open maximised. Like you I edit the opera.desktop file and add the --start-maximized option to the end of the Exec=opera %U line. However I do this directly on the /usr/share/applications/opera.desktop file, I don't copy that file and then edit the copy.

But I'm guessing that it depends on where you're running Opera from, eg from the Start menu, a desktop shortcut, etc. You'd have to make sure that you were editing the correct file that matches where you're launching Opera from.

Personally I find having to manually edit the desktop file every time Opera updates a real pain (the update process overwrites my changes each time). It would be good if this could be automated somehow...
I right-clicked the Opera icon in the Start Menu, then clicked Add to Panel. I'm using the one in the Panel.
Last edited by FenderGuy on Fri Sep 13, 2019 9:28 am, edited 1 time in total.

FenderGuy
Level 2
Level 2
Posts: 51
Joined: Thu Aug 18, 2016 5:24 pm

Re: Opera doesn't open maximized in 19.2 (Cinnamon)

Post by FenderGuy » Thu Sep 12, 2019 8:30 am

Disregard.
Last edited by FenderGuy on Fri Sep 13, 2019 9:31 am, edited 1 time in total.

FenderGuy
Level 2
Level 2
Posts: 51
Joined: Thu Aug 18, 2016 5:24 pm

Opera doesn't open maximized in 19.2 (Cinnamon)

Post by FenderGuy » Thu Sep 12, 2019 12:56 pm

Any ideas?

User avatar
murray
Level 4
Level 4
Posts: 300
Joined: Tue Nov 27, 2018 4:22 pm
Location: Auckland, New Zealand

Re: [SOLVED] Opera doesn't open maximized in 19.2 (Cinnamon)

Post by murray » Fri Sep 13, 2019 5:17 pm

This is what I've just done and it appears to be working ok, even after an Opera update. In Opera go Menu > Settings. In the "On startup" section select "Retain tabs from previous session" (optionally select "Display the start page first" option if you want that). This seems to cause Opera to remember the window size when it was closed and to reinstate that size. So maximize the Opera window and then close and reopen Opera to see if it now opens full-screen.
Running Mint 19.2 Cinnamon on an Intel NUC8i5BEH with 16GB RAM and 500GB SSD

LogMan
Level 2
Level 2
Posts: 54
Joined: Thu Apr 06, 2017 8:57 pm

Re: [SOLVED] Opera doesn't open maximized in 19.2 (Cinnamon)

Post by LogMan » Fri Sep 13, 2019 6:58 pm

murray wrote:
Fri Sep 13, 2019 5:17 pm
This is what I've just done and it appears to be working ok, even after an Opera update. In Opera go Menu > Settings. In the "On startup" section select "Retain tabs from previous session" (optionally select "Display the start page first" option if you want that). This seems to cause Opera to remember the window size when it was closed and to reinstate that size. So maximize the Opera window and then close and reopen Opera to see if it now opens full-screen.
Finally an easy solution that worked !

Thanks for that 8)

Post Reply

Return to “Software & Applications”