lm19.2 kill x-system hotkey

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
sadhu
Level 5
Level 5
Posts: 572
Joined: Fri Nov 22, 2013 9:48 am
Contact:

lm19.2 kill x-system hotkey

Post by sadhu » Thu Sep 12, 2019 7:52 am

In LM 18.3 I could load the kill x-system as an applet, and run it via Ctrl-Alt-Bksp. Thus I could temporarily shut down the option if needed.

In LM19.2 I have been mistakenly hitting Ctrl-Alt-Bksp, causing me to lose some work and having to reload everything. So I went to applets, thinking I had installed the old applet, and lo! it wasn't there!

How do I disable the apparently built-in key sequence Ctrl-alt-bksp, or perhaps better, assign it to a different keystroke combination, such as RIGHT Ctrl-Super-Alt-F1? I couldn't find it in the keyboard applet.

(I tried tried looking in dconf editor, but the new GUI of the editor is useless if you're hunting for some setting.)

I just discovered "sudo systemctl restart display-manager", which I can run from a custom shortcut. Unfortunately when set to a hotkey it asks for Admin Password, so that's out.

In case you're wondering why I need to kill the xsystem: often when I'm paging through video files using Nemo, the system will lock up; the mouse works, but not clicks. I've found that Restarting the x-system works to get things going again.


-Sadhu
Last edited by sadhu on Thu Sep 12, 2019 8:22 am, edited 2 times in total.
sabbe sattā bhavantu sukhitattā. LN 19.2-64 Cinn 3.6.7, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:Dell Inspiron 15-3000, Core i3, 4G RAM Intel Gfx

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: lm19.2 kill x-system hotkey

Post by gm10 » Thu Sep 12, 2019 8:13 am

Go to startup applications and disable the "Ctrl Alt Backspace" entry. Then go to your keyboard layout options and make sure you have not configured it there, either.

Restart for this to take effect (or run setxkbmap -option).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

sadhu
Level 5
Level 5
Posts: 572
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: lm19.2 kill x-system hotkey

Post by sadhu » Thu Sep 12, 2019 9:07 am

Blind. I just didn't notice the entry in the startup apps setting. Perhaps it was named something else, previously.

Thank you, I can turn it off now. however, your suggestion regarding setxkbmap -option.

However, running setxkbmap -rules evdev doesn't restart it.

The backspace key doesn't seem to have been tweaked via setmodmap, per setmodmap -pk, either.

Any other ideas?
sabbe sattā bhavantu sukhitattā. LN 19.2-64 Cinn 3.6.7, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:Dell Inspiron 15-3000, Core i3, 4G RAM Intel Gfx

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: lm19.2 kill x-system hotkey

Post by gm10 » Thu Sep 12, 2019 9:44 am

sadhu wrote:
Thu Sep 12, 2019 9:07 am
Any other ideas?
I am not sure what your remaining problem is, you said you could turn it off now and I'm not sure what the rest of your post is about?
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

sadhu
Level 5
Level 5
Posts: 572
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: lm19.2 kill x-system hotkey

Post by sadhu » Thu Sep 12, 2019 10:04 am

NOW the kill X Session function is totally messed up.

I was doing some experimentation with a combination of
  • Enabling and disabline CtrlAltBksp in System Starup
  • setxkbmap -option terminate:ctrl_alt_bksp
  • sudo systemctl restart display-manager
and now the Ctrl Alt Bksp setting has completely disappeared from the startup menu.

Both Ctrl_Alt_Bksp and sudo systemctl restart display-manager kill the X system.

But I can't turn it off by sudo setxkbmap -option terminate:ctrl_alt_bksp

Sigh.

Thank goodness for timeshift.


-Sadhu
sabbe sattā bhavantu sukhitattā. LN 19.2-64 Cinn 3.6.7, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:Dell Inspiron 15-3000, Core i3, 4G RAM Intel Gfx

sadhu
Level 5
Level 5
Posts: 572
Joined: Fri Nov 22, 2013 9:48 am
Contact:

Re: lm19.2 kill x-system hotkey

Post by sadhu » Thu Sep 12, 2019 10:52 am

gm10 wrote:
Thu Sep 12, 2019 9:44 am
sadhu wrote:
Thu Sep 12, 2019 9:07 am
Any other ideas?
I am not sure what your remaining problem is, you said you could turn it off now and I'm not sure what the rest of your post is about?
I could before, but now i can't.

BTW running timeshift to last night's save doesn't help
sabbe sattā bhavantu sukhitattā. LN 19.2-64 Cinn 3.6.7, Mobo: ASUSTeK STRIX B250G GAMING v, Dual core Pntm G4560, Intel Gfx. Laptop:Dell Inspiron 15-3000, Core i3, 4G RAM Intel Gfx

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: lm19.2 kill x-system hotkey

Post by gm10 » Thu Sep 12, 2019 11:05 am

Well, it's something else in your unknown desktop environment providing the functionality then. Check your keybinds I guess.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

Post Reply

Return to “Software & Applications”