Search function in Nemo doesn't work all of the sudden

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
James_Smith
Level 4
Level 4
Posts: 380
Joined: Wed Feb 18, 2015 6:41 pm

Search function in Nemo doesn't work all of the sudden

Post by James_Smith »

In the years that I've been using Nemo, I've been able to search a folder for "." so that I can see all files with a dot in them (which is all files). Now, all of the sudden I can't do this. In fact, I can't search for any term less than 3 digits, symbols, or letters.

For example, I can search for "kun" and everything that has "kun" in it comes up but if I search for "ku" or "k" nothing comes up.
sudo apt-get --purge remove macOS

User avatar
smurphos
Level 15
Level 15
Posts: 5581
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Search function in Nemo doesn't work all of the sudden

Post by smurphos »

Hi, the search behaviour was changed with nemo 4.2.3 released at the end of August to limit the minimum search string to three characters. It was part of a fix to prevent searches for an empty string which would crash nemo.

https://github.com/linuxmint/nemo/issues/2073
https://github.com/linuxmint/nemo/commi ... 3cc3742962

You can still have wildcards as one of the three characters if you really, really need to, but I don't recommend it. I can chew up a lot of processor time and RAM if you try that on the whole file system.

e.g.

ku* or *k* or *.*
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

Post Reply

Return to “Software & Applications”