ScreenSaver doesn't come on

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

ScreenSaver doesn't come on

Post by helpmelearn »

Hello... I'm a first time user with Linux, like 2 whole days. Just curious about how to get the screensaver to activate? I'm using Mint 19.2 "Tina" - MATE (64-bit)
When I try the preview that works but it will not activate on its own. I have a checkmark on Activate screensaver when computer is idle. ( 1 minute ) .. Both options under On AC Power >> Never
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

MATE is my primary desktop. No trouble with screensaver. Does the screen go blank instead? How much fiddling with desktop settings have you done? Resetting the desktop is an option, but I'm curious how much you'll have to do over.
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

Hi ... Yes, it goes blank or a black screen instead. I'm not sure what you mean by how much fiddling I have done, there only so much one can do within the Screensaver setting, no? Or are you saying other settings within the desktop can cause it from not working? Thanks
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

Yes, I meant the other settings, as there's no way I know to reset without resetting the whole desktop.

Let's check something simple first. The default screensaver is a blank screen. Which screensaver have you selected?
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

Have a look, it's the GL planet one
Attachments
Screenshot at 2019-10-02 14-43-00.png
Screenshot at 2019-10-02 14-42-20.png
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

Now there no blank screen. what it's doing now when the time for the screensaver should come on it does a faded out to a blank screen but seconds later it goes back to the desktop screen. I'm curious to know are you using like I am a HDMI cable set up with the monitor?
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

Hardware was what I was going to suggest we check next. No HDMI cable on my end. My main system is Mate 19.1 on a laptop. Have 19.2 on a full install USB hard drive and also a VirtualBox VM, both running on the same laptop. Both run GLPlanet fine. Please open Terminal, expand to full screen and run inxi -SMG (this will report some basic system information, including your graphics adapter). Copy the output and paste into your next post. Use code tags (the </> button about the text entry window), as this preserves formatting and makes the output easier to read.
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

Code: Select all

system:    Host: OptiPlex-990 Kernel: 4.15.0-65-generic x86_64 bits: 64 Desktop: MATE 1.22.0 Distro: Linux Mint 19.2 Tina 
Machine:   Type: Desktop System: Dell product: OptiPlex 990 v: 01 serial: <root required> 
           Mobo: Dell model: 06D7TR v: A00 serial: <root required> UEFI: Dell v: A24 date: 07/02/2018 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Redwood XT [Radeon HD 5670/5690/5730] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 4.15.0-65-generic LLVM 8.0.0) v: 3.3 Mesa 19.0.8 
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

Code: Select all

System:
Host: OptiPlex-990 Kernel: 4.15.0-65-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: MATE 1.22.0 Distro: Linux Mint 19.2 Tina
base: Ubuntu 18.04 bionic
Machine:
Type: Desktop System: Dell product: OptiPlex 990 v: 01 serial: <filter>
Mobo: Dell model: 06D7TR v: A00 serial: <filter> UEFI: Dell v: A24
date: 07/02/2018
CPU:
Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP
arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24744
Speed: 1596 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1596 2: 1596
3: 1596 4: 1597
Graphics:
Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] vendor: ASUSTeK
driver: radeon v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: ati,radeon
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 4.15.0-65-generic LLVM 8.0.0)
v: 3.3 Mesa 19.0.8 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series] vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k4.15.0-65-generic
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
v: 3.2.6-k port: 4040 bus ID: 00:19.0
IF: eno1 state: down mac: <filter>
Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network
Adapter
driver: wl v: kernel port: 3000 bus ID: 04:00.0
IF: wlp4s0 state: up mac: <filter>
Drives:
Local Storage: total: 111.79 GiB used: 15.43 GiB (13.8%)
ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB
RAID:
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
bus ID: 00:1f.2
Partition:
ID-1: / size: 109.04 GiB used: 15.42 GiB (14.1%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 34.0 C mobo: N/A gpu: radeon temp: 34 C
Fan Speeds (RPM): N/A
Info:
Processes: 164 Uptime: 4h 27m Memory: 3.81 GiB used: 457.2 MiB (11.7%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.32
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

Nothing about the hardware jumps out at me, but let's see whether anyone else has a bright idea.

By the way, given your other thread (didn't recognize the handle), I'm not keen on resetting the desktop unless
this is making you crazy. IMHO, screensaver is dispensable. And no assurance resetting will solve the problem.
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

pbear wrote:
Wed Oct 02, 2019 6:00 pm
Nothing about the hardware jumps out at me, but let's see whether anyone else has a bright idea.

By the way, given your other thread (didn't recognize the handle), I'm not keen on resetting the desktop unless
this is making you crazy. IMHO, screensaver is dispensable. And no assurance resetting will solve the problem.
No, it's no big deal I just thought to ask and see if it can be fixed. What I'm doing now I have it set to sleep instead and it's doing that. Also, I can always set preview the screensaver and that works, no biggie, thanks though for trying :)
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

You're welcome. FWIW, turning off the display is what Cinnamon and XFCE do by default. My understanding is that both groups of developers gave up on screensavers because the compatibility issues had gotten so complicated. I suspect MATE will follow suit eventually (and maybe soon).
Lanser
Level 4
Level 4
Posts: 346
Joined: Mon Mar 08, 2010 5:12 am

Re: ScreenSaver doesn't come on

Post by Lanser »

Have you tried selecting one of the other "screen savers".
Occasionally I have found some of the included options can do strange things (or not activate) depending on the graphic hardware.
Test the simple ones first. "Atlantis" seems to work OK on all the machines I have set up recently.

Lanser
exit stage left
helpmelearn
Level 2
Level 2
Posts: 83
Joined: Tue Oct 01, 2019 3:57 pm

Re: ScreenSaver doesn't come on

Post by helpmelearn »

it's funny just now my screensaver came on and I will later try different ones and see as to what you mention. oh well, that didn't last long now it's off again ...
columbo1977
Level 1
Level 1
Posts: 13
Joined: Fri May 23, 2008 7:54 pm

Re: ScreenSaver doesn't come on

Post by columbo1977 »

Hey

I was wondering if anyone had solved this. I am using Mint 19.1 Tessa on my laptop and having this issue. Instead of the screensaver activating its just a black screen. Even when I use Ctrl+Alt and L to lock.

Cheers

G
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

There's no problem with the screensaver. If you're having trouble, it's somewhere in your hardware and/or configuration.
columbo1977
Level 1
Level 1
Posts: 13
Joined: Fri May 23, 2008 7:54 pm

Re: ScreenSaver doesn't come on

Post by columbo1977 »

Hi

Config is what I would think but i haven't a clue how to work out why this is happening?

Any ideas?

G
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

Yes, read how to get help (sticky at top of page) and open your own thread.
columbo1977
Level 1
Level 1
Posts: 13
Joined: Fri May 23, 2008 7:54 pm

Re: ScreenSaver doesn't come on

Post by columbo1977 »

I will do, although since it's the same problem I thought it would be easier to ask here.
pbear
Level 15
Level 15
Posts: 5664
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: ScreenSaver doesn't come on

Post by pbear »

Read the sticky. Notice Rule 2. Don't skimp on Rule 5.
Post Reply

Return to “Software & Applications”