Cannot install e2guardian

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Cannot install e2guardian

Post by whois1230 » Fri Oct 11, 2019 10:20 am

Hello, I am running Linux Mint 18.3 Cinnamon 64-bit and trying to install e2guardian in order to block p**n. I get the following error: error: dependency is not satisfiable: libevent-pthreads-2.1-6 I executed the following commands:

Code: Select all

user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt install libevent-dev
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libclamav7 libenet7 libjs-jquery-mobile libjson-perl libnunit-cil-dev
  libnunit-console-runner2.6.3-cil libnunit-core-interfaces2.6.3-cil
  libnunit-core2.6.3-cil libnunit-framework2.6.3-cil libnunit-mocks2.6.3-cil
  libnunit-util2.6.3-cil libportmidi0 libsdl2-ttf-2.0-0 libtext-csv-perl
  mess-data supertuxkart-data unhide unhide.rb
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libevent-core-2.0-5 libevent-extra-2.0-5 libevent-openssl-2.0-5
  libevent-pthreads-2.0-5
The following NEW packages will be installed:
  libevent-core-2.0-5 libevent-dev libevent-extra-2.0-5 libevent-openssl-2.0-5
  libevent-pthreads-2.0-5
0 upgraded, 5 newly installed, 0 to remove and 13 not upgraded.
Need to get 349 kB of archives.
After this operation, 1.846 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirror.de.leaseweb.net/ubuntu xenial-updates/main amd64 libevent-core-2.0-5 amd64 2.0.21-stable-2ubuntu0.16.04.1 [70,6 kB]
Get:2 http://mirror.de.leaseweb.net/ubuntu xenial-updates/main amd64 libevent-extra-2.0-5 amd64 2.0.21-stable-2ubuntu0.16.04.1 [51,1 kB]
Get:3 http://mirror.de.leaseweb.net/ubuntu xenial-updates/main amd64 libevent-pthreads-2.0-5 amd64 2.0.21-stable-2ubuntu0.16.04.1 [5.020 B]
Get:4 http://mirror.de.leaseweb.net/ubuntu xenial-updates/main amd64 libevent-openssl-2.0-5 amd64 2.0.21-stable-2ubuntu0.16.04.1 [10,6 kB]
Get:5 http://mirror.de.leaseweb.net/ubuntu xenial-updates/main amd64 libevent-dev amd64 2.0.21-stable-2ubuntu0.16.04.1 [211 kB]
Fetched 349 kB in 0s (1.131 kB/s)     
Selecting previously unselected package libevent-core-2.0-5:amd64.
(Reading database ... 620976 files and directories currently installed.)
Preparing to unpack .../libevent-core-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-extra-2.0-5:amd64.
Preparing to unpack .../libevent-extra-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-extra-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-pthreads-2.0-5:amd64.
Preparing to unpack .../libevent-pthreads-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-pthreads-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-openssl-2.0-5:amd64.
Preparing to unpack .../libevent-openssl-2.0-5_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-openssl-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-dev.
Preparing to unpack .../libevent-dev_2.0.21-stable-2ubuntu0.16.04.1_amd64.deb ...
Unpacking libevent-dev (2.0.21-stable-2ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Setting up libevent-core-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up libevent-extra-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up libevent-pthreads-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up libevent-openssl-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...
Setting up libevent-dev (2.0.21-stable-2ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...

Code: Select all

user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt install libevent1-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libclamav7 libenet7 libevent-core-2.0-5 libevent-extra-2.0-5
  libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libjs-jquery-mobile
  libjson-perl libnunit-cil-dev libnunit-console-runner2.6.3-cil
  libnunit-core-interfaces2.6.3-cil libnunit-core2.6.3-cil
  libnunit-framework2.6.3-cil libnunit-mocks2.6.3-cil libnunit-util2.6.3-cil
  libportmidi0 libsdl2-ttf-2.0-0 libtext-csv-perl mess-data supertuxkart-data
  unhide unhide.rb
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libevent-1.4-2 libevent-core-1.4-2 libevent-extra-1.4-2
The following packages will be REMOVED:
  libevent-dev
The following NEW packages will be installed:
  libevent-1.4-2 libevent-core-1.4-2 libevent-extra-1.4-2 libevent1-dev
0 upgraded, 4 newly installed, 1 to remove and 13 not upgraded.
Need to get 231 kB of archives.
After this operation, 442 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://mirror.de.leaseweb.net/ubuntu xenial/universe amd64 libevent-1.4-2 amd64 1.4.14b-stable-0ubuntu1 [53,8 kB]
Get:2 http://mirror.de.leaseweb.net/ubuntu xenial/universe amd64 libevent-core-1.4-2 amd64 1.4.14b-stable-0ubuntu1 [24,6 kB]
Get:3 http://mirror.de.leaseweb.net/ubuntu xenial/universe amd64 libevent-extra-1.4-2 amd64 1.4.14b-stable-0ubuntu1 [41,6 kB]
Get:4 http://mirror.de.leaseweb.net/ubuntu xenial/universe amd64 libevent1-dev amd64 1.4.14b-stable-0ubuntu1 [111 kB]
Fetched 231 kB in 0s (722 kB/s)        
(Reading database ... 621052 files and directories currently installed.)
Removing libevent-dev (2.0.21-stable-2ubuntu0.16.04.1) ...
Selecting previously unselected package libevent-1.4-2.
(Reading database ... 620996 files and directories currently installed.)
Preparing to unpack .../libevent-1.4-2_1.4.14b-stable-0ubuntu1_amd64.deb ...
Unpacking libevent-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Selecting previously unselected package libevent-core-1.4-2.
Preparing to unpack .../libevent-core-1.4-2_1.4.14b-stable-0ubuntu1_amd64.deb ...
Unpacking libevent-core-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Selecting previously unselected package libevent-extra-1.4-2.
Preparing to unpack .../libevent-extra-1.4-2_1.4.14b-stable-0ubuntu1_amd64.deb ...
Unpacking libevent-extra-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Selecting previously unselected package libevent1-dev.
Preparing to unpack .../libevent1-dev_1.4.14b-stable-0ubuntu1_amd64.deb ...
Unpacking libevent1-dev (1.4.14b-stable-0ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libevent-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Setting up libevent-core-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Setting up libevent-extra-1.4-2 (1.4.14b-stable-0ubuntu1) ...
Setting up libevent1-dev (1.4.14b-stable-0ubuntu1) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt install libevent-2.1-6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libevent-2.1-6
E: Couldn't find any package by glob 'libevent-2.1-6'
E: Couldn't find any package by regex 'libevent-2.1-6'

Code: Select all

user@user-Lenovo-ideapad-110-17IKB ~ $ su
Password: 
user-Lenovo-ideapad-110-17IKB user # apt install libevent-2.1-6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libevent-2.1-6
E: Couldn't find any package by glob 'libevent-2.1-6'
E: Couldn't find any package by regex 'libevent-2.1-6'
user-Lenovo-ideapad-110-17IKB user # exit
exit

Code: Select all

user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt update
Ign:1 http://mirror.netcologne.de/linuxmint/packages sylvia InRelease
Hit:2 http://ppa.launchpad.net/git-core/ppa/ubuntu xenial InRelease            
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:4 http://mirror.netcologne.de/linuxmint/packages sylvia Release            
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:6 http://mirror.de.leaseweb.net/ubuntu xenial InRelease                    
Hit:7 http://mirror.de.leaseweb.net/ubuntu xenial-updates InRelease            
Hit:8 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:9 http://mirror.de.leaseweb.net/ubuntu xenial-backports InRelease          
Hit:10 http://archive.canonical.com/ubuntu xenial InRelease              
Hit:12 https://repo.skype.com/deb stable InRelease 
Hit:13 https://download.mono-project.com/repo/ubuntu stable-xenial InRelease
Hit:14 https://download.mono-project.com/repo/ubuntu vs-xenial InRelease
Reading package lists... Done 
Building dependency tree       
Reading state information... Done
13 packages can be upgraded. Run 'apt list --upgradable' to see them.

Code: Select all

user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libclamav7 libenet7 libevent-core-2.0-5 libevent-extra-2.0-5
  libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libjs-jquery-mobile
  libjson-perl libnunit-cil-dev libnunit-console-runner2.6.3-cil
  libnunit-core-interfaces2.6.3-cil libnunit-core2.6.3-cil
  libnunit-framework2.6.3-cil libnunit-mocks2.6.3-cil libnunit-util2.6.3-cil
  libportmidi0 libsdl2-ttf-2.0-0 libtext-csv-perl mess-data supertuxkart-data
  unhide unhide.rb
Use 'sudo apt autoremove' to remove them.
The following packages will be upgraded:
  google-chrome-stable idle-python3.5 libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  python2.7 python2.7-minimal python3.5 python3.5-minimal skypeforlinux
13 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 151 MB of archives.
After this operation, 639 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 77.0.3865.120-1 [61,1 MB]
Get:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5 amd64 3.5.2-2ubuntu0~16.04.9 [1.360 kB]
Get:3 https://repo.skype.com/deb stable/main amd64 skypeforlinux amd64 8.53.0.85 [79,2 MB]
Get:4 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5-minimal amd64 3.5.2-2ubuntu0~16.04.9 [524 kB]
Get:5 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython3.5-stdlib amd64 3.5.2-2ubuntu0~16.04.9 [2.137 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 python3.5-minimal amd64 3.5.2-2ubuntu0~16.04.9 [1.593 kB]
Get:7 http://security.ubuntu.com/ubuntu xenial-security/main amd64 python3.5 amd64 3.5.2-2ubuntu0~16.04.9 [165 kB]
Get:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython2.7 amd64 2.7.12-1ubuntu0~16.04.9 [1.070 kB]
Get:9 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython2.7-minimal amd64 2.7.12-1ubuntu0~16.04.9 [338 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libpython2.7-stdlib amd64 2.7.12-1ubuntu0~16.04.9 [1.884 kB]
Get:11 http://security.ubuntu.com/ubuntu xenial-security/main amd64 python2.7-minimal amd64 2.7.12-1ubuntu0~16.04.9 [1.262 kB]
Get:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 python2.7 amd64 2.7.12-1ubuntu0~16.04.9 [224 kB]
Get:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 idle-python3.5 all 3.5.2-2ubuntu0~16.04.9 [39,4 kB]
Fetched 151 MB in 2min 50s (884 kB/s)                                          
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../libpython3.5_3.5.2-2ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython3.5:amd64 (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Preparing to unpack .../libpython3.5-minimal_3.5.2-2ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython3.5-minimal:amd64 (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Setting up libpython3.5-minimal:amd64 (3.5.2-2ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../libpython3.5-stdlib_3.5.2-2ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython3.5-stdlib:amd64 (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Setting up libpython3.5-stdlib:amd64 (3.5.2-2ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../python3.5-minimal_3.5.2-2ubuntu0~16.04.9_amd64.deb ...
Unpacking python3.5-minimal (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python3.5-minimal (3.5.2-2ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../python3.5_3.5.2-2ubuntu0~16.04.9_amd64.deb ...
Unpacking python3.5 (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python3.5 (3.5.2-2ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../libpython2.7_2.7.12-1ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.8) ...
Preparing to unpack .../libpython2.7-minimal_2.7.12-1ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.8) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Setting up libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../libpython2.7-stdlib_2.7.12-1ubuntu0~16.04.9_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.8) ...
Setting up libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../python2.7-minimal_2.7.12-1ubuntu0~16.04.9_amd64.deb ...
Unpacking python2.7-minimal (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.8) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python2.7-minimal (2.7.12-1ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../python2.7_2.7.12-1ubuntu0~16.04.9_amd64.deb ...
Unpacking python2.7 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.8) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python2.7 (2.7.12-1ubuntu0~16.04.9) ...
(Reading database ... 621034 files and directories currently installed.)
Preparing to unpack .../google-chrome-stable_77.0.3865.120-1_amd64.deb ...
Unpacking google-chrome-stable (77.0.3865.120-1) over (77.0.3865.90-1) ...
Preparing to unpack .../idle-python3.5_3.5.2-2ubuntu0~16.04.9_all.deb ...
Unpacking idle-python3.5 (3.5.2-2ubuntu0~16.04.9) over (3.5.2-2ubuntu0~16.04.8) ...
Preparing to unpack .../skypeforlinux_8.53.0.85_amd64.deb ...
Unpacking skypeforlinux (8.53.0.85) over (8.52.0.138) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1.1) ...
Setting up libpython3.5:amd64 (3.5.2-2ubuntu0~16.04.9) ...
Setting up libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.9) ...
Setting up google-chrome-stable (77.0.3865.120-1) ...
Setting up idle-python3.5 (3.5.2-2ubuntu0~16.04.9) ...
Setting up skypeforlinux (8.53.0.85) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
user@user-Lenovo-ideapad-110-17IKB ~ $ sudo apt install libevent-2.1-6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libevent-2.1-6
E: Couldn't find any package by glob 'libevent-2.1-6'
E: Couldn't find any package by regex 'libevent-2.1-6'
Last edited by karlchen on Fri Oct 11, 2019 3:23 pm, edited 1 time in total.
Reason: split the single gigantic code clock into separate code block to make reading easier

User avatar
karlchen
Level 20
Level 20
Posts: 11408
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Cannot install e2guardian

Post by karlchen » Fri Oct 11, 2019 3:44 pm

Hello, whois1230.

Am I right in assuming that e2guardian is not available in the Ubuntu 16.04 software repositories (Mint 18.x is based on Ubuntu 16.04)?
Either you are trying to install the e2guardian software packages for Ubuntu 18.04. Trying to do so might lead to dependency problems, such as the libevent-2-1.6, which cannot be found, because Ubuntu 16.04 only offers libevent-2-0.5.
Or you have tried to follow the e2guardian installation instructions on Github, but not correctly maybe.

Regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Re: Cannot install e2guardian

Post by whois1230 » Fri Oct 18, 2019 11:07 am

karlchen wrote:
Fri Oct 11, 2019 3:44 pm
Hello, whois1230.

Am I right in assuming that e2guardian is not available in the Ubuntu 16.04 software repositories (Mint 18.x is based on Ubuntu 16.04)?
Either you are trying to install the e2guardian software packages for Ubuntu 18.04. Trying to do so might lead to dependency problems, such as the libevent-2-1.6, which cannot be found, because Ubuntu 16.04 only offers libevent-2-0.5.
Or you have tried to follow the e2guardian installation instructions on Github, but not correctly maybe.

Regards,
Karl
Hello, I tried to install version 5.3.2 as well and got error: dependency is not satisfiable: libtommath1

User avatar
Flemur
Level 17
Level 17
Posts: 7318
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Cannot install e2guardian

Post by Flemur » Fri Oct 18, 2019 11:21 am

karlchen wrote:
Fri Oct 11, 2019 3:44 pm
Am I right in assuming that e2guardian is not available in the Ubuntu 16.04 software repositories (Mint 18.x is based on Ubuntu 16.04)?
It's not in my Mint 18.3 repos. FWIW, .deb files are here:
https://gitlab.com/fredbcode/e2guardian/tree/packages/
It doesn't seem to say which versions of Ubuntu it's supposed to run on; I tried the 5.3.3. version w/Mint18.3 and got:

Code: Select all

...Unpacking e2guardian (5.3.3) ...
dpkg: dependency problems prevent configuration of e2guardian:
 e2guardian depends on libevent-pthreads-2.1-6; however:
  Package libevent-pthreads-2.1-6 is not installed.
 e2guardian depends on libtommath1; however:
  Package libtommath1 is not installed.
 e2guardian depends on libssl1.1; however:
  Package libssl1.1 is not installed.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

Post Reply

Return to “Software & Applications”