Page 1 of 1

Problem defaulting to Thunderbird solved

Posted: Thu Oct 17, 2019 9:18 am
by stevengarland
I am using the latest version of Mint Cinnamon

Until recently my email defaulted to Thunderbird with no problem. Now it has started to default to Xfinity which is my ISP. I checked system settings and saw that the default showed Google. Either this was changed recently by the gremlins or the TB default worked regardless. I changed the default to Thunderbird and did a restart.
Unfortunately things still default to Xfinity?????

Ideas?

Thanks

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 10:17 am
by gittiest personITW
Hi,
What exactly defaults to Xfinity?

Also, for your own sake, stop leaking data (if it is as you have written).
For instance, (if it is as you have written), anyone can see your name, ISP, the state you live, and probably there are other places (idiotbook/twitter etc) where anyone who gave a toss could match it to you. Just a friendly heads up.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 12:16 pm
by stevengarland
I am not on any social media.

On sites that I use there is often an opportunity to contact them by email. In the past when I clicked on the email address it would come up as a "write" on Thunderbird mail, now it defaults to the ISP sign in site.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 12:47 pm
by gittiest personITW
Ok,

Firstly, try, in Thunderbird,
Edit
Preferencees
Advanced
System Integration - Tick 'Always check to see if Thunderbird is your default email client on startup'
Check now

If that doesn't work, post back.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 1:48 pm
by stevengarland
Ok. I checked and Thunderbird was and is set as my default. I had't checked off the "always check" box before as it is an irritation, but now it is checked. Didn't yield any new results on the default issue.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 2:16 pm
by ajgreeny
In what application are the links that you now click on and they open Xfinity?

It sounds to me as though it may be a configuration setting in that application (eg, firefox, chromium?).
What do you see if you right click on one those links instead of left clicking?

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 2:25 pm
by gittiest personITW
Try a reboot and see if it is ok.
Also, what browser do you use?
In Firefox, for instance, you can choose where to point 'mailto'.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 6:40 pm
by stevengarland
I am using, and always have used, Chrome.

Why would something that was set up correctly all along be solved by a restart? I have now done two restarts with no change on the problem.

Re: Problem defaulting to Thunderbird

Posted: Thu Oct 17, 2019 10:51 pm
by Spearmint2
You using a wifi hotspot, or a router?

Re: Problem defaulting to Thunderbird

Posted: Fri Oct 18, 2019 8:53 am
by stevengarland
I have a wired connection to my modem

Re: Problem defaulting to Thunderbird

Posted: Fri Oct 18, 2019 9:18 am
by gittiest personITW
stevengarland wrote:
Thu Oct 17, 2019 6:40 pm

Why would something that was set up correctly all along be solved by a restart? I have now done two restarts with no change on the problem.
Maybe there was a Chrome udate? Maybe a setting was changed by an itchy finger? Who knows?
Go into Chrome and see if you can find a setting that relates to 'mailto'.

Re: Problem defaulting to Thunderbird

Posted: Fri Oct 18, 2019 9:45 am
by stevengarland
gittiest,

That last one was a good idea. Indeed "Handlers" had been taken over by my ISP. I removed the ISP reference and now the default is to Thunderbird.

Than you!

Re: Problem defaulting to Thunderbird

Posted: Fri Oct 18, 2019 9:47 am
by stevengarland
solved

Re: Problem defaulting to Thunderbird

Posted: Fri Oct 18, 2019 9:48 am
by gittiest personITW
Cool.