I can't install anything on Mint 19.1

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
karolyn
Level 1
Level 1
Posts: 2
Joined: Thu Oct 17, 2019 3:39 pm

I can't install anything on Mint 19.1

Post by karolyn » Thu Oct 17, 2019 4:00 pm

Hi. Before going into the topic I must say I'm not a programmer, software developer or anything like that, I only switched to Linux because it uses less resources and also I don't want to install Windows 10 so I'm not really familiar with this kind of errors...

It started when I tried to install VLC to play some music, I did the usual thing for me that's open a terminal window, enter "sudo apt-get install vlc" my password and then it should download and install automatically, well that doesn't occurs anymore, instead I get this weird message saying I should run "apt --fix-broken install" because the following packages have unmet dependencies and it lists some packages

linux-image-generic: depends: linux-image-4.15.0-64-generic but it's not going to be installed
linux-modules-extra-4.15.0-58-generic depends linux-image-4.15.0-58-generic or linux-image-unsigned-4.15.0-58-generic but it's not installable
vlc: Here it lists a bunch of packages related to VLC saying they can't be installed
E: unmet dependencies, Try "apt --fix-broken install" without packages or specify a solution

The obvious way to go was to try that fix broken install command but instead of doing something it simply shows the apt help, also "--fix-broken install" isn't listed as a valid apt command. This happens with anything I try to install not just VLC. Is there something I can do or I'll need to reinstall everything again just like when Windows breaks?

OS: Mint 19.1 32 bits
Memory: 2 GB

User avatar
karlchen
Level 20
Level 20
Posts: 11428
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: I can't install anything on Mint 19.1

Post by karlchen » Thu Oct 17, 2019 4:04 pm

Hello, Karolyn.

Please, try the command sudo apt-get --fix-broken install This should work.

Regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

karolyn
Level 1
Level 1
Posts: 2
Joined: Thu Oct 17, 2019 3:39 pm

Re: I can't install anything on Mint 19.1

Post by karolyn » Thu Oct 17, 2019 10:32 pm

karlchen wrote:
Thu Oct 17, 2019 4:04 pm
Hello, Karolyn.

Please, try the command sudo apt-get --fix-broken install This should work.

Regards,
Karl
Hello Karl. Thanks for the reply, I've tried that command and it returns:

Code: Select all

dpkg: error processing file /var/cache/apt/archives/linux-modules-4.15.0-65-generic_4.15.0-65.74_i386.deb (--unpack): 
could not copy data extracted from './boot/vmlinuz-4.15.0-64-generic' to '/boot/vmlinuz-4.15.0-64-generic.dpkg-new': write error
 (No space left on device)
dpkg-deb: error: copy subprocess was killed by signal (Broken pipe)
The same set of errors go for the rest of the packages labeled as broken:

Code: Select all

/var/cache/apt/archives/linux-image-4.15.0-65-generic_4.15.0-65.74_i386.deb
/var/cache/apt/archives/linux-modules-4.15.0-64-generic_4.15.0-64.73_i386.deb
/var/cache/apt/archives/linux-image-4.15.0-64-generic_4.15.0-64.73_i386.deb
There's 95% of free space on the hard drive (4TB)
I have SU access

User avatar
karlchen
Level 20
Level 20
Posts: 11428
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: I can't install anything on Mint 19.1

Post by karlchen » Fri Oct 18, 2019 6:53 am

Hi, karolyn.

Should have very likely spotted this part of the error message in your previous post also: (No space left on device)
This means,
+ if /boot is on a separate filesystem then it is full. No space left to write anything.
+ if /boot is on the root filesystem /, then the root filesystem is full. No space left to write anything.

Please, post the output of the terminal command df -h | grep "^/dev/". This will tell us which filesystem is full, /boot or /. Knowing so will help us point you to the right way of resolving the root cause.

Regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Post Reply

Return to “Software & Applications”