Audio qjackctl does not start

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

I was about to make a new suggestion then saw trytip pointed to a place with similar stuff. Here's what I'd try to see if it helps to disable pulseaudio:

1. Reboot so we're starting fresh
2. Run pasuspender -- qjackctl & in the terminal (if that fails try pasuspender -- /usr/bin/qjackctl & instead)
3. Click on Start in qjackctl
4. Run sonic-pi

PulseAudio should restart when closing qjackctl.

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Wed Nov 27, 2019 7:10 pm
I was about to make a new suggestion then saw trytip pointed to a place with similar stuff. Here's what I'd try to see if it helps to disable pulseaudio:

1. Reboot so we're starting fresh
2. Run pasuspender -- qjackctl & in the terminal (if that fails try pasuspender -- /usr/bin/qjackctl & instead)
3. Click on Start in qjackctl
4. Run sonic-pi

PulseAudio should restart when closing qjackctl.

Code: Select all

pasuspender -- qjackctl
does start the qjackctl and the messages of qjackctl are normal, as they should be. I an the member of the group audio.
Running SP doesnt work.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Wed Nov 27, 2019 5:08 pm
Let's see the output of cat ~/.jackdrc

That Patchbay deactivated seems very suspicious as I don't get that line. I do not have Activate Patchbay persistance checked in Setup > Options tab > Connections. If you do, try un-checking that.

Code: Select all

cat ~/.jackdrc 
/usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic
Connect screen looks like this after I start SP
connections.png
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Sat Nov 23, 2019 4:01 pm
One last test if you still have it installed. Run apt install swh-plugins, then start QJackCtl, then run sonic-pi.

This line made me think of that:

Code: Select all

Found 0 LADSPA plugins
swh-plugins is already installed.

The qjackctl messages now are

Code: Select all

09:27:29.759 Statistics reset.
09:27:29.835 ALSA connection change.
09:27:29.856 JACK is starting...
09:27:29.857 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
09:27:30.008 JACK was started with PID=7749.
no message buffer overruns
no message buffer overruns
no message buffer overruns
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio1
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:Generic|1024|2|44100|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
09:27:32.163 JACK connection change.
09:27:32.164 Server configuration saved to "/home/uma/.jackdrc".
09:27:32.165 Statistics reset.
09:27:32.171 Client activated.
09:27:32.172 Patchbay deactivated.
09:27:32.281 JACK connection graph change.
09:28:29.199 JACK connection graph change.
09:28:31.198 JACK connection graph change.
09:28:31.272 JACK connection change.
09:29:01.224 JACK connection graph change.
09:29:01.414 JACK connection change.
09:33:42.622 JACK connection graph change.
09:33:42.949 JACK connection graph change.
09:33:43.022 JACK connection change.
09:34:12.977 JACK connection graph change.
09:34:13.164 JACK connection change.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Does aplay -l return something similar to this:

Code: Select all

card 0: Generic [HD-Audio Generic], device 0: ALC221 Analog [ALC221 Analog]
I know the ALC number will probably be different. The important part is where mine says Generic. If yours also says Generic in that position, see if starting the jack daemon this way makes any difference:

Code: Select all

/usr/bin/jackd -dalsa -dhw:Generic -r44100 -p1024 -n2
To be clear, you'll not be pressing Start in qjackctl, which for you is calling /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic.

I don't know enough about jackd options, but I'm thinking yours might be messed up. If the command I gave fails try it this way instead:

Code: Select all

/usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2
Or alternatively, with whatever name was discovered from the aplay output like this:

Code: Select all

/usr/bin/jackd -dalsa -dhw:NameReturnedFromAplayImmediatelyAfterTheFirstColon -r44100 -p1024 -n2
If that successfully starts a daemon, you can then open qjackctl without clicking on anything in it, then run sonic-pi

I'm not really expecting that to work, but that's how my working config does things so thought it would be worth trying.

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

You can see information about qjackctl with

Code: Select all

man qjackctl
. I have run the commands as per your instructions.

Code: Select all

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC3227 Analog [ALC3227 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
(base) uma@mint-18-uma ~ $ jackd --help
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns

Usage: jackdmp [ --no-realtime OR -r ]
               [ --realtime OR -R [ --realtime-priority OR -P priority ] ]
      (the two previous arguments are mutually exclusive. The default is --realtime)
               [ --name OR -n server-name ]
               [ --timeout OR -t client-timeout-in-msecs ]
               [ --loopback OR -L loopback-port-number ]
               [ --port-max OR -p maximum-number-of-ports]
               [ --slave-backend OR -X slave-backend-name ]
               [ --internal-client OR -I internal-client-name ]
               [ --internal-session-file OR -C internal-session-file ]
               [ --verbose OR -v ]
               [ --clocksource OR -c [ h(pet) | s(ystem) ]
               [ --autoconnect OR -a <modechar>]
                 where <modechar> is one of:
                   ' ' - Don't restrict self connect requests (default)
                   'E' - Fail self connect requests to external ports only
                   'e' - Ignore self connect requests to external ports only
                   'A' - Fail all self connect requests
                   'a' - Ignore all self connect requests
               [ --replace-registry ]
               [ --silent OR -s ]
               [ --sync OR -S ]
               [ --temporary OR -T ]
               [ --version OR -V ]
         -d master-backend-name [ ... master-backend args ... ]
       jackdmp -d master-backend-name --help
             to display options for each master backend

Available backends:
      alsarawmidi (slave)
      dummy (master)
      netone (master)
      firewire (master)
      net (master)
      loopback (slave)
      alsa (master)

Available internals:
      netadapter
      profiler
      netmanager
      audioadapter
      
      qjackctl --help
Usage: qjackctl [options] [command-and-args]

QjackCtl - JACK Audio Connection Kit - Qt GUI Interface

Options:

  -s, --start
	Start JACK audio server immediately

  -p, --preset=[label]
	Set default settings preset name

  -a, --active-patchbay=[path]
	Set active patchbay definition file

  -n, --server-name=[label]
	Set default JACK audio server name

  -h, --help
	Show help about command line options

  -v, --version

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

I also observed that when qjackctl is started, sometimes the status is active and sometimes it shows as started, especially after first time after freshly booting the system.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

deepakdeshp wrote:
Thu Nov 28, 2019 12:09 am
Connect screen looks like this after I start SP
Image
your readable clients don't look right, your jackaudio is missing components. test it with smplayer >>> in smplayer options change audio output to jack, start jackaudio then play a video or audio, now you should see mplayer or mpv depending on what you use with smplayer.

Image

Image
Image

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

Code: Select all

aplay -l
lists 2 devices in my case is it the same with everybody? May be that requires some configuration.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

don't know, can you reproduce my post above?
Image

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

trytip wrote:
Thu Nov 28, 2019 12:41 pm
don't know, can you reproduce my post above?
I dont have smplayer installed, and I dont want to install it or any software I dont use if possible . Is it possible to do this test with some other player?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

vlc, audacious, even audacity
Image

User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Are you playing sound through HDMI? Because that's what you've asked jack to do via qjackctl settings with hw:0.

If the answer to the above is no, change hw:0 to hw:1 or hw:Generic

Names are often better than numbers because they won't change. On some systems, the card order can change after rebooting. This may be your issue. When you began, card 0 may have been Generic, and card 1 was HDMI. But now they're reversed.

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

No, I dont play sound through HDMI. Either through built in speakers or Blue tooth speakers. in qjackctl the option is already hw:generic or hw:1
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

deepakdeshp wrote:
Thu Nov 28, 2019 12:09 am

Code: Select all

cat ~/.jackdrc 
/usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -D -Chw:Generic
Connect screen looks like this after I start SP
That says otherwise. The first occurance of hw:

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

config.png
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Do the same for Output Device

User avatar
MrEen
Level 19
Level 19
Posts: 9578
Joined: Mon Jun 12, 2017 8:39 pm

Re: Audio qjackctl does not start

Post by MrEen »

Better yet, go to the Parameters tab and change Interface there to hw:Generic

User avatar
trytip
Level 13
Level 13
Posts: 4679
Joined: Tue Jul 05, 2016 1:20 pm

Re: Audio qjackctl does not start

Post by trytip »

we need to see your drop down selections for output/input in qjackctl.
i use this, but really annoyed that i can't see the whole output window since the theme cuts it off
Image
Image

deepakdeshp
Level 17
Level 17
Posts: 7516
Joined: Sun Aug 09, 2015 10:00 am

Re: Audio qjackctl does not start

Post by deepakdeshp »

MrEen wrote:
Thu Nov 28, 2019 1:28 pm
Better yet, go to the Parameters tab and change Interface there to hw:Generic
It wass there in advanced tab. There is no such option in parameters tab
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Software & Applications”